From: Carl Phelan (carlphelan@xxxxxxxxxxx)
Date: Mon Feb 18 2002 - 11:26:01 GMT-3
Hi All,
Redistribution problem - R2 runs OSPF area 0 and IRGP. I cannot get the
following network to summarize to a /24 bit mask for redistribution into IGRP
on R4- the address is 137.7.8.1/22 and is directly connected to E0. 'Area 0
range...' cannot be used in the backbone - doesn't work anyway and the command
'summary-address 137.7.8.0 255.255.255.0' creates a null 0 path in the routing
table and the neigboring IGRP router although sees the route, pings null0 i.e.
unreachable. This null path has now mysteriously disapeared.
Also the lab requires RIP routes advertised on R1 to be summarised for
redistribution into OSPF which I have done as follows : 'summary-address
192.190.100.0 255.255.248.0' which corrects itself to 192.190.92.0/22 as
required. I have mutually redistributed RIP and OSPF on R1 as required and
although the other routers see the routes they cannot ping any of them: the
160.100.x.x or the 192.100.x.x and the 192.100 summary route appears as null0
on R1.
One more thing, Solie does not specify how loopbacks are to be advertised yet
expects reachability. How should these loopbacks be advertised - by OSPF if
it exists on the router and in which area if two or more exist? Configs as
below:
Many thanks for your advice.
r1# sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0001.0001.0001
!
!
!
interface Loopback0
ip address 137.7.1.1 255.255.255.0
no ip directed-broadcast
ipx network 1
!
interface Ethernet0
ip address 160.100.2.1 255.255.255.0
no ip directed-broadcast
ipx network 2
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
bandwidth 64
ip address 137.7.20.3 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
ip ospf priority 0
logging event subif-link-status
logging event dlci-status-change
no arp frame-relay
frame-relay map ip 137.7.20.1 141 broadcast
frame-relay map ip 137.7.20.2 141 broadcast
no frame-relay inverse-arp
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
summary-address 192.190.96.0 255.255.248.0
redistribute rip metric 20 subnets route-map rip-into-ospf
network 137.7.20.3 0.0.0.0 area 10
!
router rip
redistribute ospf 1 route-map ospf-into-rip
network 160.100.0.0
default-metric 6
no auto-summary
!
ip classless
!
access-list 1 permit 192.0.0.0 0.255.255.255
access-list 1 permit 160.100.0.0 0.0.255.255
access-list 2 deny 192.0.0.0 0.255.255.255
access-list 2 deny 160.100.0.0 0.0.255.255
!
!
!
route-map rip-into-ospf permit 10
match ip address 1
!
route-map ospf-into-rip permit 10
match ip address 2
!
route-map ospf-into-rip permit 20
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
r1# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
137.7.0.0/16 is variably subnetted, 8 subnets, 2 masks
O IA 137.7.14.0/24 [110/3134] via 137.7.20.1, 00:12:39, Serial1
O IA 137.7.11.0/24 [110/1572] via 137.7.20.2, 00:12:39, Serial1
O IA 137.7.8.0/22 [110/1572] via 137.7.20.1, 00:12:39, Serial1
O E2 137.7.4.0/24 [110/20] via 137.7.20.1, 00:12:39, Serial1
C 137.7.1.0/24 is directly connected, Loopback0
O IA 137.7.30.0/24 [110/1563] via 137.7.20.1, 00:12:40, Serial1
C 137.7.20.0/24 is directly connected, Serial1
O E2 137.7.77.0/24 [110/20] via 137.7.20.1, 00:12:40, Serial1
160.100.0.0/24 is subnetted, 5 subnets
R 160.100.128.0 [120/1] via 160.100.2.254, 00:00:13, Ethernet0
R 160.100.129.0 [120/1] via 160.100.2.254, 00:00:14, Ethernet0
R 160.100.130.0 [120/1] via 160.100.2.254, 00:00:14, Ethernet0
R 160.100.100.0 [120/1] via 160.100.2.254, 00:00:14, Ethernet0
C 160.100.2.0 is directly connected, Ethernet0
R 192.190.102.0/24 [120/1] via 160.100.2.254, 00:00:15, Ethernet0
R 192.190.100.0/24 [120/1] via 160.100.2.254, 00:00:15, Ethernet0
R 192.190.101.0/24 [120/1] via 160.100.2.254, 00:00:15, Ethernet0
O 192.190.96.0/21 is a summary, 00:11:02, Null0
r2#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0002.0002.0002
isdn switch-type basic-net3
!
!
!
interface Loopback0
ip address 137.7.2.2 255.255.255.0
no ip directed-broadcast
ipx network 2
!
interface Ethernet0
ip address 137.7.8.1 255.255.252.0
no ip directed-broadcast
ip ospf network broadcast
ipx network 8
!
interface Serial0
ip address 137.7.25.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
ip address 137.7.14.2 255.255.255.0
no ip directed-broadcast
isdn switch-type basic-net3
!
router ospf 1
summary-address 137.7.8.0 255.255.255.0
redistribute igrp 10 subnets route-map igrp-redistrib
network 137.7.8.1 0.0.0.0 area 0
network 137.7.14.2 0.0.0.0 area 100
!
router igrp 10
timers basic 5 15 30 50
redistribute ospf 1 metric 64000 100 255 1 1500 route-map ospf-redistrib
passive-interface BRI0
passive-interface Ethernet0
passive-interface Loopback0
network 137.7.0.0
!
ip classless
!
access-list 1 permit 137.7.77.0 0.0.0.255
access-list 1 permit 137.7.4.0 0.0.0.255
access-list 2 deny 137.7.77.0 0.0.0.255
access-list 2 deny 137.7.4.0 0.0.0.255
access-list 2 permit any
!
!
!
route-map ospf-redistrib permit 10
match ip address 2
!
route-map igrp-redistrib permit 10
match ip address 1
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
r2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
137.7.0.0/16 is variably subnetted, 9 subnets, 2 masks
C 137.7.14.0/24 is directly connected, BRI0
O IA 137.7.11.0/24 [110/84] via 137.7.8.2, 00:48:33, Ethernet0
C 137.7.8.0/22 is directly connected, Ethernet0
I 137.7.4.0/24 [100/8976] via 137.7.25.1, 00:00:01, Serial0
C 137.7.2.0/24 is directly connected, Loopback0
O IA 137.7.30.0/24 [110/11] via 137.7.8.2, 00:48:33, Ethernet0
C 137.7.25.0/24 is directly connected, Serial0
O IA 137.7.20.0/24 [110/74] via 137.7.8.2, 00:48:33, Ethernet0
I 137.7.77.0/24 [100/8576] via 137.7.25.1, 00:00:01, Serial0
160.100.0.0/24 is subnetted, 5 subnets
O E2 160.100.128.0 [110/20] via 137.7.8.2, 00:48:33, Ethernet0
O E2 160.100.129.0 [110/20] via 137.7.8.2, 00:48:34, Ethernet0
O E2 160.100.130.0 [110/20] via 137.7.8.2, 00:48:34, Ethernet0
O E2 160.100.100.0 [110/20] via 137.7.8.2, 00:48:35, Ethernet0
O E2 160.100.2.0 [110/20] via 137.7.8.2, 00:48:35, Ethernet0
O E2 192.190.96.0/21 [110/20] via 137.7.8.2, 00:13:50, Ethernet0
r4#
r4#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0004.0004.0004
!
!
!
interface Loopback0
ip address 137.7.4.4 255.255.255.0
no ip directed-broadcast
ipx network 4
!
interface Ethernet0
ip address 137.7.77.1 255.255.255.0
no ip directed-broadcast
ipx network 77
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
ip address 137.7.25.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Virtual-TokenRing0
ip address 10.10.10.1 255.255.255.240
no ip directed-broadcast
ipx network 10
ring-speed 16
!
router igrp 10
timers basic 5 15 30 50
network 137.7.0.0
!
ip classless
!
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
r4#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
137.7.0.0/24 is subnetted, 8 subnets
I 137.7.14.0 [100/160250] via 137.7.25.2, 00:00:03, Serial1
I 137.7.11.0 [100/8576] via 137.7.25.2, 00:00:03, Serial1
C 137.7.4.0 is directly connected, Loopback0
I 137.7.2.0 [100/8976] via 137.7.25.2, 00:00:03, Serial1
I 137.7.30.0 [100/8576] via 137.7.25.2, 00:00:03, Serial1
C 137.7.25.0 is directly connected, Serial1
I 137.7.20.0 [100/8576] via 137.7.25.2, 00:00:03, Serial1
C 137.7.77.0 is directly connected, Ethernet0
I 160.100.0.0/16 [100/8576] via 137.7.25.2, 00:00:03, Serial1
10.0.0.0/28 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Virtual-TokenRing0
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:26 GMT-3