From: Chris Hugo (chrishugo@xxxxxxxxx)
Date: Sat Feb 16 2002 - 11:33:22 GMT-3
Hi Ahmed,
I have a couple of questions listed:
A. What if we have a scenario with a SERIAL line between (r1 and 0) and (r2 and
1). Can we make this work instead of using ethernet between (r1 and 0) and (
r2 and 1)? I believe this is the topology Ying has.
Scenrio # 3
r1---(s)---(0)ra(dlsw)------(dlsw)rb(0)---(s)---r2
.B. Why do we have to use even numbers in our RSAP and LSAP statements?
C. On scenario 2 can you list specifically the commands of r1,r2,r3,0, and 1. h
eading before the config would be great. Is it correct for me to say theirs no
dlsw here ? Just translational bridging.
I am also a little confused on the logical topology and which routers have whic
h interfaces on SCENARIO 2.
Thanx again for your help,
chris hugo
Ahmed Mamoor Amimi <mamoor@ieee.org> wrote: Sorry guys for posting this confi
gs and tested results for DSPU from UP and
DOWN.
Here are some pointers which everyone who had tried and failed to configure
including me are these... i also over looked and anyone who have posted
before with tested result they also.
1- When configuring RSAP and LSAP dont use ODD # like 1,3,5,7... use 2,4,6
2- In scenrio 1 i used simple bridging and there is nothing to do with
bit-swapping
3- In scenrio 2 i used bridging b/w TR and ether so i needed bit-swap. BUT
REMEMBER THAT BITSWAP COMMAND IS FOR LAYER 3.... YES LAYER THREE. It will
not benefit in this SNA
enviroment so when giving RMACs i bit-swapped there... from 7<->e and 4<->2
4- In scenerio 3 i used dlsw+ between Ra and Rb and bridge on there
ethernet.Now REMEMBER DLSW ALWAYS USED MAC-ADDRESS FORMAT LIKE TOKEN-RING
THAT IS CONNONICAL. So there are ethernets and when i use RMAC without bit
swap then it will not work as DLSW RULZ. So
i bitswapped and WOW it works... In the archieves they have tested it so
that they always have TR on ends so it works but it will not work if ether.
5- DLSW will not preserve VLAN property... bridge do. In my scenrio 1 and 2
when i do diff vlan i dont work as i was working on one 5000 switch so that
was the only way to seperate, when i use direct cross-overs it works and in
DLSW both ethernets are from different VLANS and are working nicely as the
DLSW CIRCUIT
is showing.
for ur convinence i have made BATCH commands just built the scenerio as
under and copy and paste it to console and u will know everything in a min.
Scenrio # 1
r1(0)---(e)----0(bridge)1----(e)---(0)r2
R1 :
conf t
dspu pu TEST rmac 4444.4444.4444 rsap 4 lsap 4
int e0
mac-address 2222.2222.2222
dspu enable-pu lsap 4
dspu start TEST
exit
R2 :
conf t
dspu host TEST rmac 2222.2222.2222 rsap 4 lsap 4
int e0
mac-address 4444.4444.4444
dspu enable-host lsap 4
dspu start TEST
exit
Scenrio # 2
r1(0)----(e)---0(bridge)1-----(e)----(0)r2
|
|
|
(TR)
|
|
r3
R1 :
conf t
dspu pu TEST rmac eeee.eeee.eeee rsap 6 lsap 6
interface e0
mac-address 2222.2222.2222
dspu start TEST1
dspu enable-host lsap 6
R3 :
conf t
dspu pu TEST rmac 4444.4444.4444 rsap 6 lsap 6
inter to0
mac-address 7777.7777.7777
dspu start TEST1
dspu enable-host lsap 6
multiring all
bridge config :
conf t
source-bridge ring-group 100
source-bridge transparent 100 1000 1 1
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
int e0
bridge-group 1
exit
int e1
bridge-group 1
exit
inter to0
source-bridge 10 1 100
source-bridge spanning
multiring all
exit
exit
Scenrio # 3
r1---(e)---(0)ra(dlsw)------(dlsw)rb(0)---(e)---r2
R1
conf t
dspu pu PU rmac 2222.2222.2222 rsap 4 lsap 4
int e0
mac-address 6666.6666.6666
dspu enable-pu lsap 4
dspu start test
exit
R2
conf t
dspu host PU xid-snd 00000000 rmac 6666.6666.6666 rsap 4 lsap 4
int e0
mac-address 2222.2222.2222
dspu enable-host lsap 4
dspu start PU
exit
Ra
conf t
dlsw local-peer peer-id 192.168.1.1
dlsw remote-peer 0 tcp 192.168.1.2
dlsw bridge-group 1
bridge 1 protocol ieee
inter e0
bridg-group 1
Rb
conf t
dlsw local-peer peer-id 192.168.1.2
dlsw remote-peer 0 tcp 192.168.1.1
dlsw bridge-group 1
bridge 1 protocol ieee
int e0
bridge-group 1
ra#sh dlsw circuits
Index local addr(lsap) remote addr(dsap) state uptime
1258291201 6666.6666.6666(04) 4444.4444.4444(04) CONNECTED
00:20:49
Total number of circuits connected: 1
rb#sh dlsw ci
Index local addr(lsap) remote addr(dsap) state uptime
1929379841 4444.4444.4444(04) 6666.6666.6666(04) CONNECTED
00:21:25
Total number of circuits connected: 1
Please do let me know if this paper helps u or not.
-Mamoor
----- Original Message -----
From: ying chang
To:
Cc:
Sent: Friday, February 15, 2002 10:34 PM
Subject: Re: How to Simulate SNA Traffic through DLSW Peers: Finally
> Hi Chris,
>
> Here's what I have:
>
> R8-x.25(serial)-R6-dlsw(ethernet)-R5-FR--R2
> \-R3
>
> Sorry it takes a while to recreate what I had, below are commands I used,
my
> intention was to create circuits between R2 and R8. Tried another host on
R8
> with different lsap, but never see anything came up though.
>
> Thanks,
> Chang
>
> R8:
> !
> dspu host R8 xid-snd 00800006 x25 600808 qllc 12
> !
> !
> interface Serial0
> encapsulation x25
> no ip mroute-cache
> x25 address 8006
> x25 map qllc 600808 broadcast
> x25 map bridge 6008 broadcast
> bridge-group 6
> dspu enable-host qllc 08
> dspu start R8
> !
>
> R6:
> !
> !
> dspu pu R6 x25 800608 qllc 08
> !
> !
> interface Serial0
> encapsulation x25 dce
> x25 address 6008
> x25 map bridge 8006 broadcast
> x25 map qllc 800608
> x25 map qllc 800612
> ipx network 6008
> clockrate 64000
> bridge-group 6
> dspu enable-pu qllc 08
> !
>
>
> R5:
> !
> dspu host H5 xid-snd 00012345 dlci 502 rsap 4 lsap 8
> !
> dspu host H3 xid-snd 00013245 dlci 503 rsap 4 lsap 8
> !
> interface Serial0.1 multipoint
> frame-relay map llc2 503 broadcast
> frame-relay map llc2 502 broadcast
> no frame-relay inverse-arp
> dspu enable-host lsap 8
> dspu start H5
> dspu start H3
> !
>
> R2:
> !
> dspu pu R2PU dlci 205 rsap 8 lsap 4
> !
> !
> interface Serial0
> frame-relay map llc2 205 broadcast
> frame-relay interface-dlci 205
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> dspu enable-pu lsap 4
> dspu start R2PU
> !
>
> Result:
>
> r2#sh dspu pu
> dspu pu R2PU Serial0 (FRAME-RELAY) PU STATUS Active
> FRAMES RECEIVED 3 FRAMES SENT 3
> LUs USED BY DSPU 0 LUs ACTIVE 0
> LUs USED BY API 0 LUs ACTIVE 0
> LUs ACTIVATED BY HOST BUT NOT USED 0
>
> r6#sh dspu pu
> dspu pu R6 Serial0 (QLLC) PU STATUS Active
> FRAMES RECEIVED 1 FRAMES SENT 1
> LUs USED BY DSPU 0 LUs ACTIVE 0
> LUs USED BY API 0 LUs ACTIVE 0
> LUs ACTIVATED BY HOST BUT NOT USED 0
>
>
>
> >From: CHRIS HUGO
> >Reply-To: CHRIS HUGO
> >To: ying chang
> >CC: ccielab@groupstudy.com
> >Subject: Re: How to Simulate SNA Traffic through DLSW Peers: Finally
> >Date: Fri, 15 Feb 2002 08:20:21 -0800 (PST)
> >
> > Ying,
> >Please post your topology. Do you have access to move cables around? and
> >also let me know if you have one switch.
> >thanx,
> >chris hugo
> > ying chang wrote: Hi,
> >
> >Have you tried dspu on serial line? I could not get the dspu to go across
> >the DLSW cloud when I replace R1-R2 and R3-R4 link with serial lines. I
> >have
> >no problems to set up dspu just between R1-R2 with either FR or X.25
(dspu
> >does not support HDLC, but it does support X.25). When I added the DLSW
> >into
> >the picture, the dspu would just stay inactive. I also tried to put
serial
> >line and the ethernet in the same bridge group and start dspu from the
> >ethernet, but got the same result. Please let me know if you have
different
> >results. I'm assuming there will be a FR cloud in the core and psdu
host/pu
> >to dlsw router can be anything.
> >
> >Thanks,
> >Chang
> >
> > >From: CHRIS HUGO
> > >Reply-To: CHRIS HUGO
> > >To: ying chang
> > >CC: mamoor@ieee.org, ccielab@groupstudy.com, kshah@hellocomputers.com,
> > > vinay@hellocomputers.com
> > >Subject: How to Simulate SNA Traffic through DLSW Peers: Finally
> > >Date: Thu, 14 Feb 2002 23:51:39 -0800 (PST)
> > >
> > > First of all I want to thank everybody who helped me on this setup(2
> >days
> > >long). This lab setup is simulating SNA traffic through 2 DLSW
peers.Here
> > >is the configs straight from the routers. I have also added what to
test
> > >for in each router.Not sure if needed but make sure you reload r1 and
r2
> > >before you start testing the lab.
> > >thank you again,
> > >chris hugo
> > >Here is the topology of the lab.
> > >r1(eth)----(eth)r2(serial)----(serial)r3(eth)----(eth)r4
> > >!
> > >hostname r1
> > >!
> > >!
> > >ip subnet-zero
> > >!
> > >!
> > >!
> > >!
> > >!
> > >dspu pu ETH1 rmac 4000.1010.0001 rsap 4 lsap 4
> > >!
> > >interface Ethernet0
> > > mac-address 4000.3745.0001
> > > no ip address
> > > no ip directed-broadcast
> > > dspu enable-pu lsap 4
> > > dspu start ETH1
> > >!
> > >interface Serial0
> > > no ip address
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > shutdown
> > > no fair-queue
> > >!
> > >interface Serial1
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >interface TokenRing0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >ip classless
> > >!
> > >!
> > >!
> > >line con 0
> > > transport input none
> > >line aux 0
> > >line vty 0 4
> > > login
> > >!
> > >end
> > >!Test your PU
> > >r1#sh dspu pu ETH1
> > >dspu pu ETH1 Ethernet0 PU STATUS Active
> > > RMAC 4000.1010.0001 RSAP 4 LSAP 4
> > > XID 01010101 RETRIES 4 RETRY_TIMEOUT 30
> > > WINDOW 7 MAXIFRAME 1472
> > > ACT BUFFERS 0 SAP ACT BUFFERS 0
> > > FRAMES RECEIVED 1 FRAMES SENT 1
> > > LUs USED BY DSPU 0 LUs ACTIVE 0
> > > LUs USED BY API 0 LUs ACTIVE 0
> > > LUs ACTIVATED BY HOST BUT NOT USED 0
> > >hostname r2
> > >!
> > >!
> > >ip subnet-zero
> > >!
> > >!
> > >bridge crb
> > >!
> > >dlsw local-peer peer-id 10.1.1.1
> > >dlsw remote-peer 0 tcp 10.1.1.2
> > >dlsw bridge-group 1
> > >!
> > >!
> > >interface Ethernet0
> > > no ip address
> > > no ip directed-broadcast
> > > bridge-group 1
> > >!
> > >interface Serial0
> > > no ip address
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > no fair-queue
> > >!
> > >interface Serial1
> > > ip address 10.1.1.1 255.255.255.0
> > > no ip directed-broadcast
> > > clockrate 64000
> > >!
> > >interface Serial2
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >interface Serial3
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >interface BRI0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >ip classless
> > >!
> > >!
> > >bridge 1 protocol ieee
> > >!
> > >line con 0
> > > transport input none
> > >line aux 0
> > >line vty 0 4
> > >!
> > >end
> > >!Verify DLSW peering
> > >r2#sh dlsw peer
> > >Peers: state pkts_rx pkts_tx type drops ckts TCP
> > >uptime
> > > TCP 10.1.1.2 CONNECT 416 204 conf 0 1 0
> > >01:39:10
> > >Total number of connected peers: 1
> > >Total number of connections: 1
> > >
> > >!Verify Non-Routable (SNA) Traffic is passing thru DLSW peers
> > >r2#sh dlsw circuit de
> > >Index local addr(lsap) remote addr(dsap) state
> > >uptime
> > >2181038080 0200.eca2.0080(04) 0200.0808.0080(04) CONNECTED
> > >00:30:32
> > > PCEP: 327C68 UCEP: 32E884
> > > Port:TB1 peer 10.1.1.2(2065)
> > > Flow-Control-Tx CW:20, Permitted:39; Rx CW:20, Granted:19; Op:
> > >Repeat
> > > Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0
> > > RIF = --no rif--
> > >Total number of circuits connected: 1
> > >
> > >hostname r3
> > >!
> > >!
> > >ip subnet-zero
> > >!
> > >!
> > >bridge crb
> > >!
> > >dlsw local-peer peer-id 10.1.1.2
> > >dlsw remote-peer 0 tcp 10.1.1.1
> > >dlsw bridge-group 1
> > >!
> > >!
> > >interface Ethernet0
> > > no ip address
> > > no ip directed-broadcast
> > > bridge-group 1
> > >!
> > >interface Serial0
> > > no ip address
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > shutdown
> > > no fair-queue
> > >!
> > >interface Serial1
> > > ip address 10.1.1.2 255.255.255.0
> > > no ip directed-broadcast
> > >!
> > >interface BRI0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >ip classless
> > >!
> > >!
> > >bridge 1 protocol ieee
> > >!
> > >line con 0
> > > transport input none
> > >line aux 0
> > >line vty 0 4
> > >!
> > >end
> > >!Verify DLSW peering
> > >r3#sh dlsw peers
> > >Peers: state pkts_rx pkts_tx type drops ckts TCP
> > >uptime
> > > TCP 10.1.1.1 CONNECT 206 424 conf 0 1 0
> > >01:39:53
> > >Total number of connected peers: 1
> > >Total number of connections: 1
> > >!Verify Non-Routable (SNA) Traffic is passing thru DLSW peers
> > >r3#sh dlsw cir de
> > >Index local addr(lsap) remote addr(dsap) state
> > >uptime
> > >1862270976 0200.0808.0080(04) 0200.eca2.0080(04) CONNECTED
> > >00:30:02
> > > PCEP: 2FC1D4 UCEP: 30524C
> > > Port:TB1 peer 10.1.1.1(2065)
> > > Flow-Control-Tx CW:20, Permitted:19; Rx CW:20, Granted:39; Op:
> > >Repeat
> > > Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0
> > > RIF = --no rif--
> > >Total number of circuits connected: 1
> > >hostname r4
> > >!
> > >!
> > >ip subnet-zero
> > >!
> > >!
> > >!
> > >!
> > >!
> > >dspu host ETH2 xid-snd 01010101 rmac 4000.3745.0001 rsap 4 lsap 4
> > >!
> > >interface Ethernet0
> > > mac-address 4000.1010.0001
> > > no ip address
> > > no ip directed-broadcast
> > > dspu enable-host lsap 4
> > > dspu start ETH2
> > >!
> > >interface Serial0
> > > no ip address
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > shutdown
> > > no fair-queue
> > >!
> > >interface Serial1
> > > no ip address
> > > no ip directed-broadcast
> > >!
> > >interface TokenRing0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > >!
> > >ip classless
> > >!
> > >!
> > >!
> > >line con 0
> > > transport input none
> > >line aux 0
> > >line vty 0 4
> > > login
> > >!
> > >end
> > >!Test your PU
> > >r4# sh dspu pu ETH2
> > >dspu host ETH2 Ethernet0 PU STATUS Active
> > > RMAC 4000.3745.0001 RSAP 4 LSAP 4
> > > XID 01010101 RETRIES 255 RETRY_TIMEOUT 30
> > > WINDOW 7 MAXIFRAME 1472
> > > ACT BUFFERS 0 SAP ACT BUFFERS 0
> > > FRAMES RECEIVED 1 FRAMES SENT 1
> > > LUs USED BY DSPU 0 LUs ACTIVE 0
> > > LUs USED BY API 0 LUs ACTIVE 0
> > > LUs ACTIVATED BY HOST BUT NOT USED 0
> > >r4#
> > >
> > > ying chang wrote: Hi,
> > >
> > >You do need additional 2 routers to make it to work. I took a quick
look
> >at
> > >chapter 15 in Cisco IOS Bridging and IBM Network Solutions, it supports
> > >quite a few different medias, but does not support HDLC. Since I don't
> >have
> > >2513, and could not make it to work over FR, the only one I made it to
> >work
> > >is on pure ethernet:
> > >
> > >R1-dspu pu-e0-e1--R2--e0-DLSW-e0--R3--e1--e0-dspu host-R4
> > >
> > >
> > >I think we can use this to test SNA filtering, but I don't think I
would
> > >use
> > >it in the real lab to verify DLSW - I have my serious doubt that we
will
> > >have the right media and enough routers to set it up.
> > >
> > >You should have no problems to make it to work with your environment.
> > >There's no need to do bit swapping with ethernet. If you decide to use
> > >token
> > >ring's mac as reference point, I think you need to use translational
> > >bridging.
> > >
> > >Please let me know if you run into problems. I'll try FR again when I
> >have
> > >a
> > >chance.
> > >
> > >Chang
> > >
> > >
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:24 GMT-3