Simple NAT Clarification

From: Ramachandra Shenoy N (rshenoy@xxxxxxxxxx)
Date: Wed Feb 13 2002 - 22:52:21 GMT-3


   
Scenario:

R1------R2---------Cloud

R2 is the router performing NAT, I am able to ping the cloud if I
specify the inside global address on the Ethernet interface, but if I
specify inside global address on any loopback interface am not able to
ping the cloud. Due to memory restraints on my routers currently am
using ver 11.3, could this be a problem ? attached is the configs on the
R2, the configurations are highlighted in the relevant sections, would
appreciate suggestions

ip nat inside source static 172.16.5.1 192.168.8.3
ip nat inside source static 172.16.5.2 192.168.8.2
no ip domain-lookup
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-dense-mode
!
interface Loopback10
 ip address 192.168.8.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Ethernet0
 ip address 172.16.5.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside

!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 ip address 192.168.1.1 255.255.255.0
 ip nat outside
 encapsulation frame-relay
 frame-relay map bridge 106 broadcast
 frame-relay map ip 192.168.1.2 106 broadcast
 frame-relay map ip 192.168.1.6 104 broadcast
 no frame-relay inverse-arp
!
interface BRI0

!
router ospf 10
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.1.0 0.0.0.3 area 0
 network 192.168.5.0 0.0.0.255 area 3
 network 192.168.8.0 0.0.0.255 area 3
 network 192.168.17.1 0.0.0.0 area 11
!
ip classless
!
access-list 69 permit 172.16.5.0 0.0.0.255 (not relevant as I am using
static nat)
!
line con 0
 exec-timeout 0 0
 escape-character 122
line aux 0
line vty 0 4
 login
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:22 GMT-3