Re: RE: BPG and NAT issues

From: Neil G. Legada (nglegada@xxxxxxxxxxx)
Date: Tue Feb 12 2002 - 00:13:05 GMT-3


   
If you want to retain the "overload" keyword .... try to change your ACL to
something like this:

access-list 100 deny tcp any eq bgp any
access-list 100 deny tcp any any eq bgp
access-list 100 permit ip any any

this prevents translation of TCP port 179 ....

then:

ip nat inside source list 10o interface Serial1 overload

Regards,
Neil

----- Original Message -----
From: "Sam" <SamB@cisco.com>
To: <RSiddappa@NECBNS.com>; <armreg@netscape.net>;
<jamartinez@landata.payma.es>; <ccielab@groupstudy.com>
Sent: Tuesday, February 12, 2002 6:13 AM
Subject: Re: RE: BPG and NAT issues

> Antonio,
>
> I noticed that you are using the "overload" keyword in your nat config.
> This will change the TCP port numbers. Since BGP uses TCP to
> establish/maintain neighbor relations this is important. Try removing
> overload and see what happens. ;)
> -Sam
>
>
>
>
> ----- Original Message -----
> From: <RSiddappa@NECBNS.com>
> To: <armreg@netscape.net>; <jamartinez@landata.payma.es>;
> <ccielab@groupstudy.com>
> Sent: Monday, February 11, 2002 11:54 AM
> Subject: RE: RE: BPG and NAT issues
>
>
> Hi,
>
> It looks good for me.
>
> But what is the status of u r BGP neighbor.
>
> Pls send the o/p of Debug BGP events, and clear the BGP process and see
> where it stops.
>
> And can u try to take out ur OSPF our for while and see will the BGP makes
a
> neighbor relation.
>
> R.
>
>
> -----Original Message-----
> From: armreg@netscape.net [mailto:armreg@netscape.net]
> Sent: Monday, February 11, 2002 12:37 PM
> To: Siddappa, Rajeev; jamartinez@landata.payma.es;
> ccielab@groupstudy.com
> Subject: RE: RE: BPG and NAT issues
>
>
>
> Sorry Guy,
>
> these are the configurations for R1 and R2.
>
>
>
> R1#sh run
> Building configuration...
>
> Current configuration : 1645 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip finger
> ip tcp synwait-time 5
> no ip domain-lookup
> !
> ipx routing 0001.0001.0001
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 15.15.1.1 255.255.255.0
> ipx network 11
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Serial0
> ip address 10.1.11.1 255.255.255.0
> ip nat inside
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> ipx network 1401
> frame-relay map ipx 1401.0014.0014.0014 301 broadcast
> frame-relay map ip 10.1.11.1 301 broadcast
> frame-relay map ipx 1401.0001.0001.0001 301 broadcast
> frame-relay map ipx 1401.0003.0003.0003 301 broadcast
> frame-relay map ip 10.1.11.14 301 broadcast
> frame-relay lmi-type cisco
> !
> interface Serial1
> ip address 200.200.200.1 255.255.255.0
> ip nat outside
> !
> router ospf 1
> log-adjacency-changes
> redistribute static subnets
> network 10.1.11.0 0.0.0.255 area 0
> network 15.15.1.0 0.0.0.255 area 0
> network 200.200.200.0 0.0.0.255 area 20
> !
> router ospf 100
> log-adjacency-changes
> !
> router bgp 100
> bgp log-neighbor-changes
> network 200.200.200.0
> neighbor 200.200.200.2 remote-as 200
> !
> ip nat inside source list 10 interface Serial1 overload
> ip classless
> ip route 15.15.2.0 255.255.255.0 200.200.200.2
> ip http server
> !
> access-list 10 permit any
> !
> !
> !
> ipx router eigrp 20
> network 1401
> network 11
> !
> !
> ipx router rip
> no network 11
> no network 1401
> !
> !
> ipx sap 4 f1server 11.000e.000e.000e 1 1
> ipx sap 7 p1server 11.000e.000e.000e 1 1
> !
> !
> line con 0
> logging synchronous
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
>
>
>
>
>
> R2
>
> R2#sh run
> Building configuration...
>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R2
> !
> !
> !
> !
> interface Loopback0
> ip address 15.15.2.2 255.255.255.0
> !
> interface Loopback1
> ip address 1.1.1.1 255.255.255.0
> !
> interface Loopback2
> ip address 1.1.2.1 255.255.255.0
> !
> interface Loopback3
> ip address 1.1.3.1 255.255.255.0
> !
> interface Serial0
> no ip address
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> ip address 200.200.200.2 255.255.255.0
> clockrate 125000
> !
> interface TokenRing0
> no ip address
> shutdown
> !
> router odr
> !
> router ospf 1
> network 15.15.2.0 0.0.0.255 area 20
> network 200.200.200.0 0.0.0.255 area 20
> distribute-list 11 in Serial1
> !
> router bgp 200
> no synchronization
> network 1.1.1.0 mask 255.255.255.0
> network 1.1.2.0 mask 255.255.255.0
> network 1.1.3.0 mask 255.255.255.0
> network 200.200.200.0
> neighbor 200.200.200.1 remote-as 100
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 200.200.200.1
> !
> access-list 11 deny any
> !
> line con 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
>
>
> RSiddappa@NECBNS.com wrote:
>
> >
> >Antonio,
> >
> >Can you send me the full configs.
> >
> >R.
> >
> >
> >
> >
> >-----Original Message-----
> >From: JOSE ANGEL MARTINEZ DE LA VARA
> >[mailto:jamartinez@landata.payma.es]
> >Sent: Monday, February 11, 2002 10:20 AM
> >To: 'armreg@netscape.net'; ccielab@groupstudy.com
> >Subject: RE: BPG and NAT issues
> >
> >
> >Your TCP connections are not broken since you are in Open state. Halabi
> book
> >says in page 110 that in openSent or openConfirm the TCP connection IS
> >stablished and the BGP OPEN message has been sent.
> >
> >I think your problem comes from the reuirements from BGP not from IP
> >conectivity.
> >
> >I cannot see where your ASES start and end so I cannot give you more
> >details.
> >
> >Funny work
> >
> >Jose Angel
> >
> >-----Mensaje original-----
> >De: armreg@netscape.net [mailto:armreg@netscape.net]
> >Enviado el: lunes, 11 de febrero de 2002 16:54
> >Para: ccielab@groupstudy.com
> >Asunto: BPG and NAT issues
> >
> >
> >Guys,
> >
> >I am having some problems with BGP and NAT configuration.
> >
> >
> > Nat inside Nat outside
> >
> > 10.1.11.x/24 .1 .1 200.200.200.x /24 .2
> >FR Cloud-------------------R1-----------------------------------R2
> > BGP 100 BGP200
> >
> >BGP neighbors relationship stay in Open State, they never establish the
> >full TCP connection. The Nat translation is breaking my TCP connections
> for
> >BGP neighbor. When I remove Nat Bgp neighbors between R1 and R2 get
> >established. I have been trying any possible configuration for Nat but
> keep
> >breaking my TCP connections needed for BGP. Has somebody face this
problem
> >before?
> >
> >
> >Thanks
> >
> >Antonio
> >
> >
> >--
> >
> >
> >
> >



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:19 GMT-3