Re: Frame Relay and Custom Queueing and 'debug custom'

From: CiscoCCNP3@xxxxxxx
Date: Sun Feb 10 2002 - 15:35:26 GMT-3


   
hiya folks

with regards to the above topic,

before i start, any comments are welcome, if i can improve my solution

here's a little custom queue example over frame for you to check out. maybe
it will help, hopefully anyway.

r6 is my frame hub, connected to r3 and r4 with multipoint, and r2 via p2p
in the below debug i snd traffic from r12 ro r1 and then from r4 to r1/r1 to
r4 simultaeneously,

topology
                                    r1
                                     | <---serial
                                    r5
                                     | <----ethernet
               r7------------------sw
 eth---> | | <---eth
               r4------frp2m----r1
                                   / \
                     frame / \ cloud
                               / \
              r3---frp2m---/ \----frp2p---r2
 ser---> | | <---ser
              r12 r20

relevant config for r6 - frame hub

interface Serial0/0
no ip address
encapsulation frame-relay
no fair-queue
clockrate 115200
frame-relay traffic-shaping
frame-relay class custom
frame-relay lmi-type ansi
!
interface Serial0/0.1 multipoint
description HUB connected to R4 & R3
ip address 140.10.11.6 255.255.255.0
ip irdp
ip pim sparse-dense-mode
ip ospf network point-to-multipoint
ip ospf priority 200
ip igmp static-group 224.0.5.5
ipx network 647
no ipx split-horizon eigrp 666
frame-relay map ipx 647.0003.0003.0003 110 broadcast
frame-relay map ipx 647.0004.0004.0004 100 broadcast
frame-relay map ipx 647.0006.0006.0006 100
frame-relay map ip 140.10.11.3 110 broadcast
frame-relay map ip 140.10.11.4 100 broadcast
frame-relay map ip 140.10.11.6 100
frame-relay interface-dlci 100
 class slow_pvc
frame-relay interface-dlci 110
 class fast_pvc
!
interface Serial0/0.2 point-to-point
description P2P to R2
ip address 140.10.10.6 255.255.255.0
ip ospf network point-to-point
ipx network 62
no ipx split-horizon eigrp 666
frame-relay class custom
frame-relay interface-dlci 140
!
<edit>
map-class frame-relay custom
no frame-relay adaptive-shaping
frame-relay custom-queue-list 1
<edit>
!
map-class frame-relay slow_pvc
frame-relay traffic-rate 4800 9600
no frame-relay adaptive-shaping
frame-relay custom-queue-list 1
!
map-class frame-relay fast_pvc
frame-relay traffic-rate 32000 64000
no frame-relay adaptive-shaping
frame-relay custom-queue-list 1
<edit>
queue-list 1 protocol dlsw 1
queue-list 1 protocol ip 2 tcp telnet
queue-list 1 protocol ipx 3
queue-list 1 default 4
queue-list 1 queue 1 byte-count 4000 limit 40
queue-list 1 queue 2 byte-count 2000
queue-list 1 queue 4 limit 40

after applying that config, i sent traffic from r20 to r1, 1500byte packets
using icmp with debug custom on and part of the debug from r6 is listed below

6d23h: intf Serial0/0: dlci 110 PQ: (Pk size: 1504) Inc. Q # to 5
6d23h: intf Serial0/0: dlci 110 PQ: (Pk size: 1504) Inc. Q # to 5
6d23h: intf Serial0/0: dlci 110 PQ: (Pk size: 98) Q # was 5 now 4
6d23h: intf Serial0/0: dlci 110 PQ: (Pk size: 88) Q # was 4 now 4
6d23h: intf Serial0/0: dlci 110 PQ: (Pk size: 1504) Inc. Q # to 5

next, i pinged from r4 to r1 with extended ping 1000 packets and 1250 size,
while at the same time telnetting to r4 from r1, and then issuing commands
such as show run to get telnet traffic. below is a sample of the debug from
r6, the hub/transit router where the traffic shapping/ queuing was applied.

1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Q # was 1 now 4
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Inc. Q # to 5
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Q # was 5 now 4
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 100) Q # was 4 now 4
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Inc. Q # to 5
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Q # was 5 now 4
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Inc. Q # to 5
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 44) Q # was 5 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 44) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 44) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 44) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 56) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 86) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 47) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 50) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 56) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 47) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 44) Q # was 2 now 2
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 1252) Q # was 2 now 4
1w0d: intf Serial0/0: dlci 100 PQ: (Pk size: 56) Q # was 4 now 4

the frame pvcs look like this,,,

cc1019857-b#sh frame pvc 100

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 347613 output pkts 176253 in bytes 26436262
 out bytes 11018412 dropped pkts 49 in FECN pkts 0
 in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
 in DE pkts 0 out DE pkts 0
 out bcast pkts 51284 out bcast bytes 3038982
 pvc create time 1w0d, last time pvc status changed 1d21h
 cir 4800 bc 4800 be 4800 limit 675 interval 125
 mincir 2400 byte increment 75 Adaptive Shaping none
 pkts 46157 bytes 2963922 pkts delayed 667 bytes delayed 371482
 shaping active
 traffic shaping drops 0

List Queue Args
1 4 default
1 1 protocol dlsw
1 2 protocol ip tcp port telnet
1 3 protocol ipx
1 1 byte-count 4000 limit 40

List Queue Args
1 2 byte-count 2000
1 4 limit 40
 Output queues: (queue #: size/max/drops/dequeued)
    0: 0/20/0/32 1: 0/40/0/0 2: 0/20/0/41 3: 0/20/0/0 4: 39/40/50/596
    5: 0/20/0/0 6: 0/20/0/0 7: 0/20/0/0 8: 0/20/0/0 9: 0/20/0/0
    10: 0/20/0/0 11: 0/20/0/0 12: 0/20/0/0 13: 0/20/0/0 14: 0/20/0/0
    15: 0/20/0/0 16: 0/20/0/0
cc1019857-b#

cc1019857-b#sh frame pvc 110

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 110, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 592670 output pkts 413565 in bytes 58377078
 out bytes 38705611 dropped pkts 0 in FECN pkts 0
 in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
 in DE pkts 0 out DE pkts 0
 out bcast pkts 51288 out bcast bytes 3039242
 pvc create time 1w0d, last time pvc status changed 1d21h
 cir 32000 bc 32000 be 32000 limit 4500 interval 125
 mincir 16000 byte increment 500 Adaptive Shaping none
 pkts 157633 bytes 15368707 pkts delayed 55 bytes delayed 60144
 shaping inactive
 traffic shaping drops 0

List Queue Args
1 4 default
1 1 protocol dlsw
1 2 protocol ip tcp port telnet
1 3 protocol ipx
1 1 byte-count 4000 limit 40

List Queue Args
1 2 byte-count 2000
1 4 limit 40
 Output queues: (queue #: size/max/drops/dequeued)
    0: 0/20/0/0 1: 0/40/0/0 2: 0/20/0/0 3: 0/20/0/0 4: 0/40/0/55
    5: 0/20/0/0 6: 0/20/0/0 7: 0/20/0/0 8: 0/20/0/0 9: 0/20/0/0
    10: 0/20/0/0 11: 0/20/0/0 12: 0/20/0/0 13: 0/20/0/0 14: 0/20/0/0
    15: 0/20/0/0 16: 0/20/0/0
cc1019857-b#

best regards, peace \/

jr



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:18 GMT-3