Lab 18 NAT

From: Yigit Zorlu (alec_cisco@xxxxxxxxx)
Date: Sat Feb 09 2002 - 09:45:01 GMT-3


   
Hi group,

I almost finished Lab 18 except this tiny problem. R1 has a serial
connection over FR with R2 (200.200.200.2) . They can ping each other they
can exchange IPX routes but they can not establish an OSPF neighborship and
BGP neighborship. I found the reason but could not get the logic behind it.
When I remove ip nat outside from interface s0/0.3 problem disappears all
peer establishments become OK. But why ? I need this NAT thing on that
subinterface . I think I am missing a point.

Any ideas ?

version 12.1

!
interface Loopback0
 ip address 15.15.1.1 255.255.255.0
 ip ospf network point-to-point
 ipx network 1000
!
interface Ethernet0/0
 no ip address
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 custom-queue-list 1
 no frame-relay inverse-arp
!
interface Serial0/0.1 multipoint
!
interface Serial0/0.2 point-to-point
 ip ospf network point-to-multipoint
!
interface Serial0/0.3 point-to-point
 ip address 200.200.200.1 255.255.255.0
 ip nat outside
 ip ospf network point-to-point
 ipx network 200
 frame-relay interface-dlci 102
!
interface Serial0/0.4 multipoint
 ip address 11.1.11.1 255.255.255.0
 ip nat inside
 ip ospf network point-to-multipoint
 ipx network 1401
 frame-relay map ipx 1401.0002.fd69.0281 109 broadcast
 frame-relay map ip 11.1.11.3 109 broadcast
 frame-relay map ip 11.1.11.14 109 broadcast
 frame-relay map ipx 1401.0002.fd68.ebc1 109 broadcast
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 11.1.11.0 0.0.0.255 area 0
 network 15.15.1.0 0.0.0.255 area 0
 network 200.200.200.0 0.0.0.255 area 20
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 11.1.12.194 remote-as 100
 neighbor 11.1.12.194 default-originate
 neighbor 200.200.200.2 remote-as 200
 no auto-summary
!
ip nat inside source list 1 interface Serial0/0.3 overload
ip classless
ip http server



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:17 GMT-3