RE: DLSW+ Backup

From: ssowell@xxxxxxxx
Date: Fri Feb 08 2002 - 17:03:09 GMT-3


   
Hi Janto,
Here's a "known good" config for dlsw w/backup that I use quite often. Why don'
t you peruse this and see if you can find your problem.(see below) Also, you'll
 make it easier to help you if you remove unrelated syntax from your configs be
fore sending them. This Alaskan temperature makes a Florida boy lazy! ;-)
Steven Sowell
CCIE#7317
            (R2)---Serial---(R1)---Serial---(R3)
              | |
              |-----------token-ring---------|

Hostname R1
int loop0
 ip address 10.1.195.1 255.255.255.255
Dlsw local-peer peer-id 10.1.195.1 lf 1500
Dlsw remote-p 0 tcp 10.1.192.2 lf 1500
Dlsw remote-p 0 tcp 10.1.193.3 backup 10.1.192.2

Dlsw bridge-group 1
Bridge 1 protocol ieee

Int e0
 Bridge-group 1

Hostname r2
int loop0
 ip address 10.1.192.2 255.255.255.255
Source-bridge ring-group 10
Dlsw local-peer peer-id 10.1.192.2 lf 1500 prom

Int t0/0
 Source-bridge 20 1 10
 Source-bridge span

Hostname r3
int loop0
 ip address 10.1.193.3 255.255.255.255
Source-bridge ring-group 10
Dlsw local-peer peer-id 10.1.193.3 passive prom
Dlsw remote-peer 1 tcp 10.1.194.4 lf 1500

Int t0/0
 Source-bridge 20 3 10
 Source-bridge spanning

Original Message:
-----------------
From: Janto Cin jantocin@yahoo.com
Date: Fri, 8 Feb 2002 15:37:37 +0700
To: ccielab@groupstudy.com
Subject: DLSW+ Backup

Hi All,

I have problem when configuring DLSW+ Backup feature.
The network model same like in page 907 of Karl Solie's CCIE Practical
Studies Vol. I book.
I tried to configure backup peer for router skywalker, the primary peer
is router solo, and the backup peer is router vader.
The DLSW+ configuration for the each router is like below:

Router Skywalker configuration:
=======================
skywalker#sh ru
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname skywalker
!
dlsw local-peer peer-id 172.16.128.5
dlsw remote-peer 0 tcp 172.16.128.9
dlsw remote-peer 0 tcp 172.16.128.1 backup-peer 172.16.128.9 linger 5
dlsw bridge-group 1
!
interface Loopback20
 ip address 172.16.128.5 255.255.255.252
!
interface Ethernet0
 ip address 172.16.5.1 255.255.255.0
 no keepalive
 bridge-group 1
!
interface Serial0
 ip address 172.16.1.5 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 172.16.1.6 111 broadcast
 frame-relay map ip 172.16.1.1 111 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 65001
 network 172.16.0.0
 no auto-summary
!
ip classless
!
bridge 1 protocol ieee
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router Solo configuration:
===================
solo#sh ru
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname solo
!
dlsw local-peer peer-id 172.16.128.9
dlsw remote-peer 0 tcp 172.16.128.5
dlsw bridge-group 1
!
interface Loopback20
 ip address 172.16.128.9 255.255.255.252
!
interface Ethernet0
 ip address 172.16.6.1 255.255.255.0
 no keepalive
 bridge-group 1
!
interface Serial0
 ip address 172.16.1.6 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay map ip 172.16.1.5 131 broadcast
 frame-relay map ip 172.16.1.1 131 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 65001
 network 172.16.0.0
!
no ip classless
!
bridge 1 protocol ieee
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router Vader configuration:
====================
vader#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname vader
!
memory-size iomem 15
ip subnet-zero
!
 source-bridge ring-group 110
 dlsw local-peer peer-id 172.16.128.1
 dlsw remote-peer 0 fst 172.16.128.13
 dlsw remote-peer 0 tcp 172.16.128.5
 !
interface Loopback20
 ip address 172.16.128.1 255.255.255.252
 no ip directed-broadcast
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type ansi
!
interface Serial0/0.1 multipoint
 ip address 172.16.1.1 255.255.255.0
 no ip directed-broadcast
 no ip split-horizon eigrp 65001
 frame-relay map ip 172.16.1.5 110 broadcast
 frame-relay map ip 172.16.1.6 130 broadcast
!
interface Serial0/0.2 point-to-point
 ip address 172.16.2.1 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 180
!
interface TokenRing0/0
 ip address 172.16.30.1 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
 source-bridge 1 1 110
 source-bridge spanning
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router eigrp 65001
 network 172.16.0.0
 no auto-summary
 no eigrp log-neighbor-warnings
!
ip classless
no ip http server
!
line con 0
 transport input none
 speed 19200
line aux 0
line vty 0 4
!
no scheduler allocate
end

Router Chewbacca configuration:
========================
chewbacca#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname chewbacca
!
memory-size iomem 20
ip subnet-zero
!
 source-bridge ring-group 111
 dlsw local-peer peer-id 172.16.128.13
 dlsw remote-peer 0 fst 172.16.128.1
!
interface Loopback20
 ip address 172.16.128.13 255.255.255.252
 no ip directed-broadcast
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/0
 ip address 172.16.2.2 255.255.255.252
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 frame-relay interface-dlci 181
!
interface TokenRing0/0
 ip address 172.16.3.1 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
 source-bridge 1 2 111
 source-bridge spanning
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router eigrp 65001
 network 172.16.0.0
 no eigrp log-neighbor-warnings
!
ip classless
no ip http server
!
line con 0
 transport input none
 speed 19200
line aux 0
line vty 0 4
!
no scheduler allocate
end

Below is the result of 'show dlsw peer' command for each router:
Skywalker
========
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:05
 TCP 172.16.128.1 DISCONN 0 0 conf 0 0 -
-
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:07
 TCP 172.16.128.1 DISCONN 0 0 conf 0 0 -
-
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:08
 TCP 172.16.128.1 DISCONN 0 0 conf 0 0 -
-
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:08
 TCP 172.16.128.1 DISCONN 0 0 conf 0 0 -
-
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:09
 TCP 172.16.128.1 CONNECT 2 2 conf 0 0 0
00:00:00
skywalker#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.9 CONNECT 506 506 conf 0 0 0
04:16:10
 TCP 172.16.128.1 CONNECT 2 2 conf 0 0 0
00:00:01

Solo
===
solo#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 TCP 172.16.128.5 CONNECT 524 524 conf 0 0 0
04:22:22

Vader
=====
vader#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 FST 172.16.128.13 CONNECT 17 17 conf 0 - -
00:07:56
        Expected: 0 Next Send: 0 Seq errors: 0
 TCP 172.16.128.5 CONNECT 15 15 conf 0 0 0
00:06:33
Total number of connected peers: 2
Total number of connections: 2

Chewbacca
=========
chewbacca#sh dlsw peer
Peers: state pkts_rx pkts_tx type drops ckts TCP
uptime
 FST 172.16.128.1 CONNECT 18 18 conf 0 - -
00:08:22
        Expected: 0 Next Send: 0 Seq errors: 0
Total number of connected peers: 1
Total number of connections: 1

The question is why the peer connection between skywalker and vader can
be CONNECT ?
Is this correct ? Pls help me.
TIA,

Janto



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:16 GMT-3