Re: OSPF and IGRP redistribution

From: Elsayed Mohamed (elsayedm@xxxxxxxxxxx)
Date: Mon Feb 04 2002 - 13:41:01 GMT-3


   
Two solutions:
1- Second ospf prosess in the distributing router. Then define the subnet
that you want igrp to see using the nei area command. Finally redistibute
the new ospf process into igrp. I TRIED THIS METHOD AND IT IS WORKING.

2- Use secondary interfaces. Many people say it working but I never tried.
Try to do it in your lab and let me know.

Elsayed

----Original Message Follows----
From: "atul pawar" <atulpawar@hotmail.com>
Reply-To: "atul pawar" <atulpawar@hotmail.com>
To: ccielab@groupstudy.com
Subject: OSPF and IGRP redistribution
Date: Mon, 04 Feb 2002 15:33:45

Guyes
I am doing VLSM to FLSM redistribution lab. I have three routers r4 ,r1 and
r2.

r4-----serial link-------r1--------ethernet---------r2

r4 and r1 are running ospf in area 0 and r1 is running igrp with r2.
r1 is redistributing between ospf and igrp.

I am not able to get /29 and /24 networks from r4 to get advertised to r2.
On r2 I can just see 172.16.0.0 /24 which is directly connected.
I want establish connectivity between r2 and r4 but not able to get it
working without a default route on r2 :(. As per my understanding r2 will
never get /29 network of r4 because classful nature of IGRP. Is there any
other way to get it working ? configs are as follows.

r1
sh run
Building configuration...

Current configuration:
!
! Last configuration change at 06:30:38 GMT Mon Mar 1 1993
! NVRAM config last updated at 06:32:36 GMT Mon Mar 1 1993
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
username atul password 0 cisco
!
!
!
!
clock timezone GMT 0
ip subnet-zero
no ip domain-lookup
!
--More-- !
!
process-max-time 200
!
interface Loopback1
ip address 9.1.1.1 255.0.0.0
no ip directed-broadcast
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
no ip redirects
no ip directed-broadcast
standby 1 timers 5 15
standby 1 priority 110 preempt
standby 1 authentication atul
standby 1 ip 10.1.1.3
standby 1 track Serial0 100
!
interface Serial0
ip address 172.16.2.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
--More-- interface Serial1
no ip address
ip access-group 133 in
no ip directed-broadcast
encapsulation frame-relay
ip ospf network point-to-multipoint
shutdown
ntp broadcast
cdp enable
frame-relay map ip 172.17.59.1 102 broadcast
frame-relay map ip 172.17.59.3 101 broadcast
!
router ospf 200
redistribute igrp 100 metric 10 subnets
network 9.0.0.0 0.255.255.255 area 0
network 172.16.2.0 0.0.0.255 area 0
!
router igrp 100
redistribute ospf 200 metric 1000 10 255 1 1500
passive-interface Serial0
network 9.0.0.0
network 10.0.0.0
!
--More-- ip classless
ip route 172.16.4.0 255.255.255.0 Null0
no ip http server
!
access-list 133 permit ospf any any
access-list 133 dynamic firewall timeout 5 permit ip any any
access-list 133 permit tcp any host 172.16.2.2 eq telnet
route-map setmed permit 10
set metric 20
!
route-map chuchcu permit 10
match ip address 1
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password cisco
login local
!
ntp master
--More-- end

r4#
sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
process-max-time 200
!
interface Loopback0
--More-- ip address 12.1.1.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
!
interface Loopback3
no ip address
no ip directed-broadcast
ip ospf network point-to-point
!
interface Loopback5
ip address 172.16.1.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
!
interface Loopback6
ip address 172.16.3.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
!
interface Loopback7
ip address 172.16.4.33 255.255.255.248
no ip directed-broadcast
ip ospf network point-to-point
--More-- !
interface Loopback8
ip address 172.16.4.65 255.255.255.248
no ip directed-broadcast
ip ospf network point-to-point
!
interface Serial0
ip address 172.16.2.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 64000
!
interface Serial1
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
--More-- summary-address 172.16.4.0 255.255.255.0
network 172.16.1.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
network 172.16.3.0 0.0.0.255 area 0
network 172.16.4.0 0.0.0.63 area 0
network 172.16.4.64 0.0.0.63 area 0
network 172.16.10.8 0.0.0.7 area 0
!
router rip
network 12.0.0.0
network 192.168.3.0
!
ip classless
no ip http server
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password cisco
login
--More-- !
ntp clock-period 17179871
ntp server 172.17.59.2
end

r2#
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
username atul password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
process-max-time 200
!
--More-- interface Loopback1
ip address 172.16.22.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback2
ip address 172.16.21.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback3
ip address 172.16.20.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback11
ip address 172.16.4.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip redirects
no ip directed-broadcast
no keepalive
standby 1 timers 5 15
standby 1 preempt
--More-- standby 1 authentication atul
standby 1 ip 10.1.1.3
!
interface Serial0
no ip address
ip access-group 120 in
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
router igrp 100
network 10.0.0.0
network 172.16.0.0
no default-information out
!
ip classless
ip route 172.16.0.0 255.255.0.0 172.16.16.0
--More-- no ip http server
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password cisco
login local
!
end

r2#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 4 subnets
C 172.16.20.0 is directly connected, Loopback3
C 172.16.21.0 is directly connected, Loopback2
C 172.16.22.0 is directly connected, Loopback1
C 172.16.4.0 is directly connected, Loopback11
I 9.0.0.0/8 [100/1600] via 10.1.1.2, 00:00:33, Ethernet0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0
C 192.168.2.0/24 is directly connected, Serial1

r1#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.16.4.32/29 [110/65] via 172.16.2.2, 00:32:36, Serial0
S 172.16.4.0/24 is directly connected, Null0
O 172.16.1.0/24 [110/65] via 172.16.2.2, 00:32:36, Serial0
C 172.16.2.0/24 is directly connected, Serial0
O 172.16.3.0/24 [110/65] via 172.16.2.2, 00:32:36, Serial0
O 172.16.4.64/29 [110/65] via 172.16.2.2, 00:32:36, Serial0
C 9.0.0.0/8 is directly connected, Loopback1
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0

                   Atul



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:11 GMT-3