From: Stephen C. Feldberg (scfeldberg@xxxxxxxxxxx)
Date: Thu Jan 10 2002 - 11:17:06 GMT-3
Here are the working configs. I will say up front that this lab has 12.0(4)
on router1 and 11.3(26a) on router2 although CW says that this configuration
should work properly in 12.1
router1#sh run
interface Loopback0
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback99
ip address 1.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0
ip address 192.168.1.249 255.255.255.0
no ip directed-broadcast
!
router rip
network 192.168.1.0
network 192.168.3.0
!
end
router1#sh ip route
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback99
168.28.0.0/24 is subnetted, 1 subnets
R 4.0.0.0/8 [120/1] via 192.168.1.1, 00:00:22, Ethernet0
R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:22, Ethernet0
C 192.168.1.0/24 is directly connected, Ethernet0
C 192.168.3.0/24 is directly connected, Loopback0
router1#
router2#sh run
interface Loopback1
ip address 172.16.1.1 255.255.255.240
!
interface Loopback2
ip address 172.16.1.17 255.255.255.240
!
interface Loopback3
ip address 172.16.1.33 255.255.255.240
!
interface Loopback98
ip address 4.4.4.5 255.255.255.255
!
interface Loopback99
ip address 4.4.4.4 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
router ospf 1
network 172.16.1.0 0.0.0.255 area 0
network 4.4.4.4 0.0.0.0 area 0
!
router ospf 2
summary-address 172.16.0.0 255.255.0.0
redistribute ospf 1 subnets
network 4.4.4.5 0.0.0.0 area 0
!
router rip
redistribute ospf 2
network 192.168.1.0
!
end
router2#sh ip route
4.0.0.0/32 is subnetted, 2 subnets
C 4.4.4.4 is directly connected, Loopback99
C 4.4.4.5 is directly connected, Loopback98
C 192.168.1.0/24 is directly connected, Ethernet0
R 192.168.3.0/24 [120/1] via 192.168.1.249, 00:00:21, Ethernet0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.1.32/28 is directly connected, Loopback3
C 172.16.1.16/28 is directly connected, Loopback2
O 172.16.0.0/16 is a summary, 17:44:47, Null0
C 172.16.1.0/28 is directly connected, Loopback1
router2#sh ip ospf d
OSPF Router with ID (192.168.1.1) (Process ID 2)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
192.168.1.1 192.168.1.1 1201 0x80000026 0x69B9 1
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
4.4.4.4 192.168.1.1 1661 0x80000024 0x1104 0
172.16.0.0 192.168.1.1 1661 0x80000024 0x4424 0
OSPF Router with ID (4.4.4.4) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
4.4.4.4 4.4.4.4 1523 0x80000027 0xDB60 4
router2#
Steve
----- Original Message -----
From: "Jeongwoo Park" <Jpark@wams.com>
To: "'scott mann'" <smann0762@hotmail.com>; <chris_aguillo@alfalak.com>;
<ccielab@groupstudy.com>
Sent: Thursday, January 10, 2002 4:59 AM
Subject: RE: Redistribute ospf1-> ospf2->rip
> Here is the latest config. But still not working.
> R1;
> interface Loopback1
> ip address 192.168.3.20 255.255.255.0
> !
> interface Ethernet0
> ip address 192.168.1.249 255.255.255.0
> !
> router rip
> network 192.168.1.0
> network 192.168.3.0
> !
> ip http server
> ip classless
> !
> alias exec b sh ip int brie
> alias exec r sh ip route
> !
> line con 0
> password xxx
> transport input none
> stopbits 1
> line vty 0 4
> exec-timeout 0 0
> password xxx
> login
> !
> end
>
> R1's routing table;
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> C 192.168.1.0/24 is directly connected, Ethernet0
> C 192.168.3.0/24 is directly connected, Loopback1
>
> R2;
> router ospf 1
> log-adjacency-changes
> network 172.16.0.0 0.0.255.255 area 0
> !
> router ospf 2
> log-adjacency-changes
> summary-address 172.16.0.0 255.255.0.0
> redistribute ospf 1 subnets
> network 172.16.0.0 0.0.255.255 area 0
> network 192.68.1.0 0.0.0.255 area 0
> !
> router rip
> redistribute ospf 2
> network 192.168.1.0
>
> I am still struggling with this
> Could you some show me the working config?
>
> JP
>
> -----Original Message-----
> From: scott mann [mailto:smann0762@hotmail.com]
> Sent: Wednesday, January 09, 2002 2:15 PM
> To: Jpark@wams.com; chris_aguillo@alfalak.com; ccielab@groupstudy.com
> Subject: RE: Redistribute ospf1-> ospf2->rip
>
> Here is why it is not working;
>
> You ethernet inteface to R1 is class C /24 by default 192.168.1.0/24.
>
> The Loopbacks are /28 being summarized into class C /24, but the network
> classful address is 172.16.0.0 or class B /16. Rip will only accept /24
> routes from a neighbor if the Network is a class C network 192-223 OR ->
if
> the interface is a different class (say 10.1.1.1/24) but has a class C
(/24)
>
> mask -> then other 10.1.x.x/24 will be sent.
>
> The ethernet interface to R1 is 192 or class C by default, so only
classfull
>
> addresses will be sent to the neighbor ..i.e. 172.16.0.0/16 NOT
> 172.16.1.0/24. You have to summarize to /16 or give the ethernet interface
a
>
> 172.16.x.x/24 address.
>
> Scott
>
>
> >From: Jeongwoo Park <Jpark@wams.com>
> >Reply-To: Jeongwoo Park <Jpark@wams.com>
> >To: "'Christian C. Aguillo'" <chris_aguillo@alfalak.com>,
> >"'ccielab@groupstudy.com'" <ccielab@groupstudy.com>
> >Subject: RE: Redistribute ospf1-> ospf2->rip
> >Date: Wed, 9 Jan 2002 10:51:12 -0800
> >
> >router ospf 1
> > log-adjacency-changes
> > redistribute ospf 2
> > network 172.16.1.0 0.0.0.15 area 0
> > network 172.16.1.16 0.0.0.15 area 0
> > network 172.16.1.32 0.0.0.15 area 0
> >!
> >router ospf 2
> > log-adjacency-changes
> > summary-address 172.168.1.0 255.255.255.0
> > redistribute ospf 1
> > redistribute rip
> > passive-interface Vlan1
> > network 192.168.1.0 0.0.0.255 area 0
> >!
> >router rip
> > redistribute ospf 2
> > network 192.168.1.0
> >!
> >Unfortunately it is not working either. Thanks for the input thought.
> >
> >JP
> >-----Original Message-----
> >From: Christian C. Aguillo [mailto:chris_aguillo@alfalak.com]
> >Sent: Wednesday, January 09, 2002 3:55 AM
> >To: Jeongwoo Park
> >Subject: Re: Redistribute ospf1-> ospf2->rip
> >
> >This is how I do it on R2:
> >
> >ip classless
> >
> >router ospf 1
> > network 172.16.1.0 0.0.0.15 area 0
> > network 172.16.1.16 0.0.0.15 area 0
> > network 172.16.1.32.0 0.0.0.15 area 0
> > redistribute ospf 2
> >
> >router ospf 2
> > redistribute ospf 1
> > summary-address 172.16.1.0 255.255.255.0
> > redistribute rip
> > passive interface e0
> > network 192.168.1.0 0.0.0.255 area 0
> >
> >router rip
> > redistribute ospf 2
> > network 192.168.1.0
> >
> >pls let me know coz I don't have routers to play with.
> >
> >Chris
> >
> >----- Original Message -----
> >From: "Jeongwoo Park" <Jpark@wams.com>
> >To: <ccielab@groupstudy.com>
> >Cc: "'Stephen C. Feldberg'" <scfeldberg@hotmail.com>
> >Sent: Wednesday, January 09, 2002 1:19 PM
> >Subject: Redistribute ospf1-> ospf2->rip
> >
> >
> > > Hi all
> > > Here is the scenario.
> > > Loopbacks
> > > R1(e0)-----------(e0)R2------172.16.1.1/28
> > > 172.16.1.17/28
> > > 172.16.1.33/28
> > > What I want to do is ultimately to redistribute these three loopback
> > > networks into rip.
> > > R2 is ASBR running ospf and rip. R1 is running only rip.
> > > As the people on this list recommended, I first created ospf 2 and
> > > redistributed ospf 1 into ospf 2. And during this redistribution from
> >ospf2
> > > to ospf1, I summarized three loopback networks to the classful address
(
> > > 172.16.0.0/16) And I redistributed ospf 2 into rip.
> > > NOT WORKING
> >
> > > Here is my config
> > > R2;
> > > !
> > > !
> > > !
> > > interface Loopback1
> > > ip address 172.16.1.1 255.255.255.240
> > > !
> > > interface Loopback2
> > > ip address 172.16.1.17 255.255.255.240
> > > !
> > > interface Loopback3
> > > ip address 172.16.1.33 255.255.255.240
> > > !
> > > router ospf 1
> > > log-adjacency-changes
> > > redistribute rip
> > > network 172.16.0.0 0.0.255.255 area 0
> > > !
> > > router ospf 2
> > > log-adjacency-changes
> > > summary-address 172.16.0.0 255.255.0.0
> > > redistribute ospf 1
> > > !
> > > router rip
> > > redistribute ospf 2
> > > network 192.168.1.0
> > > !
> > > ip route 172.16.0.0 255.255.0.0 Null0
> > > no ip http server
> > > !
> > > !
> > > line con 0
> > > password 7 120E0333
> > > login
> > > transport input none
> > > line vty 0 4
> > > exec-timeout 0 0
> > > password 7 xxxxxx
> > > login
> > > !
> > > end
> > >
> > > R1;
> > > version 12.1
> > > service timestamps debug uptime
> > > service timestamps log uptime
> > > no service password-encryption
> > > !
> > > hostname Router
> > > !
> > > enable secret 5 $1$ZMs8$bNzuexNNx77K24cGqgx6B0
> > > !
> > > !
> > > !
> > > !
> > > !
> > > !
> > > ip subnet-zero
> > > !
> > > ip name-server 192.168.1.6
> > > no ip finger
> > > isdn switch-type basic-ni
> > > !
> > > !
> > > !
> > > interface Loopback1
> > > ip address 192.168.3.20 255.255.255.0
> > > !
> > > interface Ethernet0
> > > ip address 192.168.1.249 255.255.255.0
> > > !
> > > !
> > > router rip
> > > network 192.168.1.0
> > > network 192.168.3.0
> > > !
> > > ip http server
> > > ip classless
> > > !
> > > !
> > > line con 0
> > > password xxx
> > > transport input none
> > > stopbits 1
> > > line vty 0 4
> > > exec-timeout 0 0
> > > password xxx
> > > login
> > > !
> > > end
> > >
> > > R1's routing table;
> > > R1#sh ip route
> > > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
> > > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> >inter
> > > area
> > > * - candidate default, U - per-user static route, o - ODR
> > > P - periodic downloaded static route
> > >
> > > Gateway of last resort is not set
> > >
> > > C 192.168.1.0/24 is directly connected, Ethernet0
> > > C 192.168.3.0/24 is directly connected, Loopback1
> > >
> > > As you can see, those three loopbacks didn't show up in this routing
> >table,
> > > which means it is not working.
> > >
> > > Can anyone point out what is wrong?
> > > I will appreciate your reply.
> > >
> > > JP
> >######################################################################
> >Attention:
> >This e-mail is privileged and confidential. If you are not the
> >intended recipient please delete the message and notify the sender.
> >Any views or opinions presented are solely those of the author.
> >
> >Note:
> >This email has been virus scanned and cleared. Should you encounter
> >any virus problems and deem them as our responsibility please notify
> >us immediately.
> >######################################################################
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:22 GMT-3