Re: Redistributing IS-IS and OSPF into each other.

From: Michael Popovich (m.popovich@xxxxxxxx)
Date: Sat Jan 05 2002 - 22:33:57 GMT-3


   
Here is the solution I came up with.

R4 is my distribution between OSPF and IS-IS. L0, S0 and S1 are all
configured for IS-IS and To0 is in OSPF Area 1.

R4

hostname R4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 200.10.10.4 255.255.255.255
 ip router isis
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 bandwidth 64
 ip address 172.100.10.6 255.255.255.252
 ip router isis
 frame-relay interface-dlci 107
 isis password cisco level-1
!
interface Serial1
 bandwidth 64
 ip address 172.100.10.24 255.255.255.240
 ip router isis
 clockrate 64000
 isis password cisco level-1
 isis priority 127
!
interface TokenRing0
 ip address 10.10.10.4 255.255.255.0
 ring-speed 16
!
router ospf 100
 log-adjacency-changes
 redistribute connected subnets route-map ospf-connected
 redistribute isis level-1 subnets
 passive-interface Serial0
 passive-interface Serial1
 network 10.10.10.0 0.0.0.255 area 1
!
router isis
 redistribute ospf 100 metric-type external
 net 50.0000.0000.0000.0002.00
!
ip classless
ip http server
!
access-list 10 deny 10.10.10.0 0.0.0.255
access-list 10 permit any
route-map ospf-connected permit 10
 match ip address 10

When I double checked the routes in OSPF I was seeing all of the routes in
IS-IS except the networks that were directly connected in R4. I created a
route-map to redistribute the connected networks on R4 except for the Token
Ring interface since it is already in OSPF.

That did the trick as far as pinging across domains is concerned.

Was this the right way to do it or can anyone else think of another way?

MP
----- Original Message -----
From: "Michael Popovich" <m.popovich@home.com>
To: "CCIE GROUPSTUDY" <ccielab@groupstudy.com>
Sent: Saturday, January 05, 2002 5:38 PM
Subject: Redistributing IS-IS and OSPF into each other.

> I am working on redistribution of IS-IS and OSPF into each other.
>
> I see all the appropriate routes in OSPF and in IS-IS but I can't ping
across
> routing domains. In R2 (IS-IS router) I can see a route for R8 (OSPF
router) I
> try and ping it and I don't receive any response. I look at the next hop
> address which is R4 (IS-IS and OSPF router/redistributing). R4 can ping
> everything in both domains.
>
> Must be a problem with my redistribution.
>
> R4
>
> router ospf 100
> log-adjacency-changes
> redistribute isis level-1 subnets
> passive-interface Serial0
> passive-interface Serial1
> network 10.10.10.0 0.0.0.255 area 1
> !
> router isis
> redistribute ospf 100 metric-type external
> net 50.0000.0000.0000.0002.00
>
> Thanks for any help.
>
> MP



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:17 GMT-3