RE: CCBootcamp Lab 1, ospf hello timer mismatch

From: Marc Russell (mrussell@xxxxxxxxxxxxxx)
Date: Mon Dec 31 2001 - 04:04:37 GMT-3


   
Do your configs look like the ones below. These are the new final configs
from our soon to be released 1-day versions of our labs.

Marc Russell
www.ccbootcamp.com

Router R1.

hostname r1
!
!
!
!
 !
 !
 process-max-time 200
 !
!
interface Ethernet0
 ip address 10.1.1.1 255.255.0.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 bandwidth 2000
 no fair-queue
 clockrate 2000000
!
interface Serial0.1 multipoint
 ip address 10.10.1.1 255.255.0.0
 ip ospf priority 200
 frame-relay map ip 10.10.1.2 102 broadcast
 frame-relay map ip 10.10.1.3 103 broadcast
 frame-relay map ip 10.10.1.5 105 broadcast
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 network 10.1.1.1 0.0.0.0 area 1
 network 10.10.1.1 0.0.0.0 area 0
 neighbor 10.10.1.2
 neighbor 10.10.1.3
 neighbor 10.10.1.5
!
ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

r1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
200.200.200.1 0 FULL/DROTHER 00:01:48 10.10.1.2 Serial0.1
10.34.1.1 0 FULL/DROTHER 00:01:54 10.10.1.3 Serial0.1
10.10.1.5 0 FULL/DROTHER 00:01:31 10.10.1.5 Serial0.1

r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is 10.10.1.2 to network 0.0.0.0

     137.20.0.0/24 is subnetted, 1 subnets
O IA 137.20.20.0 [110/60] via 10.10.1.2, 00:13:06, Serial0.1
     10.0.0.0/16 is subnetted, 4 subnets
C 10.10.0.0 is directly connected, Serial0.1
C 10.1.0.0 is directly connected, Ethernet0
O IA 10.44.0.0 [110/115] via 10.10.1.3, 00:13:06, Serial0.1
O IA 10.34.0.0 [110/114] via 10.10.1.3, 00:13:06, Serial0.1
     11.0.0.0/16 is subnetted, 1 subnets
O IA 11.1.0.0 [110/60] via 10.10.1.5, 00:13:06, Serial0.1
O*E1 0.0.0.0/0 [110/150] via 10.10.1.2, 00:13:06, Serial0.1

r1#show frame map
Serial0.1 (up): ip 10.10.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0.1 (up): ip 10.10.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
Serial0.1 (up): ip 10.10.1.5 dlci 105(0x69,0x1890), static,
              broadcast,
              CISCO, status defined, active
r1#

Router R2

hostname r2
!
!
!
!
 !
 !
 process-max-time 200
 !
 interface Loopback0
 ip address 200.200.200.1 255.255.255.0
!
interface Ethernet0
 ip address 137.20.20.1 255.255.255.0
!
interface Serial0
 ip address 10.10.1.2 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
 no ip mroute-cache
 ip policy route-map 10
 no fair-queue
 clockrate 2000000
 frame-relay map ip 10.10.1.1 201 broadcast
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 1
 network 10.10.1.2 0.0.0.0 area 0
 network 137.20.20.1 0.0.0.0 area 10
 default-information originate always metric 100 metric-type 1
!
ip local policy route-map 10
ip classless
ip route 0.0.0.0 0.0.0.0 137.20.20.2
!
access-list 101 permit ip any 10.34.0.0 0.0.255.255
access-list 101 permit ip any 11.1.0.0 0.0.255.255
access-list 101 permit ip any 10.4.0.0 0.0.255.255
access-list 101 permit ip any host 10.10.1.3
access-list 101 permit ip any host 10.10.1.5
access-list 101 permit ip any 10.44.0.0 0.0.255.255
route-map 10 permit 10
 match ip address 101
 set ip next-hop 10.10.1.1
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

r2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.10.1.1 200 FULL/DR 00:01:38 10.10.1.1 Serial0
r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is 137.20.20.2 to network 0.0.0.0

C 200.200.200.0/24 is directly connected, Loopback0
     137.20.0.0/24 is subnetted, 1 subnets
C 137.20.20.0 is directly connected, Ethernet0
     10.0.0.0/16 is subnetted, 4 subnets
C 10.10.0.0 is directly connected, Serial0
O IA 10.1.0.0 [110/74] via 10.10.1.1, 00:16:11, Serial0
O IA 10.44.0.0 [110/129] via 10.10.1.3, 00:16:11, Serial0
O IA 10.34.0.0 [110/128] via 10.10.1.3, 00:16:11, Serial0
     11.0.0.0/16 is subnetted, 1 subnets
O IA 11.1.0.0 [110/74] via 10.10.1.5, 00:16:11, Serial0
S* 0.0.0.0/0 [1/0] via 137.20.20.2
r2#sh frame map
Serial0 (up): ip 10.10.1.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

-----Original Message-----
From: Steve Barone
To: ccielab@groupstudy.com
Sent: 12/31/01 1:18 AM
Subject: CCBootcamp Lab 1, ospf hello timer mismatch

all:
I cannot establish nieghbor adjacency on r1 and r2, debug shows a hello
parameter mismatch, a sh ip o int, shows both interface are
NON__BROADCAST and I am using neighbor statements.
Both show hello interval =20, but I get the message below:
(can ping 100% successful)

R1#:
I B00:18:26: OSPF: rcv. v:2 t:1 l:44 rid:172.168.32.1
      aid:0.0.0.0 chk:2EC5 aut:0 auk: from Serial0.1
00:18:26: OSPF: Rcv hello from 172.168.32.1 area 0 from Serial0.1
10.10.1.2
00:18:26: OSPF: Mismatched hello parameters from 10.10.1.2
00:18:26: OSPF: Dead R 80 C 80, Hello R 20 C 20 Mask R 255.255.0.0 C
255.255.255.0

r2#
00:23:16: OSPF: rcv. v:2 t:1 l:44 rid:10.10.1.1
      aid:0.0.0.0 chk:E656 aut:0 auk: from Serial0
00:23:16: OSPF: Rcv hello from 10.10.1.1 area 0 from Serial0 10.10.1.1
00:23:16: OSPF: Mismatched hello parameters from 10.10.1.1
00:23:16: OSPF: Dead R 80 C 80, Hello R 20 C 20 Mask R 255.255.255.0 C
255.255.0.0



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:50 GMT-3