RE: OT : Drop and Insert

From: Ron Royston (ccie6824@xxxxxxxxxxx)
Date: Fri Dec 21 2001 - 14:16:08 GMT-3


   
Mason, Thanks for the config. As it turns out the customer was doing a bit
more than just grabbing the frame (or data) channels and passing the TDM
voice. The customer was passing 10 TDM voice channels (simple enough) but
also was only wanting to grab 2 of 6 DLCI's and pass the other 4 DLCI's on
to a Micom box along with the 10 voice channels. However, the Micom was
only expecting a 256 frame port (channels 20-24). Anyway, after a couple of
hours, I got it working. Here it is in case anyone gets hit with something
like this...

term length 0
Router#sho run
Building configuration...

Current configuration : 4442 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot system flash:c3600-is-mz.122-2.T.bin
logging rate-limit console 10 except errors
enable password cisco
!
username avnet password 0 xxxx
username Fadi password 0 xxxx
username Fadi autocommand menu I
!
!
memory-size iomem 15
voice-card 5
!
ip subnet-zero
!
!
no ip domain-lookup
!
no ip dhcp-client network-discovery
frame-relay switching
call rsvp-sync
!
!
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
controller T1 5/0
framing esf
linecode b8zs
channel-group 1 timeslots 17-24 speed 64
tdm-group 2 timeslots 1-10
!
controller T1 5/1
framing esf
clock source internal
linecode b8zs
channel-group 13 timeslots 17-20 speed 64
tdm-group 12 timeslots 1-10
!
!
interface FastEthernet0/0
description ** xxxxxx Houston LAN Segment **
ip address 172.16.1.254 255.255.255.0
duplex auto
speed auto
!
interface Serial5/0:1
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay route 104 interface Serial5/1:13 104
frame-relay route 105 interface Serial5/1:13 105
frame-relay route 106 interface Serial5/1:13 106
frame-relay route 107 interface Serial5/1:13 107
!
interface Serial5/0:1.1 multipoint
ip address 172.16.253.100 255.255.255.0 secondary
ip address 172.16.254.100 255.255.255.0
frame-relay map ip 172.16.254.102 102 broadcast
frame-relay map ip 172.16.254.103 103 broadcast
!
interface Serial5/1:13
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 104 interface Serial5/0:1 104
frame-relay route 105 interface Serial5/0:1 105
frame-relay route 106 interface Serial5/0:1 106
frame-relay route 107 interface Serial5/0:1 107
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
connect PASS T1 5/0 2 T1 5/1 12
!
!
!
menu I title ^CCC
                                 | |
                                .|. .|.
                               .|||. .|||.
                             .:|||||:..:|||||:.
                           C i s c o S y s t e m s

                        Welcome to Texas Pipe& Supply

                                Voice Gateway

For System Maintenence, please contact Avnet Enterprise Solutions
@(713)780-7770
^C
menu I prompt ^CC
** text omitted **
menu I status-line
menu I single-space
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
dial-peer cor custom
!
!
!
banner exec ^CC

                        | |
                       .|. .|.
                      .|||. .|||.
                    .:|||||:..:|||||:.
                  C i s c o S y s t e m s

               Welcome to Texas Pipe& Supply

                       Voice Gateway
^C
banner login ^CC

******************************************************************************
* Unauthorized access to this system is strictly prohibited. Violators will
*
* be prosecuted to the fullest extent of the law.
*
******************************************************************************

^C
!
line con 0
password xxxx
logging synchronous
login local
line aux 0
modem InOut
modem autoconfigure discovery
transport input all
speed 115200
line vty 0 4
password xxxx
logging synchronous
login
!
!
end

>From: "Mason Harris" <maharris@cisco.com>
>Reply-To: "Mason Harris" <maharris@cisco.com>
>To: "Ron Royston" <ccie6824@hotmail.com>, <ccielab@groupstudy.com>
>Subject: RE: OT : Drop and Insert
>Date: Thu, 20 Dec 2001 01:14:24 -0500
>
>Ron--
>
>Here you go:
>
>! Below config is for data and Drop & Insert
>controller T1 0/0
> framing esf
> clock source internal
> linecode b8zs
> channel-group 0 timeslots 1-12 speed 64
> tdm-group 1 timeslot 13-24
>
>! Below is only for Drop & Insert
>controller T1 0/1
> framing esf
> clock source internal
> linecode b8zs
>tdm-group 1 timeslot 13-24
>
>! Below command is for tdm-group
>connect 1 T1 0/0 1 T1 0/1 1
>interface Serial0/0:0
> ip address 1.0.1.1 255.255.255.0
>
>and off of CCO for more detail on the commands: (watch for url wrap)
>http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120
>t/120t7/t1_mf_t6.htm#xtocid1046213
>
>Good luck,
>Mason
>
>CCIE #5916
>R&S, SNA-IP, ISP-Dial
>
>-----Original Message-----
>From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
>Ron Royston
>Sent: Wednesday, December 19, 2001 4:09 PM
>To: ccielab@groupstudy.com
>Subject: OT : Drop and Insert
>
>
>Anyone got a sample config for a VWIC-2MFT-T1-D1 configuration for drop and
>insert of some voice channels off a channelized T1 circuit?
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:46 GMT-3