AW: Best way to get Loopback interface in dynamic Routing Protoco l (O SPF or EIGRP)

From: Frei Peter (Peter.Frei@xxxxxxxx)
Date: Tue Dec 11 2001 - 12:38:11 GMT-3


   
Hi Steve, hi group
Scanatio is from CCBootcamp 16. I do a mutually redistribution from EIGRP to
OSPF on the same router with the loopback. If I don't use

route-map C2E permit 10
 match interface Loopback0 Serial0.2 Serial0.3 !S0.2,S0.3 run OSPF

for the redistribute connected to EIGRP and
I loose the connected interfaces from OSPF in EIGRP
route-map C2O permit 10
 match interface Ethernet0 Serial0.1 Loopback0 !Ethernet0,Serial 0.1 runs
EIGRP

for the redistribute connected to OSPF
I loose the connected interfaces from EIGRP in OSPF

Relevant Part of the configuration
interface Loopback0
 ip address 10.1.12.1 255.255.255.0
!
interface Ethernet0
 ip address 10.1.20.1 255.255.255.240
!
interface Serial0
 bandwidth 256
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 bandwidth 64
 ip address 172.30.1.1 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial0.2 multipoint
 bandwidth 128
 ip address 10.1.10.1 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 100
 frame-relay interface-dlci 101
!
interface Serial0.3 point-to-point
 bandwidth 64
 ip address 172.32.10.1 255.255.255.0
 frame-relay interface-dlci 103
!
router eigrp 10
 redistribute connected metric 1000 100 255 1 1500 route-map C2E
 redistribute ospf 1 metric 10000 100 255 1 1500 route-map O2E
 network 10.1.20.1 0.0.0.0
 network 172.30.1.1 0.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 area 51 virtual-link 200.200.200.1
 redistribute connected metric-type 1 subnets route-map C2O
 redistribute eigrp 10 metric 200 metric-type 1 subnets route-map E2O
 network 10.1.10.1 0.0.0.0 area 51
 network 172.32.10.1 0.0.0.0 area 0
!
ip classless
!
ip access-list standard E2O
 permit 10.1.18.0 0.0.0.255
 permit 172.30.1.0 0.0.0.255
 permit 10.1.20.0 0.0.0.255
 permit 172.25.10.0 0.0.0.255
 permit 10.2.1.0 0.0.0.255
ip access-list standard O2E
 permit 0.0.0.0
route-map C2E permit 10
 match interface Loopback0 Serial0.2 Serial0.3
!
route-map E2O permit 10
 match ip address E2O
!
route-map O2E deny 10
 match ip address O2E
!
route-map O2E permit 20
!
route-map C2O permit 10
 match interface Ethernet0 Serial0.1 Loopback0 Serial0.2

Peter

!-----Urspr|ngliche Nachricht-----
Von: SFeldberg@edeltacom.com [mailto:SFeldberg@edeltacom.com]
Gesendet: Montag, 10. Dezember 2001 17:41
An: Frei Peter
Cc: ccielab@groupstudy.com
Betreff: Re: Best way to get Loopback interface in dynamic Routing
Protocol (O SPF or EIGRP)

I would do it the way that you first attempted. Redistribute connected
with a route-map that only references the correct interface.

interface loopback0
ip address 10.10.10.10 255.255.255.255
!
router eigrp 10
redistribute connected route-map conn2eigrp10
default-metric 1 1 1 1 1
!
route-map conn2eigrp10
match interface loopback0
!

This will not affect other redistribution efforts- assuming that you were
not already redistributing connected routes on this router.

Steve

                    Frei Peter

                    <Peter.Frei@de To: "'ccielab@groupstudy.com'"
<ccielab@groupstudy.com>
                    lec.ch> cc:

                    Sent by: Subject: Best way to get
Loopback interface in dynamic Routing
                    nobody@groupst Protocol (O SPF or EIGRP)

                    udy.com

                    12/10/2001

                    10:36 AM

                    Please respond

                    to Frei Peter

Hi group
I have a router (12.1-5T.7) with EIGRP running on some interfaces and OSPF
running on others with a Loopback interface not included in EIGRP nor in
OSPF.
If I use redistribute connected with a route-map allowing only this
loopback
interface, the routes of the connected interfaces from OSPF disapears in
EIGRP and vice versa. (I've ckecked it on other routers).
What's the best way to get this Loopback int the routing table of all OSPF
and EIGRP routers, if not allowed to specify it with a network command
under
router ospf or router eigrp.

Peter



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:41 GMT-3