Re: iBGP to OSPF redistribution - weird behavior?

From: Hotmail (jthao1@xxxxxxxxxxx)
Date: Mon Dec 10 2001 - 14:34:33 GMT-3


   
Hello group,

Here are the complete configs. (slightly modified but illustrates that rip
redistribution does not work also). I discovered this behavior while trying
to slightly modify fatkid lab 501.

r1 ---- r2 ------ r3 ----- r4

All connections are serial.

r1 and r2 runs OSPF area 0
r3 and r4 run rip
r2 and r3 run internal BGP AS 10
r1 to r2 - 30.30.30.0/24
r2 to r3 - 10.10.10.0/24
r3 to r4 - 20.20.20.0 /24
r2 loopback - 40.40.40.1/24
r3 loopback - 50.50.50.1/24

Here are the complete configs... HELP !!!! Any of you guys can figure this
out it'll be appreciated. Is this an IOS bug or am I missing something
obvious here?

R1 config:
Current configuration : 907 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 70.70.70.4 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 30.30.30.4 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 30.30.30.4 0.0.0.0 area 0
!
ip classless
ip http server
!
!
alias router e exit
alias interface e exit
alias configure e exit
alias exec c config t
alias exec s sh run
alias exec sip sh ip route
alias exec sipx sh ipx route
alias exec sib sh ip bgp
alias exec cib clear ip bgp *
alias exec cip clear ip route *
alias exec co clear ip ospf process
alias exec crs copy run start
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R1#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     70.0.0.0/24 is subnetted, 1 subnets
C 70.70.70.0 is directly connected, Loopback0
     40.0.0.0/24 is subnetted, 1 subnets
O E2 40.40.40.0 [110/10] via 30.30.30.1, 00:03:49, Serial0 ---- r2
loopback gets redistribute but not r3 loopback. Why ?????
     30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, Serial0
R1#

R2 config:
Current configuration : 1227 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 40.40.40.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 30.30.30.1 255.255.255.0
 no fair-queue
!
interface Serial1
 ip address 10.10.10.1 255.255.255.0
 clockrate 64000
!
router ospf 10
 log-adjacency-changes
 redistribute bgp 10 metric 10 subnets
 network 30.30.30.1 0.0.0.0 area 0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 network 40.40.40.0 mask 255.255.255.0
 redistribute ospf 10 metric 100 match internal external 1 external 2
 neighbor 10.10.10.2 remote-as 10
 no auto-summary
!
ip classless
ip http server
!
!
alias router e exit
alias interface e exit
alias configure e exit
alias exec c config t
alias exec s sh run
alias exec sip sh ip route
alias exec sipx sh ipx route
alias exec sib sh ip bgp
alias exec cib clear ip bgp *
alias exec cip clear ip route *
alias exec co clear ip ospf process
alias exec crs copy run start
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R2#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
B 50.50.50.0 [200/0] via 10.10.10.2, 03:04:51
     20.0.0.0/24 is subnetted, 1 subnets
B 20.20.20.0 [200/0] via 10.10.10.2, 02:13:29
     40.0.0.0/24 is subnetted, 1 subnets
C 40.40.40.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial1
     30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, Serial0
R2#sh ip bgp
BGP table version is 9, local router ID is 40.40.40.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*>i20.20.20.0/24 10.10.10.2 0 100 0 ?
*> 30.30.30.0/24 0.0.0.0 0 32768 ?
*> 40.40.40.0/24 0.0.0.0 0 32768 i
*>i50.50.50.0/24 10.10.10.2 0 100 0 i
R2#

R3 config:
Building configuration...

03:32:43: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1235 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 50.50.50.2 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 20.20.20.2 255.255.255.0
 no fair-queue
!
interface Serial1
 ip address 10.10.10.2 255.255.255.0
!
interface Serial2
 ip address 80.80.80.2 255.255.255.0
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router rip
 redistribute bgp 10 metric 2
 network 20.0.0.0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 network 50.50.50.0 mask 255.255.255.0
 redistribute rip metric 22
 neighbor 10.10.10.1 remote-as 10
 no auto-summary
!
ip classless
ip http server
!
!
alias router e exit
alias interface e exit
alias configure e exit
alias exec c config t
alias exec s sh run
alias exec sip sh ip route
alias exec sipx sh ipx route
alias exec sib sh ip bgp
alias exec cib clear ip bgp *
alias exec cip clear ip route *
alias exec co clear ip ospf process
alias exec crs copy run start
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R3#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Loopback0
     80.0.0.0/24 is subnetted, 1 subnets
C 80.80.80.0 is directly connected, Serial2
     20.0.0.0/24 is subnetted, 1 subnets
C 20.20.20.0 is directly connected, Serial0
     40.0.0.0/24 is subnetted, 1 subnets
B 40.40.40.0 [200/0] via 10.10.10.1, 03:06:23
     10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial1
     30.0.0.0/24 is subnetted, 1 subnets
B 30.30.30.0 [200/0] via 10.10.10.1, 00:05:08
R3#sh ip bgp
BGP table version is 9, local router ID is 50.50.50.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 20.20.20.0/24 0.0.0.0 0 32768 ?
*>i30.30.30.0/24 10.10.10.1 0 100 0 ?
*>i40.40.40.0/24 10.10.10.1 0 100 0 i
*> 50.50.50.0/24 0.0.0.0 0 32768 i
R3#

R4#s
Building configuration...

Current configuration : 863 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 60.60.60.3 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 20.20.20.3 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 20.0.0.0
!
ip classless
ip http server
!
!
alias router e exit
alias interface e exit
alias configure e exit
alias exec c config t
alias exec s sh run
alias exec sip sh ip route
alias exec sipx sh ipx route
alias exec sib sh ip bgp
alias exec cib clear ip bgp *
alias exec cip clear ip route *
alias exec co clear ip ospf process
alias exec crs copy run start
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
end

R4#sip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R 50.0.0.0/8 [120/2] via 20.20.20.2, 00:00:07, Serial0 --- Similarly,
r3 loopback gets redistributed.
     20.0.0.0/24 is subnetted, 1 subnets
C 20.20.20.0 is directly connected, Serial0
     60.0.0.0/24 is subnetted, 1 subnets
C 60.60.60.0 is directly connected, Loopback0
R4#

----- Original Message -----
From: "Hotmail" <jthao1@hotmail.com>
To: <ccielab@groupstudy.com>
Sent: Monday, December 10, 2001 9:46 AM
Subject: iBGP to OSPF redistribution - weird behavior?

> Hello Group,
>
> I have a very simple problem that I'm having a mental block on. I am
> performing redistribution of BGP to OSPF but for some reason, iBGP
> discovered routes are not getting redistributed into the OSPF domain. I
> have turned off synchronization and auto summary on all BGP routers.
>
> Can iBGP discovered routes be redistributed into OSPF? I don't see why
not
> but I can't do it.
>
> Here's the scenario:
>
> r1 ----- r2 ----- r3 ----- r4
>
> The connections between routers does not matter.
>
> r1 to r2 - running ospf area 0 only on the interface connecting them
> r3 to r4 - running ospf area 0 only on the interface connecting them
> r2 to r3 - no IGP, no OSPF, just iBGP AS 10
> r2 has a loopback that is introduced into BGP on r2 with the network
> command.
> r3 has a loopback that is introduced into BGP on r3 with the network
> command.
>
> Mutual redistribution from BGP to OSPF (and vice-versa) is performed on
r3.
> r3 loopback appears on r4 but not r2 loopback.
>
> Also, if you perform mutual redistribution on r2, the same converse thing
> happens. That is: you can see r2 loopback on r1 but not r3 loopback.
>
> My question is: Is this the proper behavior. I don't see why iBGP
> discovered routes can not be redistributed into OSPF. This does not seem
> right to me. Am I missing something obvious here?
>
>
> Thanks
> Joseph



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:41 GMT-3