From: KK FoK (rgb98a@xxxxxxxxxxx)
Date: Mon Dec 10 2001 - 13:25:10 GMT-3
I always thought that ISIS neighbor only establishes adjacency on
point-to-point network. Now it seems it can also work on NBMA hub & spoke.
During testing I found that spoke routers can only learn routes from the hub
but not from other spokes. The hub, however, have all routes from all spoke
in its routing table.
Am I missing something ?
R1 & R2 are spokes and R3 is the hub
hostname r1
!
ip subnet-zero
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
frame-relay switching
!
!
!
interface Loopback0
ip address 152.1.1.65 255.255.255.255
ip router isis
!
interface Loopback1
ip address 152.1.1.97 255.255.255.224
!
interface Serial2/3
ip address 152.1.1.81 255.255.255.248
ip router isis
encapsulation frame-relay IETF
ip ospf authentication-key cisco3
ip ospf priority 0
serial restart-delay 0
clockrate 64000
frame-relay map clns 100 broadcast
frame-relay map ip 152.1.1.81 100 broadcast
frame-relay map ip 152.1.1.82 100 broadcast
frame-relay map ip 152.1.1.83 100 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
!
router isis
net 50.0100.0000.0000.0100
!
r1#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
152.1.0.0/16 is variably subnetted, 7 subnets, 6 masks
i L1 152.1.1.128/25 [115/20] via 152.1.1.83, Serial2/3
C 152.1.1.0/26 is directly connected, Ethernet3/0
C 152.1.1.80/29 is directly connected, Serial2/3
C 152.1.1.76/30 is directly connected, Dialer0
C 152.1.1.65/32 is directly connected, Loopback0
i L1 152.1.1.69/32 [115/20] via 152.1.1.83, Serial2/3
C 152.1.1.96/27 is directly connected, Loopback1
hostname r2
!
!
interface Loopback0
ip address 152.2.2.72 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 152.1.1.2 255.255.255.192
ip ospf authentication-key cisco3
duplex auto
speed auto
!
interface Serial0/0
ip address 152.1.1.82 255.255.255.248
ip router isis
encapsulation frame-relay IETF
ip ospf authentication-key cisco3
ip ospf priority 0
no fair-queue
frame-relay map clns 201 broadcast
frame-relay map ip 152.1.1.81 201 broadcast
frame-relay map ip 152.1.1.82 201 broadcast
frame-relay map ip 152.1.1.83 201 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
!
router isis
net 50.0100.0000.0000.0200
!
r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
152.1.0.0/16 is variably subnetted, 4 subnets, 4 masks
i L1 152.1.1.128/25 [115/20] via 152.1.1.83, Serial0/0
C 152.1.1.0/26 is directly connected, FastEthernet0/0
C 152.1.1.80/29 is directly connected, Serial0/0
i L1 152.1.1.69/32 [115/20] via 152.1.1.83, Serial0/0
152.2.0.0/32 is subnetted, 1 subnets
C 152.2.2.72 is directly connected, Loopback0
r2#
hostname r3
!
!
interface Loopback0
ip address 152.1.1.69 255.255.255.255
ip router isis
!
interface Loopback1
ip address 152.1.3.1 255.255.255.0
!
interface Ethernet0/0
ip address 152.1.1.129 255.255.255.128
ip router isis
ip ospf message-digest-key 1 md5 cisco0
!
interface Serial0/0
ip address 152.1.1.83 255.255.255.248
ip router isis
encapsulation frame-relay IETF
ip ospf authentication-key cisco3
ip ospf priority 10
no fair-queue
clockrate 64000
frame-relay map clns 301 broadcast
frame-relay map clns 300 broadcast
frame-relay map ip 152.1.1.81 300 broadcast
frame-relay map ip 152.1.1.82 301 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
!
router isis
net 50.0100.0000.0000.0300
r3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
152.1.0.0/16 is variably subnetted, 5 subnets, 4 masks
C 152.1.1.128/25 is directly connected, Ethernet0/0
C 152.1.3.0/24 is directly connected, Loopback1
C 152.1.1.80/29 is directly connected, Serial0/0
i L1 152.1.1.65/32 [115/20] via 152.1.1.81, Serial0/0
C 152.1.1.69/32 is directly connected, Loopback0
152.2.0.0/32 is subnetted, 1 subnets
i L1 152.2.2.72 [115/20] via 152.1.1.82, Serial0/0
>From: Phil <ciscostudent1@yahoo.com.br>
>Reply-To: Phil <ciscostudent1@yahoo.com.br>
>To: Asbjorn Hojmark <Asbjorn@Hojmark.ORG>, ccielab@groupstudy.com
>Subject: Re: IS-IS on frame-relay with map
>Date: Sun, 9 Dec 2001 11:56:46 -0300 (ART)
>
> You missed the "broadcast" in R2's map statement.
>
> Asbjorn Hojmark <Asbjorn@Hojmark.ORG> escreveu: Has anyone successfully
>got IS-IS running on a not fully meshed
>frame-relay with map statements? I can't seem to get all neigh-
>bors up.
>
>I have a hub-and-spoke setup, where one of the spokes come up
>fine, while the other experiences encapsulation failures.
>
>TIA,
>-A
>
>---------------------------------------------------------------
>R1 (hub)
>---------------------------------------------------------------
>interface Serial0/0
>ip address 10.1.100.1 255.255.255.240
>ip router isis
>encapsulation frame-relay
>frame-relay map clns 101 broadcast
>frame-relay map clns 102 broadcast
>frame-relay map clns 103 broadcast
>frame-relay map clns 104 broadcast
>frame-relay map ip 10.1.100.1 101 broadcast
>frame-relay map ip 10.1.100.2 101 broadcast
>frame-relay map ip 10.1.100.3 102 broadcast
>frame-relay map ip 10.1.100.4 103 broadcast
>no frame-relay inverse-arp
>frame-relay lmi-type cisco
>
>router isis
>passive-interface Loopback0
>net 49.0001.0000.0000.0001.00
>
>---------------------------------------------------------------
>R2 (spoke) This one works fine
>---------------------------------------------------------------
>interface Serial0/0
>ip address 10.1.100.2 255.255.255.240
>ip router isis
>encapsulation frame-relay
>isis priority 0
>frame-relay map clns 101 broadcast
>frame-relay map ip 10.1.100.1 101 broadcast
>frame-relay map ip 10.1.100.2 101 broadcast
>frame-relay map ip 10.1.100.3 101 broadcast
>frame-relay map ip 10.1.100.4 101 broadcast
>no frame-relay inverse-arp
>
>router isis
>passive-interface Loopback0
>net 49.0001.0000.0000.0002.00
>
>---------------------------------------------------------------
>R3 (spoke) This one fails
>---------------------------------------------------------------
>interface Serial0/0
>ip address 10.1.100.3 255.255.255.240
>ip router isis
>encapsulation frame-relay
>isis priority 0
>frame-relay map clns 102
>frame-relay map ip 10.1.100.1 102 broadcast
>frame-relay map ip 10.1.100.2 102 broadcast
>frame-relay map ip 10.1.100.3 102 broadcast
>frame-relay map ip 10.1.100.4 102 broadcast
>no frame-relay inverse-arp
>frame-relay lmi-type cisco
>
>router isis
>passive-interface Loopback0
>net 49.0001.0000.0000.0003.00
>
>---------------------------------------------------------------
>R3 debug isis adj
>---------------------------------------------------------------
>
>4d19h: ISIS-Adj: Rec L1 IIH from DLCI 102 (Serial0/0), cir type L1L2, cir
>id 0000.0000.0001.01, length 1500
>4d19h: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial0/0
>4d19h: ISIS-Adj: Rec L2 IIH from DLCI 102 (Serial0/0), cir type L1L2, cir
>id 0000.0000.0001.01, length 1500
>4d19h: ISIS-Adj: Encapsulation failed for L2 LAN IIH on Serial0/0
>---------------------------------
>Yahoo! GeoCities
>Tenha seu lugar na Web. Construa hoje mesmo sua home page no Yahoo!
>GeoCities. I facil e gratis!
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:41 GMT-3