From: Scott Meeuwsen (scott@xxxxxxxxxxxx)
Date: Sat Dec 08 2001 - 22:54:45 GMT-3
I just aquired a new 2610 router for my lab with an ethernet and bri
interface. My problem is that in order to pass traffic through the router
from the ethernet to the bri interface all forms of route caching MUST be
off on the ethernet interface. Here are my observations:
Observations:
-Traffic to and from the ethernet interface passes fine with or without
route caching turned on. Tested from a workstation...
-Traffic to and from the bri interface passes fine. Tested from router
itself.
-When traffic is pushed through the router only the process switched packets
seem to make it through (I get a TCP handshake and that is about it...).
Tested from many workstations.
-Any sort of route caching causes the problem, including CEF, fast, and
flow.
What I did:
-Tried different IOS versions and feature sets.
-Used several different debug commands to watch traffic.
-Swapped WIC slots for the BRI card.
-Swapped all cables and hubs
-Tried tests from different PC's
-Stripped config of all access-list ,etc. result is absolute skeleton
config.
So now that I made it through that my question is, why? Is route caching
tied to the ethernet interface hardware in any way on this platform? Do I
have defective interface? Or is this a software problem that has spanned
IOS revs for this particular chassis and configuration? Have you ever seen
anything like this before? Any info is appreciated. If it is the hardware
I would like to return it to the seller... Thx!
Here is the skeleton config I am using:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
!
ip subnet-zero
!
isdn switch-type basic-dms100
!
!
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
! Knock this out and it goes poof
no ip route-cache
no ip mroute-cache
!
interface BRI0/0
ip address negotiated
ip nat outside
encapsulation ppp
dialer idle-timeout 2147483
dialer string 5551212
dialer hold-queue 16
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-dms100
isdn spid1 55555512120101 5551212
isdn spid2 55555512120101 5551212
ppp multilink
!
ip nat inside source list 1 interface BRI0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0/0
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
login
!
end
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:40 GMT-3