From: EA Louie (elouie@xxxxxxxxx)
Date: Wed Dec 05 2001 - 07:35:44 GMT-3
It doesn't need to be an ABR. Simply defining a summary route in ospf has
been sufficient for me. Since the router is an ASBR, the summary route
command works bi-directionally. You might need the route-map for other
things to control routing, but not necessarily for advertising the /24
summaries.
In this example, Sleepy is connected to Dopey over s0.1. Dopey's config in
inconsequential, but its routing table is shown for clarity.
I'm trying to make it as uncomplicated as possible, as I'm sure I'll run
into other problems that demand complexity in the lab. Also, I'm not sure
that I wouldn't get dinged for having statements that didn't need to be
there (although I guess they wouldn't really know that). I'd be afraid that
putting an extra not-asked-for area in the router might cost me points.
-e-
Sleepy#wr t
Building configuration...
!
interface Serial0.1 point-to-point
description to Dopey s0
bandwidth 64
ip address 170.100.2.1 255.255.255.0
no ip directed-broadcast
ip nat outside
no ip split-horizon
ipx network 1005
frame-relay interface-dlci 105
!
interface Serial0.2 multipoint
bandwidth 64
ip address 170.100.1.1 255.255.255.0
[snip]
!
interface TokenRing0
ip address 170.100.42.241 255.255.255.240
[snip]
!
interface BRI0
ip address 170.100.60.2 255.255.255.240
[snip]
!
router ospf 1
summary-address 170.100.60.0 255.255.255.0
summary-address 170.100.42.0 255.255.255.0
redistribute igrp 1 metric 1000 subnets
network 170.100.1.0 0.0.0.255 area 0
network 170.100.42.240 0.0.0.15 area 0
network 170.100.60.0 0.0.0.15 area 0
neighbor 170.100.1.3
neighbor 170.100.1.2
!
router igrp 1
redistribute ospf 1 route-map ospf2igrp
passive-interface Serial0.2
passive-interface TokenRing0
network 170.100.0.0
default-metric 64 10 255 1 1500
!
ip access-list extended OSPFSUMMARY
! take out the routes with the non /24 masks
deny ip host 170.100.42.240 host 255.255.255.240
deny ip host 170.100.60.0 host 255.255.255.240
permit ip any any
access-list 109 permit ip 1.1.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
route-map ospf2igrp permit 10
match ip address OSPFSUMMARY
Sleepy#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
170.100.0.0/16 is variably subnetted, 13 subnets, 2 masks
I 170.100.200.0/24 [100/158313] via 170.100.2.2, 00:00:00, Serial0.1
C 170.100.42.240/28 is directly connected, TokenRing0
O IA 170.100.70.0/24 [110/1568] via 170.100.1.3, 00:00:39, Serial0.2
[110/1568] via 170.100.1.2, 00:00:39, Serial0.2
O E2 170.100.90.0/24 [110/30000] via 170.100.1.2, 00:00:39, Serial0.2
O IA 170.100.80.0/24 [110/3125] via 170.100.1.3, 00:00:39, Serial0.2
C 170.100.2.0/24 is directly connected, Serial0.1
O IA 170.100.3.0/24 [110/3124] via 170.100.1.3, 00:00:39, Serial0.2
C 170.100.1.0/24 is directly connected, Serial0.2
! the two summary-routes
O 170.100.42.0/24 is a summary, 00:10:19, Null0
O 170.100.60.0/24 is a summary, 00:10:19, Null0
C 170.100.60.0/28 is directly connected, BRI0
O E1 170.100.50.0/24 [110/3324] via 170.100.1.3, 00:00:40, Serial0.2
I 170.100.51.0/24 [100/158313] via 170.100.2.2, 00:00:02, Serial0.1
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, TokenRing0
O E1 193.14.12.0/24 [110/3324] via 170.100.1.3, 00:00:41, Serial0.2
Sleepy#
Dopey#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
170.100.0.0/24 is subnetted, 11 subnets
C 170.100.200.0 is directly connected, TokenRing1
I 170.100.70.0 [100/158260] via 170.100.2.1, 00:00:02, Serial0
I 170.100.90.0 [100/158260] via 170.100.2.1, 00:00:02, Serial0
I 170.100.80.0 [100/158260] via 170.100.2.1, 00:00:02, Serial0
C 170.100.2.0 is directly connected, Serial0
I 170.100.3.0 [100/158260] via 170.100.2.1, 00:00:02, Serial0
I 170.100.1.0 [100/160250] via 170.100.2.1, 00:00:02, Serial0
I 170.100.42.0 [100/158260] via 170.100.2.1, 00:00:03, Serial0
I 170.100.60.0 [100/158260] via 170.100.2.1, 00:00:03, Serial0
I 170.100.50.0 [100/158260] via 170.100.2.1, 00:00:03, Serial0
C 170.100.51.0 is directly connected, TokenRing0
I 193.14.12.0/24 [100/158260] via 170.100.2.1, 00:00:03, Serial0
B 196.12.14.0/24 [20/0] via 170.100.200.7, 00:00:06
B 170.0.0.0/8 [200/0] via 0.0.0.0, 00:00:06, Null0
Dopey#
----- Original Message -----
From: <SFeldberg@edeltacom.com>
To: <albert_ccie@yahoo.com>
Cc: <ccielab@groupstudy.com>; "'Mike Schlenger'"
<mschlenger@n2nsolutions.com>; "'Vincent Zhang'" <vincentzhang@yahoo.com>
Sent: Monday, December 03, 2001 2:50 PM
Subject: RE: AGAIN! IGRP OSPF redis (Solution)
> The only way I was able to make this work was by making the OSPF
> redistribution router an ABR to enable the use of the area-range command.
>
> In my scenario, R6 and R5 are running IGRP 56 over ethernet. The IGRP
> domain is 192.168.x.0 /24. R5 has the p2mp FR connection to R7, which is
> running OSPF over the 216.248.176.252 /30 subnet with R7.
>
> Solution: Area 55 is added to R5, area 0 range 216.248.176.0 255.255.255.0
> command is added to R5. R5 redistributes OSPF 10 into IGRP 56 using the
> following route-map and access-list:
>
> router igrp 56
> redistribute ospf 10 route-map ospf2igrp
> !
> access-list 101 permit ip host 216.248.176.0 host 255.255.255.0
> !
> route-map ospf2igrp permit 10
> match ip address 101
>
>
> IGRP 56 on R6 now sees the summarized route
>
> r6#sh ip route
>
> C 192.168.6.0/24 is directly connected, Loopback0
> C 192.168.1.0/24 is directly connected, Ethernet0
> I 216.248.176.0/24 [100/8576] via 192.168.1.5, 00:00:16, Ethernet0
>
> Full configs for R5, R6 and R7:
>
> r5#sh run
> Building configuration...
>
> Current configuration : 1223 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r5
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 55.55.55.55 255.255.255.255
> !
> interface Ethernet0
> ip address 192.168.1.5 255.255.255.0
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0.2 multipoint
> ip address 216.248.176.254 255.255.255.252
> ip ospf network point-to-multipoint
> frame-relay interface-dlci 507
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface BRI0
> no ip address
> shutdown
> isdn x25 static-tei 0
> !
> router ospf 10
> router-id 5.5.5.5
> log-adjacency-changes
> area 0 range 216.248.176.0 255.255.255.0
> network 55.55.55.55 0.0.0.0 area 5
> network 216.248.176.252 0.0.0.3 area 0
> !
> router igrp 56
> redistribute ospf 10 route-map ospf2igrp
> network 192.168.1.0
> network 192.168.5.0
> default-metric 1 1 1 1 1
> !
> ip classless
> ip http server
> !
> access-list 101 permit ip host 216.248.176.0 host 255.255.255.0
> route-map ospf2igrp permit 10
> match ip address 101
> !
> !
> !
> line con 0
> privilege level 15
> logging synchronous
> line aux 0
> line vty 0 4
> login
> !
> end
>
> r5#sh ip ospf d
>
> OSPF Router with ID (5.5.5.5) (Process ID 10)
>
>
> Router Link States (Area 0)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 5.5.5.5 5.5.5.5 409 0x80000002 0xD8E 2
> 7.7.7.7 7.7.7.7 409 0x8000001C 0xD4A7 2
>
> Summary Net Link States (Area 0)
>
> Link ID ADV Router Age Seq# Checksum
> 55.55.55.55 5.5.5.5 424 0x80000001 0x113A
>
> Router Link States (Area 5)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 5.5.5.5 5.5.5.5 434 0x80000001 0xD556 1
>
> Summary Net Link States (Area 5)
>
> Link ID ADV Router Age Seq# Checksum
> 216.248.176.0 5.5.5.5 424 0x80000001 0xACF9
> r5#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 55.0.0.0/32 is subnetted, 1 subnets
> C 55.55.55.55 is directly connected, Loopback0
> I 192.168.6.0/24 [100/1600] via 192.168.1.6, 00:00:08, Ethernet0
> C 192.168.1.0/24 is directly connected, Ethernet0
> 216.248.176.0/24 is variably subnetted, 3 subnets, 3 masks
> C 216.248.176.252/30 is directly connected, Serial0.2
> O 216.248.176.253/32 [110/64] via 216.248.176.253, 00:06:39,
> Serial0.2
> O 216.248.176.0/24 is a summary, 00:06:39, Null0
> r5#
>
>
>
> Xyplex -012- LAB:6 session 2 resumed
>
> r6#sh run
> Building configuration...
>
> Current configuration : 687 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r6
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 192.168.6.1 255.255.255.0
> !
> interface Ethernet0
> ip address 192.168.1.6 255.255.255.0
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> shutdown
> frame-relay lmi-type cisco
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface BRI0
> no ip address
> shutdown
> isdn x25 static-tei 0
> !
> router igrp 56
> network 192.168.1.0
> network 192.168.6.0
> !
> ip classless
> ip http server
> !
> !
> !
> line con 0
> privilege level 15
> logging synchronous
> line aux 0
> line vty 0 4
> !
> end
>
> r6#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> C 192.168.6.0/24 is directly connected, Loopback0
> C 192.168.1.0/24 is directly connected, Ethernet0
> I 216.248.176.0/24 [100/8576] via 192.168.1.5, 00:01:13, Ethernet0
> r6#
>
>
>
> Xyplex -012- LAB:7 session 3 resumed
>
>
> r7#sh run
> Building configuration...
>
> Current configuration : 740 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r7
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no fair-queue
> no frame-relay inverse-arp
> !
> interface Serial0.2 multipoint
> ip address 216.248.176.253 255.255.255.252
> ip ospf network point-to-multipoint
> frame-relay interface-dlci 705
> !
> interface Serial1
> no ip address
> shutdown
> !
> router ospf 10
> router-id 7.7.7.7
> log-adjacency-changes
> network 216.248.176.252 0.0.0.3 area 0
> !
> ip classless
> ip http server
> !
> !
> !
> line con 0
> privilege level 15
> logging synchronous
> line aux 0
> line vty 0 4
> !
> end
>
> r7#sh ip ospf d
>
> OSPF Router with ID (7.7.7.7) (Process ID 10)
>
>
> Router Link States (Area 0)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 5.5.5.5 5.5.5.5 473 0x80000002 0xD8E 2
> 7.7.7.7 7.7.7.7 473 0x8000001C 0xD4A7 2
>
> Summary Net Link States (Area 0)
>
> Link ID ADV Router Age Seq# Checksum
> 55.55.55.55 5.5.5.5 1187 0x80000001 0x113A
> r7#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 55.0.0.0/32 is subnetted, 1 subnets
> O IA 55.55.55.55 [110/65] via 216.248.176.254, 00:07:46, Serial0.2
> 216.248.176.0/24 is variably subnetted, 2 subnets, 2 masks
> C 216.248.176.252/30 is directly connected, Serial0.2
> O 216.248.176.254/32 [110/64] via 216.248.176.254, 00:07:47,
> Serial0.2
> r7#
>
>
> Stephen Feldberg
> e ^ deltacom
> phone: 678.835.5437
> sfeldberg@edeltacom.com
>
>
>
> "Albert Lu"
> <albert_ccie@y To: <SFeldberg@edeltacom.com>
> ahoo.com> cc: <ccielab@groupstudy.com>,
"'Mike Schlenger'"
> <mschlenger@n2nsolutions.com>,
"'Vincent Zhang'"
> 12/03/2001 <vincentzhang@yahoo.com>
> 03:28 PM Subject: RE: AGAIN! IGRP OSPF
redis (NEW FINDING!!)
> Please respond
> to albert_ccie
>
>
>
>
>
>
> Steve,
>
> I guess my main problem is trying to get an /24 IGRP domain to see my OSPF
> domain's FR interface which is not a /24 that is in Area 0. Since IGRP
> domain is stuck right onto Area 0, I can't use 'area 0 range' to summarise
> it. If you put secondary addresses onto the FR interface, you are still
> going to only get the /32 route of the FR secondary address.
>
> Back in the ole' days of pre-12.1, you could redistribute connected which
> will redistribute all interface's ip address, and do a summary address.
Now
> you can't.
>
> Let me know if you found a solution =)
>
> Thanks
>
> Albert
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> SFeldberg@edeltacom.com
> Sent: Tuesday, December 04, 2001 1:24 AM
> To: albert_ccie@yahoo.com
> Cc: ccielab@groupstudy.com; 'Mike Schlenger'; 'Vincent Zhang'
> Subject: RE: AGAIN! IGRP OSPF redis (NEW FINDING!!)
>
>
> Albert,
>
> The way you have described your scenario is difficult to follow. Please
> post more information including relevant configs.
>
> Steve
>
>
>
> "Albert Lu"
> <albert_ccie@y To: <ccielab@groupstudy.com>
> ahoo.com> cc: "'Mike Schlenger'"
> <mschlenger@n2nsolutions.com>,
> <SFeldberg@edeltacom.com>,
> "'Vincent Zhang'" <vincentzhang@yahoo.com>
> 12/02/2001 Subject: RE: AGAIN! IGRP OSPF
> redis (NEW FINDING!!)
> 12:56 AM
> Please respond
> to albert_ccie
>
>
>
>
>
>
> Hello Group,
>
> I think I've stumbled upon something with using secondary addresses,
> redistribute connected and summary address in order to get the FLSM router
> to see the route.
>
> It works perfectly when you configure it, but after you reload your
> routers,
> the redistribution of the secondary address would not be done.
>
> I had to remove the secondary address statement, and reenter it into the
> interface, before the secondary address would be redistributed into OSPF
> from the redistribute connected. Since it didn't redistribute after the
> reload, it doesn't get summarised by the 'summary-address' statement.
>
> Please tell me this is not happening, and I've made a big mistake. As I
> don't know any other way of getting that route into FLSM router (area 0
> range doesn't work, since IGRP is connected to Area 0).
>
> Please don't give me any static, default, policy routing solution, as they
> are not allowed.
>
> Here's the interface config of a FR spoke:
>
> Current configuration : 267 bytes
> !
> interface Serial0.2 multipoint
> ip address 110.99.50.34 255.255.255.224 secondary
> ip address 110.99.50.4 255.255.255.224
> ip ospf authentication-key ipexpert
> ip ospf network point-to-multipoint
> frame-relay interface-dlci 405
> frame-relay interface-dlci 406
> end
>
> router ospf 10
> router-id 110.90.4.4
> log-adjacency-changes
> area 0 authentication
> summary-address 110.99.50.0 255.255.255.0
> redistribute connected metric-type 1 subnets route-map redis_conn
> passive-interface default
> no passive-interface Serial0.1
> no passive-interface Serial0.2
> network 110.90.4.0 0.0.0.255 area 0
> network 110.99.40.0 0.0.0.255 area 0
> network 110.99.50.0 0.0.0.31 area 0
> !
>
> access-list 10 deny 110.99.60.0
> access-list 10 permit any
> route-map redis_conn permit 10
> match ip address 10
> !
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> SFeldberg@edeltacom.com
> Sent: Sunday, December 02, 2001 2:57 AM
> To: Vincent Zhang
> Cc: ccielab@groupstudy.com; Mike Schlenger; nobody@groupstudy.com
> Subject: Re: AGAIN! IGRP OSPF redis
>
>
> Vincent,
>
> You must mean 12.0(20) as I am running the latest release of 12.1 code
> which is 12.1(11).
>
> Steve
>
>
>
> "Vincent
> Zhang" To: "Mike Schlenger"
> <mschlenger@n2nsolutions.com>,
> <vincentzhang@ <SFeldberg@edeltacom.com>
> yahoo.com> cc: <ccielab@groupstudy.com>,
> <nobody@groupstudy.com>
> Subject: Re: AGAIN! IGRP OSPF
> redis
> 11/30/2001
> 09:43 PM
>
>
>
>
>
>
> Hi, Mark and Steve,
>
> This does not work on my IOS ver 12.1(20), I heard that in some other 12.1
> main version it works well.
>
> Thanks, V
>
>
> ----- Original Message -----
> From: <SFeldberg@edeltacom.com>
> To: "Mike Schlenger" <mschlenger@n2nsolutions.com>
> Cc: <ccielab@groupstudy.com>; <nobody@groupstudy.com>; "'Vincent Zhang'"
> <vincentzhang@yahoo.com>
> Sent: Saturday, December 01, 2001 3:41 AM
> Subject: RE: AGAIN! IGRP OSPF redis
>
>
> >
> > Vincent,
> >
> > Here's what Mike's talking about:
> >
> > r2#sh run
> > Building configuration...
> >
> > Current configuration : 438 bytes
> > !
> > version 12.1
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname r2
> > !
> > !
> > !
> > !
> > !
> > !
> > ip subnet-zero
> > !
> > !
> > !
> > !
> > !
> > !
> > interface Ethernet0
> > no ip address
> > shutdown
> > !
> > interface Serial0
> > no ip address
> > shutdown
> > no fair-queue
> > !
> > interface Serial1
> > ip address 172.16.1.1 255.255.255.0
> > !
> > router igrp 13
> > network 172.16.0.0
> > !
> > ip classless
> > ip http server
> > !
> > !
> > !
> > line con 0
> > line aux 0
> > line vty 0 4
> > !
> > end
> >
> > r2#sh ip route
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter
> > area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is not set
> >
> > 172.16.0.0/24 is subnetted, 2 subnets
> > C 172.16.1.0 is directly connected, Serial1
> > I 172.16.2.0 [100/10002001] via 172.16.1.13, 00:00:18, Serial1
> > r2#
> >
> >
> >
> > Xyplex -012- LAB:13 session 2 resumed
> >
> > r1#sh run
> > Building configuration...
> >
> > Current configuration : 952 bytes
> > !
> > version 12.1
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname r1
> > !
> > !
> > !
> > !
> > !
> > !
> > ip subnet-zero
> > !
> > !
> > !
> > !
> > !
> > !
> > interface Loopback0
> > ip address 13.13.13.13 255.255.255.255
> > !
> > interface Ethernet0
> > no ip address
> > shutdown
> > !
> > interface Serial0
> > ip address 172.16.1.13 255.255.255.0
> > no fair-queue
> > clockrate 4000000
> > !
> > interface Serial1
> > ip address 172.16.2.13 255.255.255.240
> > clockrate 4000000
> > !
> > interface TokenRing0
> > no ip address
> > shutdown
> > !
> > router ospf 13
> > log-adjacency-changes
> > area 0 range 172.16.2.0 255.255.255.0
> > network 13.13.13.13 0.0.0.0 area 13
> > network 172.16.2.0 0.0.0.15 area 0
> > !
> > router igrp 13
> > redistribute ospf 13 route-map o2i
> > passive-interface Serial1
> > network 172.16.0.0
> > default-metric 1 1 1 1 1
> > !
> > ip classless
> > ip http server
> > !
> > access-list 101 permit ip host 172.16.2.0 host 255.255.255.0
> > route-map o2i permit 10
> > match ip address 101
> > !
> > !
> > !
> > line con 0
> > line aux 0
> > line vty 0 4
> > !
> > end
> >
> > r1#sh ip route
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter
> > area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is not set
> >
> > 172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
> > C 172.16.1.0/24 is directly connected, Serial0
> > O 172.16.2.0/24 is a summary, 00:01:07, Null0
> > C 172.16.2.0/28 is directly connected, Serial1
> > 13.0.0.0/32 is subnetted, 1 subnets
> > C 13.13.13.13 is directly connected, Loopback0
> > r1#u all
> > All possible debugging has been turned off
> > r1#
> >
> > Steve
> >
> >
> >
> > Mike Schlenger
> > <mschlenger@n2nsolu To: "'Vincent Zhang'"
> <vincentzhang@yahoo.com>,
> > tions.com> ccielab@groupstudy.com
> > Sent by: cc:
> > nobody@groupstudy.c Subject: RE: AGAIN!
> IGRP
> OSPF redis
> > om
> >
> >
> > 11/30/2001 02:09 PM
> > Please respond to
> > Mike Schlenger
> >
> >
> >
> >
> >
> >
> > You have to summarize your routes into a mask IGRP will understand.
> Summary
> > address will not work as it summarizes into OSPF areas. Try "area x
range
> > x.x.x.0 x.x.x.255". Then redistribute into IGRP. I would watch out for
> the
> > secondary address. Proctors might not like that solution.
> >
> > Mike
> >
> > Mike Schlenger
> > CCIE #7079
> > N2N Solutions
> > mschlenger@n2nsolutions.com
> > 847.592.3912
> >
> > -----Original Message-----
> > From: Vincent Zhang [mailto:vincentzhang@yahoo.com]
> > Sent: Friday, November 30, 2001 12:09 PM
> > To: ccielab@groupstudy.com
> > Subject: AGAIN! IGRP OSPF redis
> >
> >
> > Hi All,
> >
> > Pls consider the following simple topology for redis OSPF into IGRP.
> >
> >
> > s0 s1
> > R2----------------------R1---------------------
> > 172.16.1.0/24 172.16.2.0/28
> >
> > R2 runs IGRP only
> > R1 runs IGRP on S0 and OSPF on S1, and there is a big OSPF cloud
attached
> > from
> > S1.
> > you are trying to redis ospf into igrp, in this case, I am talking how
to
> > redis the 172.16.2.0/28 into R1.
> >
> >
> > I know in ios 12.1, the normal "redis connect" and "summary" way
> doesn't
> > work, but I also hear about that the "second address" works, any one
> could
> > show me a light about where to put the secondary address.
> >
> >
> > Thanks, V
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:38 GMT-3