From: SFeldberg@xxxxxxxxxxxxx
Date: Mon Dec 03 2001 - 16:01:44 GMT-3
Andrew,
I have built a scenario where R5 and R6 are connected via ethernet and
serial links. Both are running 2 OSPF processes, where processes 51 and 61
form an adjacency over ethernet and processes 52 and 62 use the serial
link.
r5#sh ip ospf n
Neighbor ID Pri State Dead Time Address Interface
6.6.6.1 1 FULL/DR 00:00:33 60.60.60.6 Ethernet0
6.6.6.2 1 FULL/ - 00:00:32 50.50.50.6 Serial0
r5#
r6#sh ip ospf n
Neighbor ID Pri State Dead Time Address Interface
5.5.5.1 1 FULL/BDR 00:00:37 60.60.60.5 Ethernet0
5.5.5.2 1 FULL/ - 00:00:38 50.50.50.5 Serial0
r6#
R5 is redistributing a connected network (loopback0 10.10.10.0 /24) into
process 51, summarizing it to 10.10.0.0 /16, then redistributing the
summary to process 52- one method by which you can change the length of the
masks for the purpose of vlsm/flsm redistribution.
r5#sh ip route conn
50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Serial0
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.20.20.64/26 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, Loopback0
60.0.0.0/24 is subnetted, 1 subnets
C 60.60.60.0 is directly connected, Ethernet0
r5#sh ip route ospf 51
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 10.10.0.0/16 is a summary, 00:22:45, Null0
30.0.0.0/32 is subnetted, 1 subnets
O 30.30.30.1 [110/51] via 60.60.60.6, 00:23:33, Ethernet0
r5#sh ip route ospf 52
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 20.20.20.0/24 is a summary, 00:19:17, Null0
40.0.0.0/32 is subnetted, 1 subnets
O 40.40.40.1 [110/65] via 50.50.50.6, 00:25:29, Serial0
Xyplex -012- LAB:6 session 3 resumed
r6#sh ip route conn
50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Serial0
40.0.0.0/24 is subnetted, 1 subnets
C 40.40.40.0 is directly connected, Loopback1
60.0.0.0/24 is subnetted, 1 subnets
C 60.60.60.0 is directly connected, Ethernet0
30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, Loopback0
r6#sh ip route ospf 61
20.0.0.0/24 is subnetted, 1 subnets
O E2 20.20.20.0 [110/1] via 60.60.60.5, 00:24:52, Ethernet0
r6#sh ip route ospf 62
10.0.0.0/16 is subnetted, 1 subnets
O E2 10.10.0.0 [110/1] via 50.50.50.5, 00:20:35, Serial0
Here are the complete configs for this scenario.
r5#sh run
Building configuration...
Current configuration : 1667 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface Loopback1
ip address 20.20.20.65 255.255.255.192
!
interface Ethernet0
ip address 60.60.60.5 255.255.255.0
ip ospf cost 50
!
interface Serial0
ip address 50.50.50.5 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 50.50.50.6 506 broadcast
frame-relay interface-dlci 506
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
!
router ospf 51
router-id 5.5.5.1
log-adjacency-changes
summary-address 10.10.0.0 255.255.0.0
redistribute connected subnets route-map conn2ospf51
redistribute ospf 52 subnets route-map O52toO51
network 60.60.60.0 0.0.0.255 area 0
!
router ospf 52
router-id 5.5.5.2
log-adjacency-changes
summary-address 20.20.20.0 255.255.255.0
redistribute connected subnets route-map conn2ospf52
redistribute ospf 51 subnets route-map O51toO52
network 50.50.50.0 0.0.0.255 area 0
!
ip classless
ip http server
!
access-list 151 permit ip host 10.10.0.0 host 255.255.0.0
access-list 152 permit ip host 20.20.20.0 host 255.255.255.0
route-map O51toO52 permit 10
match ip address 151
!
route-map O52toO51 permit 10
match ip address 152
!
route-map conn2ospf51 permit 10
match interface Loopback0
!
route-map conn2ospf52 permit 10
match interface Loopback1
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
login
!
end
r5#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Serial0
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 20.20.20.0/24 is a summary, 00:06:41, Null0
C 20.20.20.64/26 is directly connected, Loopback1
40.0.0.0/32 is subnetted, 1 subnets
O 40.40.40.1 [110/65] via 50.50.50.6, 00:12:53, Serial0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 10.10.0.0/16 is a summary, 00:10:13, Null0
C 10.10.10.0/24 is directly connected, Loopback0
60.0.0.0/24 is subnetted, 1 subnets
C 60.60.60.0 is directly connected, Ethernet0
30.0.0.0/32 is subnetted, 1 subnets
O 30.30.30.1 [110/51] via 60.60.60.6, 00:11:03, Ethernet0
r5#sh ip ospf
Routing Process "ospf 52" with ID 5.5.5.2 and Domain ID 0.0.0.52
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an autonomous system boundary router
Redistributing External Routes from,
connected, includes subnets in redistribution
ospf 51, includes subnets in redistribution
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 2. Checksum Sum 0x138A7
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 18 times
Area ranges are
Number of LSA 5. Checksum Sum 0x1E7DE
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Routing Process "ospf 51" with ID 5.5.5.1 and Domain ID 0.0.0.51
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an autonomous system boundary router
Redistributing External Routes from,
connected, includes subnets in redistribution
ospf 52, includes subnets in redistribution
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 2. Checksum Sum 0x1459D
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 14 times
Area ranges are
Number of LSA 8. Checksum Sum 0x46840
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
r5#
Xyplex -012- LAB:6 session 3 resumed
r6#sh run
Building configuration...
Current configuration : 1159 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
ip address 30.30.30.1 255.255.255.0
!
interface Loopback1
ip address 40.40.40.1 255.255.255.0
!
interface Ethernet0
ip address 60.60.60.6 255.255.255.0
!
interface Serial0
ip address 50.50.50.6 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 50.50.50.5 605 broadcast
frame-relay interface-dlci 605
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
!
router ospf 61
router-id 6.6.6.1
log-adjacency-changes
network 30.30.30.0 0.0.0.255 area 0
network 60.60.60.0 0.0.0.255 area 0
!
router ospf 62
router-id 6.6.6.2
log-adjacency-changes
network 40.40.40.0 0.0.0.255 area 0
network 50.50.50.0 0.0.0.255 area 0
!
ip classless
ip http server
!
route-map conn2ospf permit 10
match interface Ethernet0
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
!
end
r6#sh run
Building configuration...
Current configuration : 1159 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
ip address 30.30.30.1 255.255.255.0
!
interface Loopback1
ip address 40.40.40.1 255.255.255.0
!
interface Ethernet0
ip address 60.60.60.6 255.255.255.0
!
interface Serial0
ip address 50.50.50.6 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 50.50.50.5 605 broadcast
frame-relay interface-dlci 605
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
!
router ospf 61
router-id 6.6.6.1
log-adjacency-changes
network 30.30.30.0 0.0.0.255 area 0
network 60.60.60.0 0.0.0.255 area 0
!
router ospf 62
router-id 6.6.6.2
log-adjacency-changes
network 40.40.40.0 0.0.0.255 area 0
network 50.50.50.0 0.0.0.255 area 0
!
ip classless
ip http server
!
route-map conn2ospf permit 10
match interface Ethernet0
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
!
end
r6#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Serial0
20.0.0.0/24 is subnetted, 1 subnets
O E2 20.20.20.0 [110/1] via 60.60.60.5, 00:10:09, Ethernet0
40.0.0.0/24 is subnetted, 1 subnets
C 40.40.40.0 is directly connected, Loopback1
10.0.0.0/16 is subnetted, 1 subnets
O E2 10.10.0.0 [110/1] via 50.50.50.5, 00:05:49, Serial0
60.0.0.0/24 is subnetted, 1 subnets
C 60.60.60.0 is directly connected, Ethernet0
30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, Loopback0
r6#sh ip ospf
Routing Process "ospf 62" with ID 6.6.6.2 and Domain ID 0.0.0.62
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 2. Checksum Sum 0x138A7
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm executed 17 times
Area ranges are
Number of LSA 2. Checksum Sum 0xEFE1
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Routing Process "ospf 61" with ID 6.6.6.1 and Domain ID 0.0.0.61
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 2. Checksum Sum 0x1459D
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm executed 13 times
Area ranges are
Number of LSA 3. Checksum Sum 0x1C6F8
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
r6#
Stephen Feldberg
e ^ deltacom
phone: 678.835.5437
sfeldberg@edeltacom.com
andrew.waldwyn
@bt.com To: ccielab@groupstudy.com
Sent by: cc:
nobody@groupst Subject: Dual OSPF processes
udy.com
12/03/2001
11:07 AM
Please respond
to
andrew.waldwyn
Hi,
Has anyone had any issues with the above? I've allocated a loopback to a
2nd
process and tried redistributing connected specifying just that interface
so
that this loopback becomes a T5 in the 2nd process, then redistributed the
2nd process into the 1st.
I also passived all the interfaces on that router for the 2nd process.
Any working configs out there would be much appreciated?
TIA
Andy
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:36 GMT-3