BVI again (with serial and token and IPX)

From: alain faure (alainfaure@xxxxxxxx)
Date: Sat Nov 24 2001 - 18:59:23 GMT-3


   
Hello,

It's a bit of a long mail but i really cannot find the point.

Here is the design :

R1(eth)---(eth)R3(serial 1)--------------(serial 1)R2(token 0)
                                              (serial 0)
                                                 |
                                                 |
                                          frame relay

I installed :
On r2 serial 1 and token 0 in the bridge-group 1
On r2 a IRB with BVI 1

The aim is to bridge IPX between serial 1 and token 0
and to route IPX this two with BVI 1.

IP is always bridged.

As you will see in the text below IPX is send by BVI 1
IPX paquets are received on the serial 1 but not relayed to the BVI 1
interface.

I use IOS IP/IPX/DEC 12.0.20 (before i was using 12.0.8)

(*R2 configuration *)

version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service tcp-small-servers
!
hostname r2
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0000.30b1.2be1 (*routing ipx allowed*)
clock timezone GMT 1
clock summer-time GMT+1 recurring last Sun Mar 2:00 last Sun Oct 2:00
bridge irb (*irb definition*)
!
!
!
interface Loopback0
 ip address 200.200.200.2 255.255.255.255
 no ip directed-broadcast
 ipx network 208
!
interface Serial0
 ip address 192.168.248.22 255.255.255.240
 no ip directed-broadcast
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 ipx network 248
 ipx type-20-propagation
 frame-relay map ipx 248.0006.3acf.1f0d 208 broadcast
 frame-relay map ip 192.168.248.28 208 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 ip address 172.18.0.2 255.255.0.0
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 bridge-group 1
!
interface TokenRing0
 mtu 1500 (*i have also tried to put 1500 on bvi *)
 ip address 10.29.0.2 255.255.0.0
 no ip redirects
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 ring-speed 16
 standby use-bia
 standby timers 5 15
 standby priority 110
 standby preempt
 standby ip 10.29.0.1
 standby track Serial1 10
 bridge-group 1
!
interface BVI1
 no ip address
 no ip directed-broadcast
 ipx network 123
 no ipx route-cache
 ipx type-20-propagation
 ipx accounting
!
router ospf 10
 network 10.29.0.0 0.0.255.255 area 1
 network 172.18.0.0 0.0.255.255 area 1
 network 200.200.200.2 0.0.0.0 area 1
!
ip classless
!
!
!
!
bridge 1 protocol ieee
 bridge 1 route ip(* no bridge 1 route ipx is default*)
 no bridge 1 bridge ip (* bridge 1 bridge ipx is default*)
alias exec s sh run
alias exec c conf t
alias exec w write mem
alias exec i sh ip int brief
alias exec u undeb all
alias exec ix sh ipx int brief
alias exec r sh ip route
alias exec rx sh ipx route
alias exec * clear ip route *
alias exec x* clear ipx route *
alias exec b* clear ip bgp *
alias exec b sh ip bgp
alias exec bn sh ip bgp nei
alias exec on sh ip ospf nei
alias exec od sh ip ospf data
alias exec fm sh frame map
alias exec fv sh frame pvc
!
line con 0
 exec-timeout 0 0
 length 0
 transport input none
line aux 0
 exec-timeout 0 0
 password cisco
 login
 transport input all
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
ntp authentication-key 1 md5 110A1016141D 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 17180059
ntp server 200.200.200.4 key 1
end

(*now is some show on R2 *)

r2#sh int bvi 1
BVI1 is up, line protocol is up
  Hardware is BVI, address is 0000.0c8d.d487 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer (*funny no thingh
received*)
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     457 packets output, 29102 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
r2#

r2#sh bridge serial 1

Total of 300 station blocks, 297 free
Codes: P - permanent, S - self

Bridge Group 1:

    Address Action Interface Age RX count TX count
0048.5450.0645 forward Serial1 0 296 0
0000.0c8c.8152 forward Serial1 0 456 0

r2#
(*------------------------------------*)
(*in this example; it seemes that the ping go away from R2 by R3, ping
effectively R1, go back by R3[i have see that on R3], but dont go back in R2
between the serial and the BVI*)

(*before ping de R2 to R1*)
r2#sh bridge 1 ver

Total of 300 station blocks, 297 free
Codes: P - permanent, S - self

BG Hash Address Action Interface VC Age RX count TX
count
 1 43/0 0048.5450.0645 forward Serial1 - 0 297
0
 1 D3/0 0000.0c8c.8152 forward Serial1 - 0 456
0(*here*)
 1 E0/0 0000.0c31.9575 forward TokenRing0 - 0 3774
11

Flood ports RX count TX count
Serial1 1194 3769
TokenRing0 3769 1194

r2#
r2#ping 123.0000.0c8c.8152
Translating "123.0000.0c8c.8152"

Type escape sequence to abort.
Sending 5, 100-byte IPXcisco Echoes to 123.0000.0c8c.8152, timeout is 2
seconds:
.....
Success rate is 0 percent (0/5)

(*after le ping*)

r2#sh bridge 1 ver

Total of 300 station blocks, 297 free
Codes: P - permanent, S - self

BG Hash Address Action Interface VC Age RX count TX
count
 1 43/0 0048.5450.0645 forward Serial1 - 0 299
0
 1 D3/0 0000.0c8c.8152 forward Serial1 - 0 462
0 (*here + 6 : at least 5 packets from the ping*)
 1 E0/0 0000.0c31.9575 forward TokenRing0 - 0 3782
11

Flood ports RX count TX count
Serial1 1197 3777
TokenRing0 3777 1197

r2#



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:22 GMT-3