Re: Merge ISDN Simulator Problem

From: Mark.Reyero@xxxxxxxxxxxxx
Date: Wed Nov 21 2001 - 12:08:54 GMT-3


   
Brian, Chris, Bryan & everyone who has been helpful thus far...

Here is how everything is configed:

MERGE (defaults):
Switch Type: NT-1
DX25 PHF: OFF
NAIL UP: NONE
DEFAULTS: NO
CALLER ID: OFF
DISPLAY: OFF
EXTS: OFF

A 2621 with a WIC1BU is plugged into Port 1, U interface
2520 with S/T port is plugged into Port 2, S/T interface

SPIDS and LDN were left as defaults, based upon Merge Documentation:
First Device at Port 1: SPID 0555100001 DN (800) 5551000
First Device at Port 2: SPID 0555200001 DN (800) 5552000
Second Device at Port 1: SPID: 0555300001 DN (800) 5553000
Second Device at Port 2: SPID: 0555400001 DN (800) 5554000

RouterA (2621) config:
hostname RouterA
!
enable password ccie
!
username RouterB password 0 cisco
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!
interface BRI0/0
 ip address 192.168.2.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 300
 dialer map ip 192.168.2.2 name RouterB 5552000
 dialer load-threshold 1 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0555100001 5551000
 isdn spid2 0555300001 5553000
 ppp authentication chap
 ppp multilink
!
!omitted
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 password ccie
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 0 0
 password ccie
 logging synchronous
 login
!

RouterB (2520)
hostname RouterB
!
enable password ccie
!
username RouterA password 0 cisco
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
 no keepalive
!
!omitted
!
interface BRI0
 ip address 192.168.2.2 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 300
 dialer map ip 192.168.2.1 name RouterA 5551000
 dialer load-threshold 128 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0555200001 5552000
 isdn spid2 0555400001 5554000
 ppp authentication chap
 ppp multilink
!
router eigrp 1
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 password ccie
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 0 0
 password ccie
 logging synchronous
 login
!
end

According to the following show isdn stat, Layer 1 is active on both ends,
and Layer 2 Multiple Frame Established. Curiously, notice how Spid1 on
RouterB is recognized as valid?

RouterA#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 66, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI 66, ces = 1, state = 6(not initialized)
            spid1 configured, spid1 sent, spid1 NOT valid
        TEI Not Assigned, ces = 2, state = 1(terminal down)
            spid2 configured, spid2 NOT sent, spid2 NOT valid
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Number of L2 Discards = 0, L2 Session ID = 15
    Total Allocated ISDN CCBs = 0

RouterB#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 65, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI 64, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 65, ces = 2, state = 6(not initialized)
            spid2 configured, spid2 sent, spid2 NOT valid
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Number of L2 Discards = 0, L2 Session ID = 3
    Total Allocated ISDN CCBs = 0

Next thing I do is to literally unplug the Cat5 from the Merge ports, wait 2
seconds, plug back in. Now look at the sh isdn stat!!!!!

RouterA#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 67, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 68, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI 67, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 1, tid = 1
        TEI 68, ces = 2, state = 5(init)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 3, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Number of L2 Discards = 0, L2 Session ID = 18
    Total Allocated ISDN CCBs = 0

RouterB#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 69, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 70, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI 69, ces = 1, state = 5(init)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 70, ces = 2, state = 5(init)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 4, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Number of L2 Discards = 0, L2 Session ID = 9
    Total Allocated ISDN CCBs = 0

SPIDS are now showing as valid?!?!?



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:20 GMT-3