Re: MTU for VoIP traffic

From: Aaron T. Hassan (tyang@xxxxxxxxxxxx)
Date: Tue Nov 20 2001 - 16:51:14 GMT-3


   
Mike, here are configs for the gateway router 2621 and CiscoVoIP 5300 on
the LAN.

first of all, "sh int" on 2621:

FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0001.96e3.a640 (bia 0001.96e3.a640)
  Internet address is xxxx.182/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 3/255, rxload 4/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 10Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 1631000 bits/sec, 2682 packets/sec
  5 minute output rate 1259000 bits/sec, 1790 packets/sec
     678798921 packets input, 1577560122 bytes
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast
     0 input packets with dribble condition detected
     461254375 packets output, 1437474282 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up
  Hardware is AmdFE, address is 0001.96e3.a641 (bia 0001.96e3.a641)
  Internet address is xxx.65/26
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 4/255, rxload 3/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 1265000 bits/sec, 1787 packets/sec
  5 minute output rate 1628000 bits/sec, 2679 packets/sec
     461407337 packets input, 1459769135 bytes
     Received 77814 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast
     0 input packets with dribble condition detected
     678941081 packets output, 1595966232 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 11935998 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

the Cisco 2621:
----------------------------------------------------------------------------
--------------
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec localtime
service timestamps log datetime
service password-encryption
!
hostname xxx
!
logging buffered 4096 debugging
!
memory-size iomem 20
ip subnet-zero
ip cef
!
!
!
interface FastEthernet0/0
  description Link to ISP
 ip address xx.xx.xx.182 255.255.255.252
 no ip directed-broadcast
 speed 10
 full-duplex
 no cdp enable
!
interface FastEthernet0/1
 description Connection to LAN
 ip address 216.xxx.xxx.65 255.255.255.192
 no ip directed-broadcast
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 xxx
no ip http server
!
no cdp run
snmp-server engineID local xxx
snmp-server community xx RO
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 xxx
 login
!
no scheduler allocate
end
----------------------------------------------------------------------------
-----------------------------
The Cisco5300:

Current configuration:
!
!
version 12.1
no service pad
service timestamps debug datetime msec
service timestamps log uptime
service password-encryption
!
hostname xxx
!
logging buffered 20000 debugging
no logging console
aaa new-model
aaa accounting connection h323 start-stop group radius
enable secret 5 $xxxx
!
!
!
resource-pool disable
!
!
clock timezone GMT -4
clock calendar-valid
calltracker enable
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
isdn switch-type primary-5ess
isdn voice-call-failure 0
call rsvp-sync
voice rtp send-recv
!
voice class codec 1
 codec preference 1 g729br8 bytes 40
 codec preference 2 g729r8 bytes 40
!
voice class codec 2
 codec preference 1 g723ar53
!
voice class codec 3
 codec preference 1 g723ar63 bytes 48
!
!
!
!
!
fax interface-type vfc
mta receive maximum-recipients 0
!
dial-control-mib retain-timer 60
dial-control-mib max-size 1200
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 clock source line secondary 2
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
gw-accounting h323
gw-accounting voip
!
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet0
 no ip address
 no ip mroute-cache
 shutdown
 no cdp enable
 ip rtp priority 16384 16383 2000
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial1
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial2
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial3
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial0:23
 no ip address
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 isdn T203 10000
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 isdn T203 10000
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 isdn T203 10000
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 description Ethernet to ISP
 ip address 216.xxx.xxx.70 255.255.255.192
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
 no cdp enable
 h323-gateway voip interface
 h323-gateway voip id xxx ipaddr 216.xxx.xxx.xxx 1718
 h323-gateway voip h323-id xxx
 h323-gateway voip tech-prefix 1260#
 h323-gateway voip tech-prefix 416#
 ip rtp priority 16384 16383 2000
!
ip classless
ip route 0.0.0.0 0.0.0.0 216.xxx.xxx.65
no ip http server
!
!
radius-server host 216.xxx.xxx.84 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key 7 xxx
!
voice-port 0:D
!
voice-port 1:D
!
voice-port 2:D
!
voice-port 3:D
!
dial-peer voice 99 voip
 incoming called-number .
 destination-pattern 4198..T
 progress_ind setup enable 3
 voice-class codec 1
 session target ipv4:xxx.xxx.xxx.xxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 fax rate 9600
 ip precedence 5
!
dial-peer voice 2 voip
 incoming called-number .
 destination-pattern 0112..T
 progress_ind setup enable 3
 voice-class codec 1
 session target ipv4:xxx.xxx.xxx.xxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 fax rate 9600
 ip precedence 5
!
dial-peer voice 1809 voip
 incoming called-number .
 destination-pattern 1809..T
 progress_ind setup enable 3
 voice-class codec 1
 session target ipv4:xxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 fax rate 9600
 ip precedence 5
!
dial-peer voice 1868 voip
 incoming called-number .
 destination-pattern 1868.......
 progress_ind setup enable 3
 session target ipv4:xxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 ip precedence 5
!
dial-peer voice 151498 voip
 incoming called-number .
 destination-pattern 514098.......T
 progress_ind setup enable 3
 session protocol sipv2
 session target ipv4:xxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 fax rate 9600
 ip precedence 5
!
.........skipped
!
dial-peer voice 38098 voip
 destination-pattern 98....T
 session target ipv4:xxxx
 codec g723r63
 ip precedence 5
!
dial-peer voice 5521 voip
 destination-pattern 5521T
 progress_ind setup enable 3
 session target ipv4:xxxx
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 codec g723r63
 ip precedence 5
!
dial-peer voice 111 pots
 destination-pattern 11111
 direct-inward-dial
 port 2:D
!
num-exp 0117555....... 7555.......
num-exp 868....... 1868.......
num-exp 01162......... 9662.........
num-exp 876....... 18761.......
num-exp 011368....... 68.......
num-exp 74121.......... 7412..........
num-exp 58261.......... 5826..........
num-exp 876187 100
num-exp 01567 10348
..........
num-exp xxxx
num-exp 0115521* 5521*
num-exp 01195....... 95.......
num-exp 0119821........ 509821......
num-exp 0119821....... 509821.....
num-exp 0119821...... 509821....
num-exp 01198* 98*
gateway
 resource threshold high 100 low 95
!
banner motd ^Cc
***********************************************************

^C
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 access-class 3 in
 exec-timeout 60 0
 password 7 xxx
 absolute-timeout 60
line vty 5 999
 absolute-timeout 60
!
ntp clock-period 17179955
ntp master
ntp server 128.100.100.128
end

----- Original Message -----
From: "Mike Schlenger" <mschlenger@n2nsolutions.com>
To: "'Aaron T. Hassan'" <tyang@attcanada.ca>; "Ccielab (E-mail)"
<ccielab@groupstudy.com>
Sent: Tuesday, November 20, 2001 2:12 PM
Subject: RE: MTU for VoIP traffic

> Can you post (or email) your config? I work alot with voip and have never
> seen this before.
>
> Mike
> CCIE #7079
>
> -----Original Message-----
> From: Aaron T. Hassan [mailto:tyang@attcanada.ca]
> Sent: Tuesday, November 20, 2001 10:06 AM
> To: Ccielab (E-mail)
> Subject: MTU for VoIP traffic
>
>
> My 2621 is always running freakly busy, the CPU usage is constantly at
> around 80%, I had tried different IOS versions but nothing help much. The
> MRTG report shows the bandwidth usage is just at 400k/ps in max, no
> throttles on both Eth interfaces. Why the CPU usage is so high? I had
> eliminated the hardware issue(pls see sh ver below). I wonder it relates
to
> the VoIP traffic, which cause more processing power, Cisco document
suggests
> to change MTU to 500. Anyone knows about this? will it help? or do you
> experience the similar problems? thanks.
>
>
> Cisco Internetwork Operating System Software
> IOS (tm) C2600 Software (C2600-I-M), Version 12.0(4)T, RELEASE SOFTWARE
> (fc1)
> Copyright (c) 1986-1999 by cisco Systems, Inc.
> Compiled Wed 28-Apr-99 16:50 by kpma
> Image text-base: 0x80008088, data-base: 0x806B44EC
>
> ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
>
> ptime uptime is 2 days, 13 hours, 52 minutes
> System restarted by reload
> System image file is "flash:c2600-i-mz.120-4.T.bin"
>
> cisco 2621 (MPC860) processor (revision 0x102) with 26624K/6144K bytes of
> memory.
> Processor board ID JAB0416013M (3352220023)
> M860 processor: part number 0, mask 49
> Bridging software.
> X.25 software, Version 3.0.0.
> 2 FastEthernet/IEEE 802.3 interface(s)
> 32K bytes of non-volatile configuration memory.
> 8192K bytes of processor board System flash (Read/Write)
>
> Configuration register is 0x2102
>
>
> ----- Original Message -----
> From: "Knellinger, Mark" <KnelliMS@tvratings.com>
> To: "'afiddler'" <afiddler@wi.rr.com>; "Ccielab (E-mail)"
> <ccielab@groupstudy.com>
> Sent: Tuesday, November 20, 2001 10:33 AM
> Subject: RE: MTU mismatch on token-ring OSPF network
>
>
> > Just set the MTU on the interface manually on one side.
> > conf t
> > int to 0
> > mtu ?
> >
> >
> > Mark
> >
> > -----Original Message-----
> > From: afiddler [mailto:afiddler@wi.rr.com]
> > Sent: Monday, November 19, 2001 4:53 PM
> > To: Ccielab (E-mail)
> > Subject: MTU mismatch on token-ring OSPF network
> >
> >
> > For you token-ring fans (all three of you):
> >
> > I have a few older routers (2500's) and a one newer router (3640) with
> > token-ring interfaces. I have run across an OSPF MTU mismatch problem
> that
> > I consider to be a "gotcha" if you don't know about it. The old routers
> > with an MTU of 4464 on their token-ring interfaces will not neighbor up
> with
> > the newer router that has an MTU of 8136. I see debug messages as
follows
> > on the older routers, which also reflects their ability to detect the
MTU
> > mismatch:
> >
> > 01:57:32: OSPF: Nbr 200.0.0.1 has larger interface MTU
> >
> > CCO has a tech note about this problem (URL is below). The tech note
> > indicates that MTU mismatch detection was introduced in 12.0(3) to
comply
> > with the OSPF RFC. The "IP OSPF MTU-IGNORE" command was introduced in
> > 12.1(3) to optionally "turn off" mismatch detection. Note that the
v12.2
> > OSPF command documentation erroneously indicates the "IP OSPF
MTU-IGNORE"
> > was introduced in 12.0(3). Instead, I believe there is a gap in the IOS
> > between the version that supports detection of MTU mismatch and the
> version
> > that provides the "MTU-IGNORE" command.
> >
> > The tech note indicates that the IOS does not support changing MTU on a
> LAN
> > interface. With respect to the OSPF problem, that is not the case. In
> > fact, it's the only way I am able to get OSPF to neighbor up on a
> token-ring
> > network with my older routers running 12.0(18) code. I just change the
> MTU
> > on the router with the default MTU of 8136, down to 4464, and they
> neighbor
> > up immediately.
> >
> > The tech note also indicates that the need for the IP OSPF MTU-IGNORE
> > statement is rare. I am not clear on their reasoning, particularly
> because
> > they also say that you can't change the MTU on a LAN interface. What
else
> > can you do (besides not use token-ring anymore ;-)?
> >
> > This problem is not specific to the mix of "older" and "newer" routers.
I
> > ran into the same problem recently when I attended a training class,
> setting
> > up OSPF over token-ring between two seemingly identical 2600 routers!
> >
> > It would have to be something to watch for anytime you set up OSPF over
a
> > token-ring supporting more than one router and the routers are running
> > 12.0(3) and up but less than 12.1(3). With these IOS versions, the
> routers
> > would detect MTU mismatches but would lack the OSPF parameter to ignore
> > them. The only other option is to change the MTU on the token-ring
> > interface of the larger MTU router to match the smaller MTU router using
> the
> > interface command "mtu nnnn", where the n's represent the lower MTU in
> > bytes.
> >
> > If I am not mistaken, a similar issue exists with IS-IS routers on a
> > token-ring network. I tried the same test with ISIS defined instead of
> OSPF,
> > but was unable to resolve the MTU mismatch by reducing the MTU on my
newer
> > router. CCO has a tech note on this issue as well (see URL below), but
> > their example involves two serial interfaces (also note that the link to
> > this URL from the Cisco > Service & Support > Technical Assistance
Center
> >
> > Technologies > Integrated Intermediate System-to-Intermediate System
> (IS-IS)
> > > Implementation and Configuration menu points to a different URL). As
> > they do in the OSPF tech note, they suggest setting the MTU to the same
> > value on all ISIS routers on the network. This method did not work
> > successfully for me, even when manually setting MTU on both the old and
> new
> > routers. Their other suggestion was to use the "no isis hello padding"
on
> > both routers. To test this, I upgraded my 2504 to v12.1(5)T10, since
this
> > command is not supported in 12.0(18). I tried this separately and in
> > combination with setting the MTU on the 3640 to match the MTU on the
2504,
> > to no avail. Just to verify my results, I configured the two older
> routers
> > with ISIS to see if they neighbored up. They did immediately.
> >
> > Does anyone know to circumvent the problem on routers running ISIS over
> > token-ring with mismatched MTU's?
> >
> > http://www.cisco.com/warp/public/104/12.html
> >
> > http://www.cisco.com/warp/public/97/isis_mtu.html



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:19 GMT-3