CCBootcamp Lab 1 neighbor commands at the spokes (FR)

From: Frei Peter (Peter.Frei@xxxxxxxx)
Date: Sun Nov 18 2001 - 10:33:49 GMT-3


   
Hi all
The solution from CCBootcamp with neighbor commands at the spokes does not
have much sense
for me. How is your opinion?
Has anybody a solution that we can ping the own FR interface without using
the frame-relay
map command? Does it matter for the lab, if we use the frame-relay map
command with broadcast
if it is not necessary? With neighbor commands we use unicast and so
broadcast is not necessary.
Comments to the solution and my config with commands below.
Comments are marked with!

R1 is Hub, R2,R3, R5 are the spokes

Solution from CCBootcamp different from mine:
R1
interface Serial0.1 multipoint
!Why changing the the hello interval both physical and point-to-multipoint
have 30s
!by default
 ip ospf hello-interval 20
!better leave default 1 and disable DR/BDR election at the spokes
 ip ospf priority 200

router ospf 1
!why setting priority to one default is 0, why changing the poll-interval
from def. 120s
 neighbor 10.10.1.2 priority 1 poll-interval 180
 neighbor 10.10.1.3 priority 1 poll-interval 180
 neighbor 10.10.1.5 priority 1 poll-interval 180

R2
interface Serial0
!Why changing the the hello interval both physical and point-to-multipoint
have 30s
!by default
 ip ospf hello-interval 20
!!better leave default 1 and disable DR/BDR election at the spokes -> I had
- ip ospf priority 0

router ospf 1
!We don't need a neighboor command at the spokes. I'm right?
 neighbor 10.10.1.1 priority 200 poll-interval 180

!same comments to R3 and R5 like to R2
R3
interface Serial0
 ip ospf hello-interval 20
- ip ospf priority 0

router ospf 1
 neighbor 10.10.1.1 priority 200 poll-interval 180

R5
interface Serial0
 ip ospf hello-interval 20
- ip ospf priority 0

router ospf 1
 neighbor 10.10.1.1 priority 200 poll-interval 180

My solution with comments marked with !
Do you use the command router-id x.x.x.x under router ospf. No more errors
with RID's
in virtual link commands, better readability of the RID in show commands. I
use 1.1.1.1 for
Router 1 and so on. You need IOS 12.0(1)T or higher.

R1#sh conf
!
version 12.1
!
hostname R1
!
enable secret 5 $1$uPKn$yPubZ7CWi7C2.zXRsioSd0
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.1.1 255.255.0.0
!
interface Serial0
 bandwidth 2000
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 bandwidth 2000
 ip address 10.10.1.1 255.255.0.0
! broadcast keyword not necessary, we use unicast (neighbor command)
! better to put always or not for the lab?
 frame-relay map ip 10.10.1.2 102 broadcast
 frame-relay map ip 10.10.1.3 103 broadcast
 frame-relay map ip 10.10.1.5 105 broadcast
!
!
router ospf 1
!sets RID to 1.1.1.1 for better readability
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 1
 network 10.10.0.0 0.0.255.255 area 0
!no changing of priority (Default 0) and poll-interval (default 120s)
 neighbor 10.10.1.5
 neighbor 10.10.1.3
 neighbor 10.10.1.2
!
ip classless
no ip http server
!
alias exec c conf t
alias exec ii sh ip int
alias exec xi sh ipx int
alias exec ir sh ip route
alias exec xr sh ipx route
alias exec ib sh ip int brief
alias exec xb sh ipx int brief
alias exec o sh ip ospf
alias exec e sh ip eigrp
alias exec pr sh ip prot
alias exec b sh ip bgp
alias exec bs sh ip bgp sum
alias exec cr clear ip route
alias exec cb clear ip bgp
alias exec co clear ip ospf
alias exec st show isdn stat
!
line con 0
 privilege level 15
 password cisco
!no mess with command input and router messages
 logging synchronous
 transport input none
 login
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco
!no mess with command input and router messages
 logging synchronous
 login
!
end

R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 0 FULL/DROTHER 00:01:35 10.10.1.5 Serial0.1
3.3.3.3 0 FULL/DROTHER 00:01:39 10.10.1.3 Serial0.1
2.2.2.2 0 FULL/DROTHER 00:01:37 10.10.1.2 Serial0.1
R1#

R2#sh conf
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable secret 5 $1$rEJR$dF0UnMvutzxhBUztg20NP1
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
 ip address 172.168.32.1 255.255.255.0
!
interface Ethernet0
 ip address 137.20.20.1 255.255.255.0
 ip policy route-map POLICYROUTE
!
interface Serial0
 bandwidth 2000
 ip address 10.10.1.2 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
 ip policy route-map POLICYROUTE
! broadcast keyword not necessary, we use unicast (neighbor command)
! better to put always or not for the lab?
 frame-relay map ip 10.10.1.1 201 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.10.0.0 0.0.255.255 area 0
 network 137.20.20.0 0.0.0.255 area 10
 default-information originate always metric 100 metric-type 1
!
ip local policy route-map POLICYROUTE
ip classless
ip route 0.0.0.0 0.0.0.0 137.20.20.2
no ip http server
!
ip access-list extended POLICYROUTE
 permit ip any host 10.10.1.3
 permit ip any host 10.10.1.5
 permit ip any 10.34.0.0 0.0.255.255
 permit ip any 10.44.0.0 0.0.255.255
 permit ip any 10.4.0.0 0.0.255.255
 permit ip any 11.1.0.0 0.0.255.255
route-map POLICYROUTE permit 10
 match ip address POLICYROUTE
 set ip next-hop 10.10.1.1
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 transport input none
 login
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
!
end

R3#sh conf
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable secret 5 $1$CxOv$rbWR52kBQ7AiR13pf6W2U1
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 bandwidth 2000
 ip address 10.10.1.3 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
 ip policy route-map POLICYROUTE
! broadcast keyword not necessary, we use unicast (neighbor command)
! better to put always or not for the lab?
 frame-relay map ip 10.10.1.1 301 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 bandwidth 2000
 ip address 10.34.1.1 255.255.0.0
 ip policy route-map POLICYROUTE
 clockrate 2000000
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 3 virtual-link 4.4.4.4
 network 10.10.0.0 0.0.255.255 area 0
 network 10.34.0.0 0.0.255.255 area 3
!
ip local policy route-map POLICYROUTE
ip classless
ip http server
!
!
ip access-list extended POLICYROUTE
 permit ip any host 10.10.1.2
 permit ip any host 10.10.1.5
 permit ip any 172.168.32.0 0.0.0.255
 permit ip any 137.20.20.0 0.0.0.255
 permit ip any 11.1.0.0 0.0.255.255
route-map POLICYROUTE permit 10
 match ip address POLICYROUTE
 set ip next-hop 10.10.1.1
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
!
end

R4#sh conf
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
enable secret 5 $1$wJgL$4pcrE4yb7bFmW3cadxXtj1
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
 ip address 10.44.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.44.2.1 255.255.255.0
!
interface Ethernet0
 ip address 10.4.1.1 255.255.0.0
!
interface Serial0
 bandwidth 2000
 ip address 10.34.1.2 255.255.0.0
 no fair-queue

router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 area 3 virtual-link 3.3.3.3
 area 44 range 10.44.0.0 255.255.0.0
 network 10.4.0.0 0.0.255.255 area 3
 network 10.34.0.0 0.0.255.255 area 3
 network 10.44.1.0 0.0.0.255 area 44
 network 10.44.2.0 0.0.0.255 area 44
!
ip classless
ip http server
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
!
end

R4#

R5#sh conf
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
enable secret 5 $1$uqDW$phh6Ld/7IM.SVYfKvk3ta0
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 11.1.1.5 255.255.0.0
 ip policy route-map POLICYROUTE
!
interface Serial0
 bandwidth 2000
 ip address 10.10.1.5 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
! broadcast keyword not necessary, we use unicast (neighbor command)
! better to put always or not for the lab?
 frame-relay map ip 10.10.1.1 501 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 10.10.0.0 0.0.255.255 area 0
 network 11.1.0.0 0.0.255.255 area 4
!
ip local policy route-map POLICYROUTE
ip classless
ip http server
!
!
ip access-list extended POLICYROUTE
 permit ip any host 10.10.1.2
 permit ip any host 10.10.1.3
 permit ip any 137.20.20.0 0.0.0.255
 permit ip any 10.34.0.0 0.0.255.255
 permit ip any 172.168.32.0 0.0.0.255
 permit ip any 10.44.0.0 0.0.255.255
 permit ip any 10.4.0.0 0.0.255.255
route-map POLICYROUTE permit 10
 match ip address POLICYROUTE
 set ip next-hop 10.10.1.1
!

line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco
 login
!
end

Peter



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:17 GMT-3