From: Rivron Francois (Francois.Rivron@xxxxxxxxx)
Date: Fri Nov 16 2001 - 06:21:59 GMT-3
Be aware of the interraction between frame map statement and inv arp:
Cf. Caslow/ Pavlichenko p 118: frame-relay map => inverse arp disabled for
the protocol on the dlci specified.
configure frame-relay map on R1.
Please send sh frame-relay map on the router.
> -----Message d'origine-----
> De: hans [SMTP:yyao@sympatico.ca]
> Date: vendredi 16 novembre 2001 08:39
> @: ccielab@groupstudy.com
> Objet: ipx over frame relay
>
> All,
>
> I got a strange question on ipx/FR. Here is my scenarios:
>
> R2/s0--302--dlci--203--s0/R1/s0--204--dlci--402--s0/R3
>
> Here is the config for R1, R2 and R3:
>
>
> R1:
>
> R1#sh run
> !
> hostname R1
> !
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> ipx routing 1111.1111.1111
> !
> !
> interface Loopback0
> ip address 11.0.0.1 255.0.0.0
> no ip directed-broadcast
> ip ospf network point-to-point
> ipx network 111
> !
> interface Serial0
> ip address 2.2.2.1 255.255.255.248
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> no ip mroute-cache
> logging event subif-link-status
> logging event dlci-status-change
> ipx network 123
> no ipx split-horizon eigrp 100
> frame-relay lmi-type cisco
> !
> ip classless
> !
> ipx router eigrp 100
> network 111
> network 123
> !
> !
> no ipx router rip
> !
> end
>
>
>
>
> R2:
>
>
> R2#sh run
> hostname R2
> !
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> ipx routing 2222.2222.2222
> !
> !
> !
> interface Loopback0
> ip address 22.22.22.1 255.255.255.0
> no ip directed-broadcast
> ipx network 222
> !
> interface Serial0
> ip address 2.2.2.2 255.255.255.248
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> no ip mroute-cache
> logging event subif-link-status
> logging event dlci-status-change
> ipx network 123
> frame-relay map ip 2.2.2.1 302 broadcast
> frame-relay map ip 2.2.2.3 302 broadcast
> frame-relay map ipx 123.1111.1111.1111 302 broadcast
> frame-relay map ipx 123.3333.3333.3333 302 broadcast
> frame-relay lmi-type cisco
> !
> ip classless
> !
> !
> !
> ipx router eigrp 100
> network 123
> network 222
> !
> no ipx router rip
> !
> end
>
>
>
>
>
> R3:
>
>
> R3#sh run
> Building configuration...
> !
> hostname R3
> !
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> ipx routing 3333.3333.3333
> !
> !
> interface Loopback0
> ip address 33.0.0.1 255.255.0.0
> no ip directed-broadcast
> ipx network 333
> !
>
> interface Serial0
> ip address 2.2.2.3 255.255.255.248
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> logging event subif-link-status
> logging event dlci-status-change
> ipx network 123
> frame-relay map ip 2.2.2.1 402 broadcast
> frame-relay map ip 2.2.2.2 402 broadcast
> frame-relay map ipx 123.1111.1111.1111 402 broadcast
> frame-relay map ipx 123.2222.2222.2222 402 broadcast
> !
> ip classless
> !
> !
> !
> ipx router eigrp 100
> network 333
> network 123
> !
> !
> no ipx router rip
> !
> !
> end
>
>
>
> I can have full ip connectivity inside the FR cloud. I can ping from
> anywhere to anywhere to/from R1, R2 and R3's serial interface.
>
> In terms of IPX, I can not ping from R3's serail0 to R2 serial 0, but I
> can
> ping from R2's serial 0 to R3's serial 0 and loopback 0. From R1(hub), I
> can
> ping both R2 and R3's serial 0 and loop0.
>
>
> When I ping from R3 to R2 thru R1, I got the following debug info by
> doing
> "debug ipx packet" on both R3, R2 and R1:
>
>
> R3#ping 123.2222.2222.2222
>
> debug info:
> R3:
> 01:05:13: IPX: local:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01 ds=0002 ss=0002, gw=Se0:123.2222.2222.2222.
> 01:05:15: IPX: local:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01 ds=0002 ss=0002, gw=Se0:123.2222.2222.2222.
> 01:05:17: IPX: local:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01 ds=0002 ss=0002, gw=Se0:123.2222.2222.2222.
> 01:05:19: IPX: local:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01 ds=0002 ss=0002, gw=Se0:123.2222.2222.2222.
> 01:05:21: IPX: local:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01 ds=0002 ss=0002, gw=Se0:123.2222.2222.2222.
>
> R2:
>
> 02:34:58: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, rcvd
> 02:34:58: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, local
> 02:34:58: IPX: local:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02 ds=0002 ss=0002, gw=Se0:123.3333.3333.3333
> 02:35:00: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, rcvd
> 02:35:00: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, local
> 02:35:00: IPX: local:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02 ds=0002 ss=0002, gw=Se0:123.3333.3333.3333
> 02:35:02: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, rcvd
> 02:35:02: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, local
> 02:35:02: IPX: local:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02 ds=0002 ss=0002, gw=Se0:123.3333.3333.3333
> 02:35:04: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, rcvd
> 02:35:04: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, local
> 02:35:04: IPX: local:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02 ds=0002 ss=0002, gw=Se0:123.3333.3333.3333
> 02:35:06: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, rcvd
> 02:35:06: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, local
> 02:35:06: IPX: local:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02 ds=0002 ss=0002, gw=Se0:123.3333.3333.3333
>
> R1:
>
> 01:45:44: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01
> ds=0002 ss=0002, rcvd, tc:00->01
> 01:45:44: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, gw=Se0:123.2222.2222.2222
> 01:45:44: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, rcvd
> 01:45:44: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, local
> 01:45:46: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01
> ds=0002 ss=0002, rcvd, tc:00->01
> 01:45:46: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, gw=Se0:123.2222.2222.2222
> 01:45:46: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, rcvd
> 01:45:46: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, local
> 01:45:48: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01
> ds=0002 ss=0002, rcvd, tc:00->01
> 01:45:48: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, gw=Se0:123.2222.2222.2222
> 01:45:48: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, rcvd
> 01:45:48: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, local
> 01:45:50: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01
> ds=0002 ss=0002, rcvd, tc:00->01
> 01:45:50: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, gw=Se0:123.2222.2222.2222
> 01:45:50: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, rcvd
> 01:45:50: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, local
> 01:45:52: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=00
> pt=01
> ds=0002 ss=0002, rcvd, tc:00->01
> 01:45:52: IPX: Se0:123.3333.3333.3333->123.2222.2222.2222 ln=100 tc=01
> pt=01
> ds=0002 ss=0002, gw=Se0:123.2222.2222.2222
> 01:45:52: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, rcvd
> 01:45:52: IPX: Se0:123.2222.2222.2222->123.3333.3333.3333 ln=100 tc=00
> pt=02
> ds=0002 ss=0002, local
>
>
> It seems that R2 got the echo and sends the echo reply to R3 through R1,
> but
> why R3 did not get it?
>
> Please help me with this.
>
> Thanks,
>
> Hans
This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:16 GMT-3