RE: A very basic question : BGP

From: Carnevale, Jason (jcarnevale@xxxxxxxxxxx)
Date: Fri Nov 16 2001 - 05:04:46 GMT-3


   
ok, I see what is happening. The answer to your question is no you do not
need to add the network statement or redistribute statement at each router.
The problem is a return path issue. All the routers no how to reach the
loopback because of bgp and it will make it there because everything is
directly connected. This means the route is in the table. The problem
is...the router in AS 1 does not know how to reach the ip address on the
router in AS4. This is not in the table. You need to either add a loopback
at as4 and add that to bgp, when pinging the interface on as 1 source the
loopback on as 4 and it will work. If you want all routers to work then you
need to run ospf, eigrp etc.... on all the routers and put all the
interfaces in the igp protocol and you will be set. Here is a sample config
for each device.

hope this helps

-Jason

router 1:

sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
no logging console
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Loopback0
 description SIMULATED LAN INTERFACE
 ip address 11.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 description CONNECTION TO FRAME-RELAY NETWORK
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no ip mroute-cache
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description CONNECTION TO R2
 ip address 192.168.1.1 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 102
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 110
 network 192.168.1.1 0.0.0.0 area 0
!
router bgp 1
 network 11.1.1.0 mask 255.255.255.0
 neighbor 192.168.1.2 remote-as 2
 neighbor 192.168.1.2 description BGP SESSION TO R2
 no auto-summary
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
 escape-character 3
line aux 0
line vty 0 4
 login
!
end

r1#term len 0
r1#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is not set

     11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Loopback0
     192.168.1.0/30 is subnetted, 3 subnets
O 192.168.1.8 [110/192] via 192.168.1.2, 00:00:57, Serial0.1
C 192.168.1.0 is directly connected, Serial0.1
O 192.168.1.4 [110/128] via 192.168.1.2, 00:00:57, Serial0.1
r1#sh ip bgp
BGP table version is 2, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 0.0.0.0 0 32768 i
r1#

router 2

sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
logging buffered 10000 debugging
no logging console
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Serial0
 description CONNECTION TO FRAME-RELAY NETWORK
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description CONNECTION TO R1
 ip address 192.168.1.2 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 201
!
interface Serial0.2 point-to-point
 description CONNECTION TO R3
 ip address 192.168.1.5 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 203
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 110
 network 192.168.1.2 0.0.0.0 area 0
 network 192.168.1.5 0.0.0.0 area 0
!
router bgp 2
 neighbor 192.168.1.1 remote-as 1
 neighbor 192.168.1.1 description BGP SESSION TO R1
 neighbor 192.168.1.6 remote-as 3
 neighbor 192.168.1.6 description BGP SESSION TO R3
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
!
end

R2# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is not set

     11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [20/0] via 192.168.1.1, 00:08:50
     192.168.1.0/30 is subnetted, 3 subnets
O 192.168.1.8 [110/128] via 192.168.1.6, 00:01:30, Serial0.2
C 192.168.1.0 is directly connected, Serial0.1
C 192.168.1.4 is directly connected, Serial0.2
R2#sh ip bgp
BGP table version is 2, local router ID is 192.168.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 192.168.1.1 0 0 1 i
R2#

router 3

sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
logging buffered 10000 debugging
no logging console
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 description CONNECTION TO FRAME-RELAY NETWORK
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description CONNECTION TO R2
 ip address 192.168.1.6 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 302
!
interface Serial0.2 point-to-point
 description CONNECTION TO R4
 ip address 192.168.1.9 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 304
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 110
 network 192.168.1.6 0.0.0.0 area 0
 network 192.168.1.9 0.0.0.0 area 0
!
router bgp 3
 neighbor 192.168.1.5 remote-as 2
 neighbor 192.168.1.5 description BGP SESSION TO R2
 neighbor 192.168.1.10 remote-as 4
 neighbor 192.168.1.10 description BGP SESSION TO R4
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
!
end

R3# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is not set

     11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [20/0] via 192.168.1.5, 00:09:36
     192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial0.2
O 192.168.1.0 [110/128] via 192.168.1.5, 00:02:23, Serial0.1
C 192.168.1.4 is directly connected, Serial0.1
R3#sh ip bgp
BGP table version is 3, local router ID is 192.168.1.9
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 192.168.1.5 0 2 1 i
R3#

router 4

sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
logging buffered 10000 debugging
no logging console
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-5ess
!
!
!
interface Serial0
 description CONNECTION TO FRAME-RELAY NETWORK
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 ip ospf network point-to-multipoint
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description CONNECTION TO R3
 ip address 192.168.1.10 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 403
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 description CONNECTION TO R6 TO0
 no ip address
 no ip directed-broadcast
 ip ospf authentication-key cisco
 ip ospf cost 1
 ip ospf priority 100
 shutdown
 ring-speed 16
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-5ess
!
router ospf 110
 network 192.168.1.10 0.0.0.0 area 0
!
router bgp 4
 neighbor 192.168.1.9 remote-as 3
 neighbor 192.168.1.9 description BGP SESSION TO R3
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
 escape-character 3
line aux 0
line vty 0 4
 login
!
end

R4# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is not set

     11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [20/0] via 192.168.1.9, 00:10:01
     192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial0.1
O 192.168.1.0 [110/192] via 192.168.1.9, 00:02:41, Serial0.1
O 192.168.1.4 [110/128] via 192.168.1.9, 00:02:41, Serial0.1
R4#sh ip bgp
BGP table version is 2, local router ID is 192.168.1.10
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 192.168.1.9 0 3 2 1 i
R4#ping 11.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 172/172/176 ms
R4#

frame-switch

term len 0
FRAME-SW#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FRAME-SW
!
logging buffered 10000 debugging
no logging console
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
!
!
!
!
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1/1
 description CONNECTION TO R1 S0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/2 201
!
interface Serial1/2
 description CONNECTION TO R2 S0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 201 interface Serial1/1 102
 frame-relay route 203 interface Serial1/3 302
!
interface Serial1/3
 description CONNECTION TO R3 S0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 302 interface Serial1/2 203
 frame-relay route 304 interface Serial1/4 403
!
interface Serial1/4
 description CONNECTION TO R4 S0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 403 interface Serial1/3 304
!
interface Serial1/5
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/6
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/7
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
!
end

FRAME-SW#

-----Original Message-----
From: Thekkethala [mailto:thek@mediaone.net]
Sent: Friday, November 16, 2001 2:39 AM
To: EA Louie
Cc: jcarnevale@gnilink.net; ccielab@groupstudy.com
Subject: Re: A very basic question : BGP

apologise for not being clear ....

The query really is : Do I need to redistribute by directly connected (Ebgp)
links that are setup between AS's,into bgp at each of the routers in the
example ?

I just found out that when i did a redistribute connected (under bgp) on all
of the routers - the ping goes through from AS4 to the loopback address on
AS1 ?? My BGP table grew too as a result of all the entries ...

Therefore : sounds like EBGP links need to be explicitly brought into the
"bgp table" across all routers for an end to end IP connectivity to happen
(network/redistribute connected...)

 sounds a bit off .... or i am missing something elementary !!!

----- Original Message -----
From: "EA Louie" <elouie@yahoo.com>
To: "Thekkethala" <thek@mediaone.net>; <ccielab@groupstudy.com>
Sent: Friday, November 16, 2001 2:18 AM
Subject: Re: A very basic question : BGP

> Try doing a traceroute to see where your ping is failing. Post those
> results. Also, try your ping/traceroute from AS1 to AS4 and post those
> results.
>
> -e-
>
> ----- Original Message -----
> From: "Thekkethala" <thek@mediaone.net>
> To: <ccielab@groupstudy.com>
> Sent: Thursday, November 15, 2001 10:49 PM
> Subject: A very basic question : BGP
>
>
> > Just a sudden 'shake-up' in my fundamentals all of a sudden
> >
> > Here is the clarification. (EBGP links - do they need to be leaked ???)
> >
> > 1. You have multiple AS's and have EBGP running between them all.
> >
> > as1 ------->as2----->as3------->as4 (a single router in each AS for
> example)
> >
> > lets say yu configure a loopback address in as1 and leak it into bgp
via
> a
> > network statement in as1.
> >
> > Now, keeping the config (basic) as is, yu sit on the router on as4 and
try
> a
> > ping back to as1 to this interface. It does no go thru. However all the
> BGP
> > tables enroute indicate this entry and since they are directly
connected
> ebgp
> > setups, the next hop are there in the ip routing table as well (directly
> > connected).I then did a redistribute-connected under the bgp process on
> ALL
> > the routers and tried again - no luck in reaching the loopback address
in
> as1
> > FROM as4 - however from as2 no problems / as3 and as4 no go at all !!
> >
> > My Question>
> > 1. The eBGP links between routers :
> >
> > Do we ALWAYS need to consciously redistribute them in BGP setup
> > (using either the redistribute-connected or network statement along with
a
> no
> > auto-summary) to enable a ping / traceroute etc .. for ip basically
> > ...........
> >
> > I am sorry if this sounds really elementary ... but am quite puzzled -
> what if
> > I have a setup involving 50/60 ebgp session (in theory I mean) ....!!!!!



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:16 GMT-3