Re: default-network and igrp (classic flsm/vlsm)

From: Fred Ingham (fningham@xxxxxxxxxxxxxxxx)
Date: Thu Nov 15 2001 - 15:23:56 GMT-3


   
Ryaboy: The requirements for using ip default-network for IGRP are:
        1. must be in routing table (of r4 in your case)
        2. must be different from ospf-igrp network (i.e.
            not 170.10.0.0) Otherwise you get a static route.
        3. must be classfull
        4. igrp router must have ip classless enabled.

You will see a Gateway on the IGRP router. The /26 routes will not be
in the IGRP router table but will be able to be pinged since r4 knows
the path.

        This has been addressed many times in this forum. In
Caslow/Pavlichenko, 2nd ed. this is on pp352-353.

An example:
R4 with interfaces in 172.16.0.0 network, 192.168.2.0 in routing
        table from another router.

router ospf 100
redistribute igrp 100 subnets route-map IGRP
network 172.16.65.0 0.0.0.255 area 0
network 172.16.75.0 0.0.0.255 area 0
!
router igrp 100
redistribute ospf 100 route-map OSPF
default-metric 10000 100 255 1 1500
network 172.16.0.0
timers basic 10 30 30 60 <<- used to shorten update period
passive serial 2.231
passive bri 0
!
route-map IGRP permit 10
match ip add 10
!
access-li 10 permit 172.16.162.0 0.0.1.255
!
access-li 30 deny 172.16.162.0 0.0.1.255
access-li 30 permit any
!
route-map OSPF permit 10
match ip address 30
!
ip classless
!
ip default-network 192.168.2.0
-------------------------------------------------------------
R1 running IGRP with /24 172.16.0.0 connection to R4

router igrp 100
network 172.16.0.0
timers basic 10 30 30 60 <<-matches R4
!
ip classless
!
----------------------------------------------------------------
Cheers, Fred.
        
Ryaboy Vadim wrote:
>
> Hello,
>
> Here is the scenario:
>
>
> R2 --- R5(E0) ---(E0) R4 (S0) --- (S1)R1
>
> R4,R1 running igrp
> R4- R5 - OSPF virtual link
> R5-R2 - OSPF area 0
>
> IGRP and OSPF mutually redistributed on R4. R1 (/24) don't see
>
> R4 S1 170.10.15.1/24
> R4 S0 170.10.15.1/24
>
> R4 (e0) 170.10.11.65 / 26
> R5 (e0) 170.10.11.66 / 26
>
> R2 -- R5 Frame Relay network 170.10.10.32/28.
>
> Classic FLSM/VLSM scenario. R1 (/24) don't see R2-R5 network .
>
> One of few solutions (right?)- use ip classless (I have it on)
> And use ip default-network.
>
> I've put ip default-network 170.10.0.0 on R4
> All it did - it created static route in running-config: ip route 170.10.0.0
> 255.255.0.0 170.10.10.0
> It did not put any gateways of last resort on R4 or R1.
>
> Can I use ip default-network to solve this problem?
> And how.



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:16 GMT-3