RE: BGP synchro problem (LONG)

From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Tue Nov 13 2001 - 03:17:43 GMT-3


   
Hi,

It seen like this note is cross posted, post here for contination..

Firstly, thank to KBI to give me the right pointer but wrong section. I
manage to find the answer but would like to know the reason, answer at :
http://www.cisco.com/warp/public/459/25.shtml
BGP Best Path Selection Algorithm,
////////
Paths marked as "not synchronized" in the show ip bgp <longer-prefixes>
output. If BGP synchronization is enabled, which it is by default in
Cisco IOS. Software, there must be a match for the prefix in the IP
routing table in order for an internal (iBGP) path to be considered a
valid path. If the matching route is learned from an OSPF neighbor, its
OSPF router ID must match the BGP router ID of the iBGP neighbor. Most
users prefer to disable synchronization using the no synchronization BGP
subcommand.
//////////
Route advertise from RR client to RR may valid/best_path if OSPF and BGP
RID match, next this route will advertise by the RR to the other RR
client which have the two RID.

The reason that "not syn" is due to the mismatch RID of IBGP and OSPF.
See below, could someone give more detail explaination
====================================================================
I use different way to advertise the network fr comparasion.

IGP is OSPF, IBGP R2<-ibgp->R4<-ibgp->R5
                            RR
              R4 (RR) advertise 40.0.0.0
             / \
test point R2----R5 advertise 50.0.0.0
///////////////////////////////////////////////////////////////
R2 show ip ospd database
========================
                Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
50.0.0.0 133.3.5.5 870 0x80000001 0xFB7B

                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
40.0.0.0 133.3.4.4 1405 0x80000001 0x41CF 0

////////////////////////////////////////////////////////////
r2#s ip bgp
==============
BGP table version is 6, local router ID is 133.3.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*>i40.0.0.0 133.3.4.4 0 100 0 i
* i50.0.0.0 133.3.5.5 0 100 0 i
///////////////////////////////////////////////////////////////
r2#s ip bgp 40.0.0.0
======================
BGP routing table entry for 40.0.0.0/8, version 6
Paths: (1 available, best #1)
  Not advertised to any peer
  Local
    133.3.4.4 (metric 397) from 133.3.4.4 (133.3.4.4)
      Origin IGP, metric 0, localpref 100, valid, internal,
synchronized, best,
///////////////////////////////////////////////////////////////////////
r2#s ip bgp 50.0.0.0
======================
BGP routing table entry for 50.0.0.0/8, version 0
Paths: (1 available, no best path)
  Not advertised to any peer
  Local
    133.3.5.5 (metric 11) from 133.3.4.4 (133.3.5.5)
      Origin IGP, metric 0, localpref 100, valid, internal, not
synchronized, re
f 2
      Originator: 133.3.5.5, Cluster list: 133.3.4.4
/////////////////////////////////////////////////////////////////
Configuration of the three routers on section related to the test
==================================================================

version 12.0
!
hostname r2
!
ip subnet-zero
!
!
interface Loopback0
 ip address 133.3.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 133.3.12.2 255.255.255.0
!
!
interface Ethernet0/0
 ip address 133.3.25.2 255.255.255.0
!
interface Serial0/1
 bandwidth 252
 ip address 133.3.24.2 255.255.255.0
!
router ospf 1
 router-id 133.3.2.2
 network 20.0.0.0 0.255.255.255 area 20
 network 133.3.0.0 0.0.255.255 area 0
!
router bgp 245
 neighbor 133.3.4.4 remote-as 245
 neighbor 133.3.4.4 update-source Loopback0
///////////////////////////////////////////////
version 12.1
!
hostname r4
!
ip subnet-zero
!
interface Loopback0
 ip address 133.3.4.4 255.255.255.0
 ip ospf network point-to-point
!
!
interface Loopback40
 ip address 40.0.0.4 255.0.0.0
 ip ospf network point-to-point
!
!
interface Serial1/1
 bandwidth 252
 ip address 133.3.24.4 255.255.255.0
 clockrate 252000
!
interface Serial1/2
 bandwidth 252
 ip address 133.3.45.4 255.255.255.0
 clockrate 252000
!
!
router ospf 1
 router-id 133.3.4.4
 redistribute connected metric 999 subnets route-map test
 network 133.3.0.0 0.0.255.255 area 0
!
router bgp 245
 network 40.0.0.0
 neighbor abc peer-group
 neighbor abc remote-as 245
 neighbor abc update-source Loopback0
 neighbor abc route-reflector-client
 neighbor 133.3.2.2 peer-group abc
 neighbor 133.3.5.5 peer-group abc
!
ip classless
!
route-map test permit 10
 match interface Loopback40
//////////////////////////////
version 12.1
!
hostname r5
!
ip subnet-zero
!
interface Loopback0
 ip address 133.3.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback50
 ip address 50.0.0.5 255.0.0.0
 ip ospf network point-to-point
!
interface Ethernet2/0
 ip address 133.3.25.5 255.255.255.0
!
interface Serial4/1
 bandwidth 252
 ip address 133.3.45.5 255.255.255.0

!
router ospf 1
 router-id 133.3.5.5
 network 50.0.0.5 0.0.0.0 area 50
 network 133.3.0.0 0.0.255.255 area 0
!
router bgp 245
 network 50.0.0.0
 neighbor 133.3.4.4 remote-as 245
 neighbor 133.3.4.4 update-source Loopback0
 no auto-summary
//////////////////////////////////////////////

> Parry Chua



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:14 GMT-3