Re: frame over isdn with no switch

From: afiddler (afiddler@xxxxxxxxx)
Date: Wed Nov 07 2001 - 22:53:49 GMT-3


   
Here is an example of ISDN set up with frame-relay encapsulation. Note that
the calling router, 3620_3, is DCE and has a frame-relay map statement.
Also, note that the called router, 3620_2, needs a dialer map with the dial
string on it. Frame-relay, ISO CLNS, and LAPB do not support dialer
profiles.

3620_2#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3620_2
!
!
username local password 7 04480E051D2458
username remote password 7 0215015819031B
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-dms100
!
interface Ethernet0/0
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no keepalive
 shutdown
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI1/0
 ip address 1.1.1.2 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 dialer idle-timeout 60
 dialer map ip 1.1.1.3 name 3620_3 2223333
 dialer-group 1
 isdn switch-type basic-dms100
 isdn spid1 41422244440101
 isdn spid2 41422255550101
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
!
access-list 100 permit ip any any
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 110A1016141D
 login
!
end

3620_3#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3620_3
!
!
ip subnet-zero
frame-relay switching
isdn switch-type basic-dms100
!
!
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI1/0
 ip address 1.1.1.3 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 dialer map ip 1.1.1.2 name 3620_2 2224444
 dialer-group 1
 isdn switch-type basic-dms100
 isdn spid1 41422233330101
 isdn spid2 41422277770101
 frame-relay map ip 1.1.1.2 101
 frame-relay intf-type dce
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

3620_3#sh frame pvc

PVC Statistics for interface BRI1/0 (Frame Relay DCE)

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE (spoofing), INTERFACE =
BRI0

  input pkts 15 output pkts 23 in bytes 1486
  out bytes 2392 dropped pkts 0 in FECN pkts 0
  in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
  in DE pkts 0 out DE pkts 0
  out bcast pkts 0 out bcast bytes 0
  pvc create time 00:28:12, last time pvc status changed 00:28:13
3620_3#sh frame map
BRI1/0 (up): ip 1.1.1.2 dlci 101(0x65,0x1850), static,
              CISCO, status defined, active (spoofing)

3620_2#sh frame pvc

PVC Statistics for interface BRI1/0 (Frame Relay DTE)

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE (spoofing), INTERFACE =
BRI0

  input pkts 24 output pkts 15 in bytes 2422
  out bytes 1486 dropped pkts 0 in FECN pkts 0
  in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
  in DE pkts 0 out DE pkts 0
  out bcast pkts 1 out bcast bytes 30
  pvc create time 00:27:28, last time pvc status changed 00:27:29
3620_2#sh frame map
BRI1/0 (up): ip 1.1.1.3 dlci 101(0x65,0x1850), dynamic,
              broadcast,, status defined, active (spoofing)

----- Original Message -----
From: "garry baker" <fallow46@yahoo.com>
To: <ccielab@groupstudy.com>
Sent: Wednesday, November 07, 2001 4:05 PM
Subject: frame over isdn with no switch

> Guys,
>
> Has anyone been able to get the following scenerio
> working.
>
> I have a customer who wishes to have a isdn backup
> circuit but wishes only to use fram relay encap. This
> is just a point to point link with one end set as a
> frame dce connection and the other as a normal dte
> connection.
>
> When doing some testing the frame relay appears fine
> but when doing some pings across the link the dce end
> originated pings get to the other end whereas the
> returned packets from the dte end fail with encap
> failed. This tells me that the frame is cactus at this
> end. Does anyone have experience with doing such a
> silly solution?
>
> Garry
>



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:08 GMT-3