RE: CCBootCamp 5 OSPF over frame question

From: SFeldberg@xxxxxxxxxxxxx
Date: Wed Nov 07 2001 - 18:14:11 GMT-3


   
I could have sworn that I tried this in an earlier IOS and it did not
work.... but... the mask concept can also be applie to include multiple
interfaces in the same area with one statement. See below:

r2#sh run
!
interface Ethernet0
 ip address 20.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
router ospf 1
 network 10.1.1.2 0.0.0.0 area 0
 network 20.1.1.1 0.0.0.0 area 1

r2#sh ip route

     20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Ethernet0
     10.0.0.0/24 is subnetted, 2 subnets
O 10.2.2.0 [110/74] via 10.1.1.4, 00:04:08, Serial1
C 10.1.1.0 is directly connected, Serial1

r2#sh ip ospf
 Routing Process "ospf 1" with ID 10.1.1.2
 Supports only single TOS(TOS0) routes
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 18 times
        Area ranges are
        Number of LSA 5. Checksum Sum 0x219AA
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x1634B
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0

r4#sh run
!
interface Ethernet0
 ip address 10.2.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.1.1.4 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 network 10.0.0.0 0.255.255.255 area 0

r4#sh ip route

     20.0.0.0/24 is subnetted, 1 subnets
O IA 20.1.1.0 [110/74] via 10.1.1.2, 00:04:19, Serial1
     10.0.0.0/24 is subnetted, 2 subnets
C 10.2.2.0 is directly connected, Ethernet0
C 10.1.1.0 is directly connected, Serial1

r4#sh ip ospf
 Routing Process "ospf 1" with ID 10.1.1.4
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0
 Number of opaque AS LSA 0. Checksum Sum 0x0
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        Area has no authentication
        SPF algorithm executed 18 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x21240
        Number of opaque link LSA 0. Checksum Sum 0x0
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Like I said, I could have sworn that I tried this before and it did NOT
work this way... can anyone attest to earlier versions of code (this is
12.07 XK2) NOT working this way...???!!! &^%$^%$*^%#

Steve

                    "Larson,

                    Chris To: "'Ben-Shalom, Omer'"

                    (Contractor)" <omer.ben-shalom@intel.com>, lgao <lga
o@cisco.com>,
                    <Chris.Larson Courtney Foster <cfoster@cnr.edu>

                    @ed.gov> cc: Dennis #6 <vacant@home.com>, C
CIE Groupstudy
                    Sent by: <ccielab@groupstudy.com>

                    nobody@groups Subject: RE: CCBootCamp 5 OSPF ove
r frame
                    tudy.com question

                    11/07/2001

                    03:30 PM

                    Please

                    respond to

                    "Larson,

                    Chris

                    (Contractor)"

Good point. I never really thought about it that way, but your right of
course. The network statement simply identifies (in the case of OSPF) which
interfaces to advertise out of and therefore a host route would work.

Thinking about it like that, I cannot really think of any instances where
you would not want to , or could not simply use a host route. Would
everyone
agree with that????

Are there instances where you could not?

-----Original Message-----
From: Ben-Shalom, Omer [mailto:omer.ben-shalom@intel.com]
Sent: Wednesday, November 07, 2001 3:00 PM
To: lgao; Courtney Foster
Cc: Dennis #6; CCIE Groupstudy
Subject: RE: CCBootCamp 5 OSPF over frame question

The OSPF network statement really has nothing to do with networks it is an
access list (and that is why it uses the mask the way it does) to filter
the
interfaces to take part in OSPF, you COULD use the right network mask for
the interfaces or not, that is really a style issue.
A while back I asked the same thing stating that I personally prefer the
network mask to a host mask but later was convinced by a number of good
people that unless you have a big router with many interfaces using the
host
mask is cleaner and less prone to mistakes and surprises so I am now using
a
host mask.

Again - both will work and this is really a style issue nothing more.

Omer.

-----Original Message-----
From: lgao [mailto:lgao@cisco.com]
Sent: Wed, November 07, 2001 7:57 PM
To: Courtney Foster
Cc: Dennis #6; CCIE Groupstudy
Subject: Re: CCBootCamp 5 OSPF over frame question

I don't think it is the best practice to advertise a host mask, it looks
like a lazy thing that dont' want to figure out what the true mask is.

Courtney Foster wrote:

> It is a host specific mask....because you don't have broadcast...you are
> telling OSPF that this host is Area 10...At least that's what I think
>
> -----Original Message-----
> From: Dennis #6 [mailto:vacant@home.com]
> Sent: Wednesday, November 07, 2001 12:04 PM
> To: CCIE Groupstudy
> Subject: CCBootCamp 5 OSPF over frame question
>
> I noticed on the CCBootCamp lab 5 solution that the wildcard mask on
> each router for the point-to-multipoint frame connections is 0.0.0.0
> (see below). Is there a good reason for using this mask as opposed to
> 0.0.0.255 (it's a /24 subnet)? When is it best to use 0.0.0.0 versus
> 0.0.0.255. I thought it was normal to use the inverse mask that
> corresponds to the subnet mask on that interface. What am I missing?
>
> router ospf 1
> redistribute igrp 1 metric 20 metric-type 1 subnets
> network 172.168.100.5 0.0.0.0 area 10 !point to multipoint frame
> connection network 137.20.20.0 0.0.0.255 area 0 area 10 virtual-link
> 172.168.30.97 area 10 virtual-link 172.168.100.6
>
> Thanks,
>
> Dennis #6



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:08 GMT-3