From: Rick Stephens (rstephens@xxxxxxxxxx)
Date: Wed Nov 07 2001 - 13:39:35 GMT-3
Yes, good tip on the route-map, match interface.
I have been thinking about what the benefit would be between an IA route
versus an E2 or E1 route. Take this a step further and think about
redistributing into IGRP or somewhere else. Sure, if it is a /24 it is not
a problem but if the interface were a /30 and you needed to get that into
RIP or IGRP, but on either you could do an "area x range" or a
"summary-address".
Additionally, there seems to me that there is an issue with either E1 or E2
routes not redistributing the same, but that distinction escapes me.
-----Original Message-----
From: SFeldberg@edeltacom.com [mailto:SFeldberg@edeltacom.com]
Sent: Wednesday, November 07, 2001 10:30 AM
To: Rick Stephens
Cc: ccielab@groupstudy.com; nobody@groupstudy.com
Subject: Re: OSPF: Passive vs redistribute connected
I think you're right on the money with the "it depends" comment. If the
interface needs to be in a specific area, then solution 2 is the answer.
For solution 1, try this when redistributing connected interfaces:
int s0
ip address 10.1.1.1 255.255.255.0
!
int e0
ip address 172.16.1.1 255.255.255.0
!
router ospf 1
network 10.1.1.1 0.0.0.0 area 0
redistribute connected metric 20 subnet route-map E0_Only
!
route-map E0_Only permit 10
match interface e0
You'll save yourself from having to write an access-list, making it a
quicker solution and less prone to errors.
Steve
Rick Stephens
<rstephens@wa To: ccielab@groupstudy.com
ntec.com> cc:
Sent by: Subject: OSPF: Passive vs
redistribute connected
nobody@groups
tudy.com
11/07/2001
11:14 AM
Please
respond to
Rick Stephens
Group,
I have a question about which might be preferred or best practice when
advertising an interface (network) without sending LSAs out the interface.
Really, I am not sure how to even ask the question, but let me provide an
example. Say you had two routers R1 & R2, connected by serial (or
whatever)
and running OSPF between each other. The requirement is to advertise the
E0
on R1, but not to advertise OSPF out that interface. I see two ways to do
this, but wonder which would be "best" and what might be the pros and cons
to each method.
1) Redistribute connected
int s0
ip address 10.1.1.1 255.255.255.0
!
int e0
ip address 172.16.1.1 255.255.255.0
!
router ospf 1
network 10.1.1.1 0.0.0.0 area 0
redistribute connected metric 20 subnet route-map E0_Only
!
route-map E0_Only permit 10
match ip address 1
!
access-list 1 permit 172.16.1.0 0.0.0.255
**Note: This method will advertise 172.16.1.0 as an E2 route.
2) network statement in OSPF for that interface and the "passive-interface"
command.
int s0
ip address 10.1.1.1 255.255.255.0
!
int e0
ip address 172.16.1.1 255.255.255.0
!
router ospf 1
network 10.1.1.1 0.0.0.0 area 0
network 172.16.1.1 0.0.0.0 area 1
passive-interface e0
Note: This method will advertise 172.16.1.0 as an IA route.
I suspect that it is the typical Cisco answer of "it depends". But, your
thoughts and direction would be appreciated.
Richard Stephens
WAN Technologies, Inc.
St. Louis, Missouri
rstephens@wantec.com
This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:07 GMT-3