Redistribute EIGRP-EIGRP-OSPF-RIPv2 using route tag

From: Charles Huang (CharlesNY2000@xxxxxxxxx)
Date: Mon Nov 05 2001 - 04:01:10 GMT-3


   
This is an example of using route tag for redistribution

you can download the network diagram from this link
http://icharles.myip.org/route-tag.jpg

and here's the configs

hostname r1
interface Loopback8
 ip address 10.0.8.1 255.255.255.255
interface Loopback9
 ip address 10.0.9.1 255.255.255.255
interface Ethernet0/0
 ip address 10.0.80.1 255.255.255.0
interface Serial0/0
 ip address 10.0.91.1 255.255.255.248
!
router eigrp 80
 redistribute eigrp 90 route-map E90-E80
 network 10.0.8.1 0.0.0.0
 network 10.0.80.0 0.0.0.255
 default-metric 1544 2000 255 1 1500
 no auto-summary
 eigrp log-neighbor-changes
!
router eigrp 90
 redistribute eigrp 80 route-map E80-E90
 network 10.0.9.1 0.0.0.0
 network 10.0.91.0 0.0.0.7
 default-metric 1544 2000 255 1 1500
 no auto-summary
 eigrp log-neighbor-changes
!
route-map E80-E90 deny 10
 match tag 90 110 120
route-map E80-E90 permit 20
 set tag 80
!
route-map E90-E80 deny 10
 match tag 80
route-map E90-E80 permit 20
 match tag 110 120
route-map E90-E80 permit 30
 match tag 90

!--------------------------------------------

hostname r2
interface Loopback8
 ip address 10.0.8.2 255.255.255.255
interface Loopback9
 ip address 10.0.9.2 255.255.255.255
interface Ethernet0/0
 ip address 10.0.80.2 255.255.255.0
interface Serial0/0
 ip address 10.0.92.2 255.255.255.248
!
router eigrp 80
 redistribute eigrp 90 route-map E90-E80
 network 10.0.8.2 0.0.0.0
 network 10.0.80.0 0.0.0.255
 default-metric 1544 2000 255 1 1500
 no auto-summary
!
router eigrp 90
 redistribute eigrp 80 route-map E80-E90
 network 10.0.9.2 0.0.0.0
 network 10.0.92.0 0.0.0.7
 default-metric 1544 2000 255 1 1500
 no auto-summary
!
route-map E80-E90 deny 10
 match tag 90 110 120
route-map E80-E90 permit 20
 set tag 80
!
route-map E90-E80 deny 10
 match tag 80
route-map E90-E80 permit 20
 match tag 110 120
route-map E90-E80 permit 30
 set tag 90

!--------------------------------------------

hostname r3
interface Loopback9
 ip address 10.0.9.3 255.255.255.255
interface Loopback11
 ip address 10.0.11.3 255.255.255.255
interface Ethernet0/0
 ip address 10.0.90.3 255.255.255.0
interface Serial0/0
 ip address 10.0.91.3 255.255.255.248
 clockrate 4000000
interface Serial0/1
 ip address 10.0.111.3 255.255.255.248
 clockrate 4000000
interface Ethernet1/0
 ip address 10.0.110.3 255.255.255.0
!
router eigrp 90
 redistribute ospf 110 route-map OSPF-EIGRP
 network 10.0.9.3 0.0.0.0
 network 10.0.90.0 0.0.0.255
 network 10.0.91.0 0.0.0.7
 default-metric 1544 2000 255 1 1500
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 110
 log-adjacency-changes
 redistribute eigrp 90 subnets route-map EIGRP-OSPF
 network 10.0.11.3 0.0.0.0 area 0
 network 10.0.110.0 0.0.0.255 area 0
 network 10.0.111.0 0.0.0.7 area 0
 default-metric 48
!
route-map EIGRP-OSPF deny 10
 match tag 110 120
route-map EIGRP-OSPF permit 20
 match tag 80
route-map EIGRP-OSPF permit 30
 set tag 90
!
route-map OSPF-EIGRP deny 10
 match tag 80 90
route-map OSPF-EIGRP permit 20
 match tag 120
route-map OSPF-EIGRP permit 30
 set tag 110

!--------------------------------------------

hostname r4
interface Loopback9
 ip address 10.0.9.4 255.255.255.255
interface Loopback11
 ip address 10.0.11.4 255.255.255.255
interface Ethernet0/0
 ip address 10.0.90.4 255.255.255.0
interface Serial0/0
 ip address 10.0.92.4 255.255.255.248
 clockrate 4000000
interface Serial0/1
 ip address 10.0.112.4 255.255.255.248
 clockrate 4000000
interface Ethernet1/0
 ip address 10.0.110.4 255.255.255.0
!
router eigrp 90
 redistribute ospf 110 route-map OSPF-EIGRP
 network 10.0.9.4 0.0.0.0
 network 10.0.90.0 0.0.0.255
 network 10.0.92.0 0.0.0.7
 default-metric 1544 2000 255 1 1500
 no auto-summary
 eigrp log-neighbor-changes
!
router ospf 110
 log-adjacency-changes
 redistribute eigrp 90 subnets route-map EIGRP-OSPF
 network 10.0.11.4 0.0.0.0 area 0
 network 10.0.110.0 0.0.0.255 area 0
 network 10.0.112.0 0.0.0.7 area 0
 default-metric 48
!
route-map EIGRP-OSPF deny 10
 match tag 110 120
route-map EIGRP-OSPF permit 20
 match tag 80
route-map EIGRP-OSPF permit 30
 set tag 90
!
route-map OSPF-EIGRP deny 10
 match tag 80 90
route-map OSPF-EIGRP permit 20
 match tag 120
route-map OSPF-EIGRP permit 30
 set tag 110

!--------------------------------------------

hostname r5
interface Loopback11
 ip address 10.0.11.5 255.255.255.255
interface Loopback12
 ip address 10.0.12.5 255.255.255.255
interface Ethernet0/0
 ip address 10.0.120.5 255.255.255.0
interface Serial0/0
 ip address 10.0.111.5 255.255.255.248
!
router ospf 110
 log-adjacency-changes
 redistribute rip subnets route-map RIP-OSPF
 network 10.0.11.5 0.0.0.0 area 0
 network 10.0.111.0 0.0.0.7 area 0
 default-metric 48
!
router rip
 version 2
 timers basic 5 15 15 15
 redistribute ospf 110 route-map OSPF-RIP
 network 10.0.0.0
 default-metric 3
 distribute-list OSPF-NETWORK out
 no auto-summary
!
ip access-list standard OSPF-NETWORK
 deny 10.0.11.5
 deny 10.0.111.0 0.0.0.7
 permit any
!
route-map OSPF-RIP deny 10
 match tag 120
route-map OSPF-RIP permit 20
 match tag 80 90
route-map OSPF-RIP permit 30
 set tag 110
!
route-map RIP-OSPF deny 10
 match tag 80 90 110
route-map RIP-OSPF permit 20
 set tag 120

!--------------------------------------------

hostname r6
interface Loopback11
 ip address 10.0.11.6 255.255.255.255
interface Loopback12
 ip address 10.0.12.6 255.255.255.255
interface Ethernet0/0
 ip address 10.0.120.6 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 ip address 10.0.112.6 255.255.255.248
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 110
 redistribute rip subnets route-map RIP-OSPF
 network 10.0.11.6 0.0.0.0 area 0
 network 10.0.112.0 0.0.0.7 area 0
 default-metric 48
!
router rip
 version 2
 timers basic 5 15 15 15
 redistribute ospf 110 route-map OSPF-RIP
 network 10.0.0.0
 default-metric 3
 distribute-list OSPF-NETWORK out
 no auto-summary
!
ip access-list standard OSPF-NETWORK
 deny 10.0.11.6
 deny 10.0.112.0 0.0.0.7
 permit any
!
route-map OSPF-RIP deny 10
 match tag 120
route-map OSPF-RIP permit 20
 match tag 80 90
route-map OSPF-RIP permit 30
 set tag 110
!
route-map RIP-OSPF deny 10
 match tag 80 90 110
route-map RIP-OSPF permit 20
 set tag 120

please e-mail me with any comments or suggestions.
Thank you
Charles



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:03 GMT-3