Re: Multicast Sparse-Dense Mode

From: David Knot (david_knot@xxxxxxxxx)
Date: Thu Nov 01 2001 - 08:31:54 GMT-3


   
I've been testing this setup & get the same problem as
described below. I've tried the suggestion below but
do not help. Any ideas please? Here are the configs:

hostname R1
!
ip multicast-routing
ip dvmrp route-limit 20000
frame-relay switching
!
interface Loopback0
 ip address 188.99.1.1 255.255.255.0
!
interface Serial0/0
 ip address 188.99.14.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network point-to-point
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no fair-queue
 frame-relay interface-dlci 104
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial0/1
 ip address 188.99.12.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network point-to-point
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 64000
 frame-relay interface-dlci 102
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
router ospf 1
 network 188.99.1.0 0.0.0.255 area 0
!
end

Hostname R2
!
ip multicast-routing
!
!
interface Loopback0
 ip address 188.99.2.2 255.255.255.0
 ip pim sparse-mode
!
interface Serial0/0
 ip address 188.99.12.2 255.255.255.0
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network point-to-point
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no fair-queue
!
interface TokenRing0/0
 ip address 188.99.20.2 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 224.1.1.1
 ip igmp join-group 224.2.2.2
 ring-speed 16
!
router ospf 1
 network 188.99.2.0 0.0.0.255 area 0
!
!
ip classless
!
ip pim send-rp-announce Loopback0 scope 255 group-list
11
ip pim send-rp-discovery scope 255
!
access-list 11 permit 224.1.0.0 0.0.255.255
!
end

hostname R4
!
ip multicast-routing
ip dvmrp route-limit 20000
!
!
interface Loopback0
 ip address 188.99.4.4 255.255.255.0
!
interface Serial0/0
 ip address 188.99.100.4 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 clockrate 64000
 frame-relay map ip 188.99.100.3 107 broadcast
 frame-relay map ip 188.99.100.5 107 broadcast
!
interface Serial0/1
 ip address 188.99.14.4 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network point-to-point
 clockrate 64000
!
router ospf 1
 network 188.99.4.0 0.0.0.255 area 0
!
end

-- Brian Hescock <bhescock@cisco.com> wrote:
> Pinging from R1 means the packets will be
> process-switched. When pinging from R4 the packets
> on R1
> will be fast-switched. Configure "no ip
> mroute-cache" on the outgoing interface on R1 and
> then see
> if you can ping from R4. If not, put an ip igmp
> join-group on the outgoing interface on R1 and see
> if you can ping from R4 and get a response from R1.
>
> There have been several multicast fast-switching
> bugs where sometimes you don't even get an
> interface in the OIL when you have a join-group
> command on that interface. As a workaround, what
> will often work is removing join-group and remove
> pim, let pim timeout then put the commands back
> on. If that doesn't work, do the same thing again
> but once the commands are off the interface do a
> "shut", wait a few seconds, do a "no shut" and put
> the commands back on the interface. You should
> then see the outbound interface in the OIL. This
> isn't something you should have to do, just a
> workaround due to a multicast fast-switching bug.
>
> Brian
>
> Sijbren Beukenkamp wrote:
>
> > Consider the following.
> >
> > Three routers R2, R1 and R4. All interconnected
> using FR. R1 is in the
> > centre and will have to route Multicast between
> its serial interface to R2
> > and R4. R2 and R4 have a tokenring interfaces at
> which SD-mode is
> > configured. The same is for all the serial
> interfaces.
> >
> >
>
Tokenring--------R2-------------FR---------------R1----------FR---------------R
4--------Tokenring
> >
> > IP MULTICAST-ROUTING IP
> MULTICAST-ROUTING IP
> > MULTICAST-ROUTING
> > PIM-S-D
> PIM-S-D
> > PIM-S-D
> > igmp-join 224.1.1.1
> > 224.1.1.1 announced by RP
> > igmp-join 224.2.2.2
> >
> > R2 is RP and mapping agent ONLY for 224.1.1.1. So
> basicly 224.1.1.1 is
> > using Sparse-mode and 224.2.2.2 is using Dense !
> > PIM Sparse Dense is configured on all Frame-relay
> interfaces and the
> > tokenring interfaces.
> > On the tokenring interface of R2 are the two igmp
> joins configured.
> >
> > R1 and R4 are showing the RP (sh ip pim rp
> mapping)
> > R1 can ping 224.1.1.1 and 224.2.2.2
> > R4 can only ping 224.2.2.2
> >
> > IOS used 12.0.18 enterprise
> >
> > What's wrong with this picture !
> >
> > Met vriendelijke groet/ Kind regards,
> > Sijbren
> >
> ++++++++++++++++++++++++++++++++++++++++++++++++++++
> > Ing. Sijbren Beukenkamp IBM Global Services
> > Internetworking Specialist Integrated
> Technology Services
> >
> Networking & Connectivity
> > Services
> >
> http://www.ibm.com/services/nc/
> > GSM +31 (0)6 53761703 The Netherlands
> > Office: +31 (0)30 2850 666
>



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:44:59 GMT-3