From: Ben-Shalom, Omer (omer.ben-shalom@xxxxxxxxx)
Date: Sun Oct 28 2001 - 09:25:08 GMT-3
Hi all.
I have 2 routers connected with ISDN, everything worked OK, I then tried to
also implement dialer callback similar to the one below and suddenly not
only the callback does not work but all the rest, removing the second dialer
interface (dialer 0 used for callback) brings the connection Via dialer 1
back up.
Any thoughts as to why the addition of a second dialer interface stops the
first as well as why the callback is not working is welcome.
See below the relevant part of the 2 router configurations as well as some
debug stuff from trying to ping between the callback client to the callback
server.
It seems from the debug that in both pings I try (to the Ip of the dialer 0
and dialer 1) the callback is matching by the source phone number not the
hostname, does this mean that callback cannot be implemented with no
callback the way I try it ?
Thanks
Omer.
!R5 configuration
hostname 2500-2
username R5Call password 0 cisco
username 3600-2 password 0 cisco
isdn switch-type basic-dms100
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 2
!
interface Dialer0
ip address 1.8.125.5 255.255.255.0
encapsulation ppp
dialer remote-name R5Call
dialer string 67594
dialer pool 2
dialer-group 2
no fair-queue
ppp callback request
ppp authentication chap
ppp chap hostname R2Call
ppp chap password cisco
ppp multilink
!
interface Dialer1
ip address 1.8.25.5 255.255.255.0
encapsulation ppp
ip ospf demand-circuit
dialer remote-name 3600-2
dialer string 67594
dialer pool 1
dialer-group 1
no fair-queue
ppp authentication chap
ppp multilink
pulse-time 0
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!R2 configuration
hostname 3600-2
username 2500-2 password 0 cisco
username R2Call password 0 cisco
interface BRI2/0
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 2
isdn switch-type basic-dms100
!
interface Dialer0
ip address 1.8.125.2 255.255.255.0
encapsulation ppp
dialer pool 2
dialer remote-name R2Call
dialer string 67595 class CallBack
dialer caller 67595 callback
dialer-group 1
pulse-time 0
ppp callback accept
ppp authentication chap
ppp chap hostname R5Call
ppp chap password 7 02050D480809
ppp multilink
!
interface Dialer1
ip address 1.8.25.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name 2500-2
dialer string 67595
dialer-group 1
ppp authentication chap
ppp chap hostname 3600-2
ppp chap password 7 13061E010803
ppp multilink
map-class dialer CallBack
dialer callback-server username
dialer-list 1 protocol ip permit
****************** DEBUG stuff follows ****************************
R5 debug
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.8.25.2, timeout is 2 seconds:
Dialer1: ip (s=1.8.25.5, d=1.8.25.2), 100 bytes, interesting (ip PERMIT)
BRI0: rotor dialout [priority]
BRI0: Dialing cause ip (s=1.8.25.5, d=1.8.25.2)
BRI0: Attempting to dial 67594
ISDN BR0: Outgoing call id = 0x8078
ISDN BR0: Event: Call to 67594 at 64 Kb/s
ISDN BR0: received HOST_PROCEEDING.
ISDN BR0: Incoming call id = 0x1EE
ISDN BR0: received HOST_INCOMING_CALL
ISDN BR0: Event: Received a call from 67594 on B1 at 64 Kb/s
ISDN BR0: Incoming call rejected, unbindable
ISDN BR0: received HOST_DISCONNECT_ACK
ISDN BR0: Error: Unexpected Disconnect_Ack - callid 1EE
Dialer1: ip (s=1.8.25.5, d=1.8.25.2), 100 bytes, interesting (ip PERMIT).
Dialer1: ip (s=1.8.25.5, d=1.8.25.2), 100 bytes, interesting (ip PERMIT)
ISDN BR0: received HOST_DISCONNECT
ISDN BR0: Event: Call to 67594 was hung up.
BRI0: wait for carrier timeout, call id=0x8078
ISDN BR0: received HOST_DISCONNECT_ACK.
Dialer1: ip (s=1.8.25.5, d=1.8.25.2), 100 bytes, interesting (ip PERMIT)
BRI0: rotor dialout [priority]
BRI0: Dialing cause ip (s=1.8.25.5, d=1.8.25.2)
BRI0: Attempting to dial 67594
ISDN BR0: Outgoing call id = 0x8079
ISDN BR0: Event: Call to 67594 at 64 Kb/s
ISDN BR0: received HOST_PROCEEDING
ISDN BR0: Incoming call id = 0x1EF
ISDN BR0: received HOST_INCOMING_CALL
ISDN BR0: Event: Received a call from 67594 on B2 at 64 Kb/s
ISDN BR0: Incoming call rejected, unbindable
ISDN BR0: received HOST_DISCONNECT_ACK
ISDN BR0: Error: Unexpected Disconnect_Ack - callid 1EF.
Dialer1: ip (s=1.8.25.5, d=1.8.25.2), 100 bytes, interesting (ip PERMIT).
Success rate is 0 percent (0/5)
2500-2#
ISDN BR0: received HOST_DISCONNECT
ISDN BR0: Event: Call to 67594 was hung up.
BRI0: wait for carrier timeout, call id=0x8079
ISDN BR0: received HOST_DISCONNECT_ACK
ISDN BR0: Incoming call id = 0x1F0
ISDN BR0: received HOST_INCOMING_CALL
ISDN BR0: Event: Received a call from 67594 on B1 at 64 Kb/s
ISDN BR0: Incoming call rejected, unbindable
ISDN BR0: received HOST_DISCONNECT_ACK
ISDN BR0: Error: Unexpected Disconnect_Ack - callid 1F0ping 1.8.125.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.8.125.2, timeout is 2 seconds:
Dialer0: ip (s=1.8.125.5, d=1.8.125.2), 100 bytes, interesting (ip PERMIT)
BRI0: rotor dialout [priority]
BRI0: Dialing cause ip (s=1.8.125.5, d=1.8.125.2)
BRI0: Attempting to dial 67594
ISDN BR0: Outgoing call id = 0x807A
ISDN BR0: Event: Call to 67594 at 64 Kb/s
ISDN BR0: Incoming call id = 0x1F1
ISDN BR0: received HOST_INCOMING_CALL
ISDN BR0: Event: Received a call from 67594 on B1 at 64 Kb/s
ISDN BR0: Incoming call rejected, unbindable
ISDN BR0: received HOST_DISCONNECT_ACK
ISDN BR0: Error: Unexpected Disconnect_Ack - callid 1F1
ISDN BR0: received HOST_PROCEEDING.
Dialer0: ip (s=1.8.125.5, d=1.8.125.2), 100 bytes, interesting (ip PERMIT).
Dialer0: ip (s=1.8.125.5, d=1.8.125.2), 100 bytes, interesting (ip PERMIT)
ISDN BR0: received HOST_DISCONNECT
ISDN BR0: Event: Call to 67594 was hung up.
BRI0: wait for carrier timeout, call id=0x807A
ISDN BR0: received HOST_DISCONNECT_ACK.
Dialer0: ip (s=1.8.125.5, d=1.8.125.2), 100 bytes, interesting (ip PERMIT)
BRI0: rotor dialout [priority]
BRI0: Dialing cause ip (s=1.8.125.5, d=1.8.125.2)
BRI0: Attempting to dial 67594
ISDN BR0: Outgoing call id = 0x807B
ISDN BR0: Event: Call to 67594 at 64 Kb/s
ISDN BR0: received HOST_PROCEEDING.
Dialer0: ip (s=1.8.125.5, d=1.8.125.2), 100 bytes, interesting (ip PERMIT).
Success rate is 0 percent (0/5)
2500-2#
ISDN BR0: received HOST_DISCONNECT
ISDN BR0: Event: Call to 67594 was hung up.
BRI0: wait for carrier timeout, call id=0x807B
ISDN BR0: received HOST_DISCONNECT_ACK
****************************************************************************
****
R2 debug
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x81FB
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x81FC
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
2d22h: BR2/0:2 DDR: Caller id 67595 matched to profile R2Call
2d22h: Di0 DDR: Caller id Callback server starting to R2Call 67595
3600-2#
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x81FD
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
3600-2#term no
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x81FE
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595 mon
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
2d22h: BR2/0:2 DDR: Caller id 67595 matched to profile R2Call
2d22h: Di0 DDR: callback to R2Call already started
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x820A
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
2d22h: BRI2/0: wait for isdn carrier timeout, call id=0x820B
2d22h: Di1 DDR: ip (s=1.8.25.2, d=224.0.0.10), 60 bytes, outgoing
interesting (ip PERMIT)
2d22h: BR2/0 DDR: rotor dialout [priority]
2d22h: BR2/0 DDR: Dialing cause ip (s=1.8.25.2, d=224.0.0.10)
2d22h: BR2/0 DDR: Attempting to dial 67595
-----Original Message-----
From: Charles Huang [mailto:CharlesNY2000@Yahoo.Com]
Sent: Sun, October 28, 2001 1:18 AM
To: Joe Lee; ccielab@groupstudy.com
Subject: Dialer Callback with dialer profile - WORKS !!!
Thank you Joe. it worked
here's the config and debug if anyone is interested
! ppp callback client
!
hostname r4
!
username r2 password 0 ccie
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 44
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
ppp authentication chap
!
interface Dialer3
ip address 192.168.3.4 255.255.255.0
encapsulation ppp
dialer pool 44
dialer remote-name r2
dialer idle-timeout 30
dialer string 8358661
dialer-group 1
ppp callback request
ppp authentication chap
!
dialer-list 1 protocol ip permit
! ppp callback server
!
hostname r2
!
username r4 password 0 ccie
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 123
isdn switch-type basic-ni
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
ppp authentication chap
!
interface Dialer1
ip address 192.168.3.2 255.255.255.0
encapsulation ppp
dialer pool 123
dialer remote-name r4
dialer callback-secure
dialer idle-timeout 30
dialer string 8358662 class CALLBACK
dialer caller 8358662 callback
dialer-group 1
ppp callback accept
ppp authentication chap
!
map-class dialer CALLBACK
dialer callback-server username
!
dialer-list 1 protocol ip permit
r4#
r4#
r4#debug dialer
Dial on demand events debugging is on
r4#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
Oct 27 19:12:31: BR0/0 DDR: rotor dialout [priority]
Oct 27 19:12:31: BR0/0 DDR: Dialing cause ip (s=192.168.3.4, d=192.168.3.2)
Oct 27 19:12:31: BR0/0 DDR: Attempting to dial 8358661
Oct 27 19:12:31: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
Oct 27 19:12:31: BR0/0:1: interface must be fifo queue, force fifo
Oct 27 19:12:31: %DIALER-6-BIND: Interface BR0/0:1 bound to profile Di3
Oct 27 19:12:31: BR0/0:1 DDR: Callback negotiated - waiting for server
disconnect
Oct 27 19:12:32: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1,
changed state to up
Oct 27 19:12:33: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from
8358661 r2, call lasted 1 seconds
Oct 27 19:12:33: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
Oct 27 19:12:33: DDR: Callback client for r2 8358661 created
Oct 27 19:12:33: BR0/0 DDR: has total 0 call(s), dial_out 0, dial_in 0
Oct 27 19:12:33: BR0/0:1 DDR: disconnecting call.
Oct 27 19:12:33: %DIALER-6-UNBIND: Interface BR0/0:1 unbound from profile
Di3
Oct 27 19:12:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1,
changed state to down....
Success rate is 0 percent (0/5)
r4#
Oct 27 19:12:47: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
Oct 27 19:12:47: BR0/0:1: interface must be fifo queue, force fifo
Oct 27 19:12:47: %DIALER-6-BIND: Interface BR0/0:1 bound to profile Di3
Oct 27 19:12:47: BR0/0:1 DDR: dialer protocol up
Oct 27 19:12:47: BR0/0:1 DDR: Callback received from r2 8358661
Oct 27 19:12:47: DDR: Freeing callback to r2 8358661
Oct 27 19:12:48: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1,
changed state to up
Oct 27 19:12:53: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to
8358661 r2
r4#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/69 ms
r4#
----- Original Message -----
From: Joe Lee
To: Charles Huang ; ccielab@groupstudy.com
Sent: Saturday, October 27, 2001 7:08 PM
Subject: Re: PPP callback Server with Dialer Profile
Hi,
I use this command in the dialer profile and it can callback.
However, you need to know the caller's number.
dialer caller number callback
Joe
----- Original Message -----
From: "Charles Huang" <CharlesNY2000@Yahoo.Com>
To: <ccielab@groupstudy.com>
Sent: Sunday, October 28, 2001 6:21 AM
Subject: PPP callback Server with Dialer Profile
> Hi,
>
> Many of the PPP callback secnarios I found on CCO uses Legacy DDR. So I
tried
> PPP callback using Dialer Profile with no luck. Then I convert it to
Legacy
> DDR and it works. I was wondering if PPP callback can be configured
using
> Dialer Profile. Below are part of my configs. Maybe somebody can point
out
> where I did wrong.
>
> Thanks
>
> ! ppp callback client
> !
> hostname r4
> !
> username r2 password 0 ccie
> !
> interface BRI0/0
> no ip address
> encapsulation ppp
> dialer pool-member 44
> isdn switch-type basic-ni
> isdn spid1 0835866201 8358662
> isdn spid2 0835866401 8358664
> ppp authentication chap
> !
> interface Dialer3
> ip address 192.168.3.4 255.255.255.0
> encapsulation ppp
> dialer pool 44
> dialer remote-name r2
> dialer idle-timeout 30
> dialer string 8358661
> dialer-group 1
> ppp callback request
> ppp authentication chap
> !
> dialer-list 1 protocol ip permit
>
>
>
>
> ! ppp callback server
> !
> hostname r2
> !
> username r4 password 0 ccie
> !
> interface BRI0/0
> no ip address
> encapsulation ppp
> dialer pool-member 123
> isdn switch-type basic-ni
> isdn spid1 0835866101 8358661
> isdn spid2 0835866301 8358663
> ppp authentication chap
> !
> interface Dialer1
> ip address 192.168.3.2 255.255.255.0
> encapsulation ppp
> dialer pool 123
> dialer remote-name r4
> dialer callback-secure
> dialer idle-timeout 30
> dialer string 8358662 class CALLBACK
> dialer-group 1
> ppp callback accept
> ppp authentication chap
> !
> map-class dialer CALLBACK
> dialer callback-server username
> !
> dialer-list 1 protocol ip permit
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:26 GMT-3