From: Daniel Prinsloo (daniel@xxxxxxxxxxxxxx)
Date: Tue Oct 23 2001 - 15:35:11 GMT-3
Here is in short ;-) as I understand it, please let me know if my logic
got lost somewhere:
In Cisco IOS Release 11.2, the following two traffic shaping features
were introduced:
* Generic (adaptive) traffic shaping
* Traffic shaping for Frame Relay
Both of these features can be used to adjust the rate at which traffic
is sent by the router. These features also allow the router to throttle
the traffic rate based on the Backward Explicit Congestion Notification
(BECNs) received from the Frame Relay switch.
The terminology used with Frame Relay varies by service provider. Listed
are the most common terms. The local access rate is different from the
rate used in the cloud.
Forward Explicit Configuration Notification (FECN) and BECN are
congestion control measures used by the Frame Relay cloud.
The service provider will allow the customer to burst beyond the CIR for
a committed period of time. Any burst in excess of the committed burst
is discard eligible.
CIR and committed burst are negotiated with the service provider. They
are among the variables that determine the cost of the Frame Relay
connection.
Note that the traffic can be throttled based on BECN notifications.
A Cisco router configured as a Frame Relay switch does not send BECN
notifications back to the originating router. If you use this feature,
the switch should be able to tag packets with BECN notifications such as
an IGX"b.
Step 1
Router(config)#map-class frame-relay map-class-name
(Enters map class configuration mode so you can define a map class)
The map-class-name in the map class command must match the
map-class-name in the frame-relay class command.
In map class mode you identify the type of traffic shaping being
employed, such as average rate, BECN notifications, and queue lists.
Step 2
Router(config-map-class)#frame-relay traffic-rate average [peak]
(Defines the average and peak rates)
Use the frame-relay traffic-rate command when monitoring flow based on
average or peak rates.
Average rate in bits per second, it is equivalent to specifying the
contracted CIR
Peak Peak rate in bits per second. Peak = CIR + Be/Tc = CIR (1+Be/Bc) =
CIR +EIR
Be is Exess Burst. The maximum number of uncommitted bits that the Frame
RElay switch accepts to transfer beyond the CIR.
Bc is Committed Burst. The maximum number of bits that the switch agrees
to transfer during any committed rate measurement interval (Tc). The
higher the Tc-to-CIR ratio is, the longer the switch can handle a
sustained burst.
or
Router(config-map-class)#frame-relay adaptive-shaping becn
(Specifies that the router fluctuates the sending rate based on the
BECNs received)
Use the frame-relay adaptive-shaping becn command when managing flow
based on BECN notifications.
or
Router(config-map-class)#frame-relay custom-queue-list number
(Specifies a custom queue list)
or
Router(config-map-class)#frame-relay priority-group number
(Specifies a priority group)
Step 3
Router(config-if)#encapsulation frame-relay
(Enables Frame Relay on an interface)
Step 4
Router(config-if)#frame-relay traffic-shaping
(Enables Frame Relay traffic shaping on an interface)
Step 5
Router(config-if)#frame-relay class map-class-name
(Maps the map class to virtual circuits on the interface)
The frame-relay traffic-shaping command must be configured at the
interface level. The frame-relay class can be defined at either the
interface or subinterface level. If defined at the interface level, all
subinterfaces on that interface will take on the configured traffic
shaping parameters.
Examples:
Example using rate enforcement:
Central(config)#interface Serial2
Central(config-if)#no ip address
Central(config-if)#encapsulation frame-relay
Central(config-if)#frame-relay traffic-shaping
Central(config-if)#frame-relay class branch
!
!&
!
Central(config)#map-class frame-relay branch
Central(config-map-class)#frame-relay traffic-rate 9600 18000
Example for Traffic Shaping with BECN Support:
Central(config)#interface serial 0
Central(config-if)#no ip address
Central(config-if)#encapsulation frame-relay
Central(config-if)#frame-relay traffic-shaping
Central(config-if)#frame-relay class becnnotify
!
!&
!
Central(config)#map-class frame-relay becnnotify
Central(config-map-class)#frame-relay adaptive-shaping becn
Traffic Queueing Example:
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay traffic-shaping
frame-relay class slow_vcs
!
interface Serial0.1 point-to-point
ip address 10.128.30.1 255.255.255.248
ip ospf cost 200
bandwidth 10
frame-relay interface-dlci 101
!
interface Serial0.2 point-to-point
ip address 10.128.30.9 255.255.255.248
ip ospf cost 400
bandwidth 10
frame-relay interface-dlci 102
class fast_vcs
!
interface Serial0.3 point-to-point
ip address 10.128.30.17 255.255.255.248
ip ospf cost 200
bandwidth 10
frame-relay interface-dlci 103
!
map-class frame-relay slow_vcs
frame-relay traffic-rate 4800 9600
frame-relay custom-queue-list 1
!
map-class frame-relay fast_vcs
frame-relay traffic-rate 16000 64000
frame-relay priority-group 2
!
access-list 100 permit tcp any any eq 2065
access-list 115 permit tcp any any eq 256
!
priority-list 2 protocol decnet high
priority-list 2 protocol ip normal
priority-list 2 default medium
!
queue-list 1 protocol ip 1 list 100
queue-list 1 protocol ip 2 list 115
queue-list 1 default 3
queue-list 1 queue 1 byte-count 1600 limit 200
queue-list 1 queue 2 byte-count 600 limit 200
queue-list 1 queue 3 byte-count 500 limit 200
And then to verify it:
CentralA#sh frame-relay pvc
PVC Statistics for interface Serial3/1 (Frame Relay DTE)
DLCI = 110, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial3/1.1
input pkts 35 output pkts 40 in bytes 4324
out bytes 6684 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 25 out bcast bytes 5124
Shaping adapts to BECN
pvc create time 00:12:55, last time pvc status changed 00:12:55
Please let me know it you need more reference material.
Kevin(>gC6?u) wrote:
> Hi there,
>
> I don't know how to apply the map-class frame-relay.
>
> If I want to mark the DE when is over 40Kbps, how should I do?
> If I want to discard when is over 60Kbps, how should I do?
> If I want to check status per 120sec, how should I do?
>
> And please let me know where I could learn about the F/R map-class.
>
> Thanks.
-- Daniel Prinsloo Prove IT daniel@prove-it.co.uk www.prove-it.co.uk ICQ 42743324 Fax 0870 135 7712
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:24 GMT-3