RE: BGP Problem

From: Tony Ng (tonyng42@xxxxxxx)
Date: Tue Oct 23 2001 - 13:46:37 GMT-3


   
Rajeev,

To add to both Rick & Brian, if you want the loopback interface/rip route to
go into BGP as a 41.1.1.0/24 network, do a "no auto-summary" under BGP
router configuration.

Tony Ng

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Rick Burts
Sent: Tuesday, October 23, 2001 4:46 AM
To: Rajeev Siddappa
Cc: ccielab@groupstudy.com
Subject: Re: BGP Problem

Rajeev

I think there are two aspects involved in your question: redistribution of
network 41.0.0.0 via RIP and inclusion of network 44.0.0.0 via network
statement. Network 41.1.1.1 is on loopback1 and matches the network
statement in RIP so is included as a RIP route. It enters BGP via
redistribution and RIP redistributes a classful summary. There were some
interesting aspects of this in a reply message from Brian.

The aspect of network 44.1.1.1 is different. In your first config you
have a BGP network statement with mask for network 44.0.0.0 mask
255.255.255.0. When you use a mask BGP looks into the table for an exact
match: it must be exactly the address and exactly the mask. When you do
a show ip route, you will find that there is not an entry for 44.0.0.0
255.255.255.0. If you had changed the network statement and not put the
mask (network 44.0.0.0) BGP would have recognized the network in the table
and advertised it. When you changed the network statement to 44.1.1.0
mask 255.255.255.0 it did find a match in the routing table and included
the network in BGP.

You should work to understand carefully the operation of BGP in
redistribution as well as the subtle operation of the network and mask
statements.

Rick

Rick Burts, CCSI CCIE 4615 burts@mentortech.com
Mentor Technologies 240-568-6500 ext 6652
133 National Business Parkway 240-568-6515 fax
Annapolis Junction, Md 20701

Chesapeake Network Solutions has now become Mentor Technologies.
Mentor Technologies is a certified Cisco Training Partner and also
a Cisco Professional Services partner.
We offer most of the Cisco training courses.
We also offer training in Checkpoint Firewall software and
Fore Systems (now Marconi) and MicroMuse.
We also provide network consulting services including
design, management, and problem solving.
We have 21 CCIEs on our staff.
We offer the breakthrough VLAB remote access technology for
access to practice configuration on real equipment.

On Mon, 22 Oct 2001, Rajeev Siddappa wrote:

> Hi friends,
>
> I was working on the Boot camp lab two. I faced this
> strange problem.
>
> This is the config I have
>
> > 41.0.0.0 0.0.0.0 0
> 32768 ?
> R4#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R4
> !
> enable password cisco
> !
> ip subnet-zero
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 44.1.1.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Loopback1
> ip address 41.1.1.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial0
> ip address 173.168.40.2 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface TokenRing0
> ip address 100.100.100.1 255.255.255.0
> no ip directed-broadcast
> no keepalive
> ring-speed 4
> !
> interface BRI0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface PCbus0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router rip
> network 41.0.0.0
> !
> router bgp 1
> no synchronization
> network 44.0.0.0 mask 255.255.255.0
> redistribute static
> redistribute rip
> neighbor 173.168.40.1 remote-as 1
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 173.168.40.1
> ip route 0.0.0.0 0.0.0.0 Null0
> !
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> password cisco
> login
> !
> end
>
> AND MY SHOW IP BGP WILL SHOW ONLY
>
>
>
> R4# SH IP BGP
> BGP table version is 2, local router ID is 44.1.1.1
> Status codes: s suppressed, d damped, h history, *
> valid, > best, i - internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf
> Weight Path
> *> 41.0.0.0 0.0.0.0 0
> 32768 ?
> R4#
>
> but when I configure it like this
>
>
> router bgp 1
> no synchronization
> network 44.1.1.0 mask 255.255.255.0
> redistribute static
> redistribute rip
> neighbor 173.168.40.1 remote-as 1
>
> MY SHOW IP BGP WILL SHOW
>
> 4#sh ip bgp
> BGP table version is 3, local router ID is 44.1.1.1
> Status codes: s suppressed, d damped, h history, *
> valid, > best, i - internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf
> Weight Path
> *> 41.0.0.0 0.0.0.0 0
> 32768 ?
> *> 44.1.1.0/24 0.0.0.0 0
> 32768 i
> R4#
>
> why is it behaving like this.
>
> Please help me and explain me.
>
> Thank you,
>
> Rajeev.
>



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:23 GMT-3