Working SR/TLB configs

From: Jaspreet Bhatia (jasbhati@xxxxxxxxx)
Date: Mon Oct 22 2001 - 18:59:32 GMT-3


   
Folks,
                  We have finally gotten SR/TLB to work for us without a TR
3920 switch . I am including the configs here for everyone's reference
.Looking at the configs , they seem ridiculously simple . but I guess it is
one command that made the difference .

bridge 1 bitswap-layer3-addresses

The important thing to remember is that normally when you set up SR/TLB ,
it will work just fine for no-routable protocols like NetBIOS etc . For IP
you need to specify this extra command .Without this command if you have IP
on end stations and are trying to PING between them it will not work . WHY
? Because the SR/TLB will only look into the header and do the MAC address
conversion for MAC addresses contained in the header .What does ARP do ? It
places the MAC address in the data portion of the link-layer frame .Sneaky
Eh !

To fix this behavior and have the SR/TLB look inside the Data portion of
the frame to do the MAC address conversion you need the above command . I
am including the configurations and the RIF and ARP traces below .Thanks a
million to everyone who helped .....

R1----tokenring--------R2------Ethernet------R3

R1

Current configuration : 488 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
!
!
!
!
ip subnet-zero
no ip routing
!
cns event-service server
!
!
!
!
!
!
!
!
!
interface TokenRing0/0
  mtu 1500
  ip address 172.16.70.9 255.255.255.0
  no ip route-cache
  ring-speed 16
  multiring ip
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
!
line con 0
  transport input none
line aux 0
line vty 0 4
  --More-- Translating "R1"...domain server (255.25! )
no scheduler allocate
end

R1#

R2

R2#sh run
Building configuration...

Current configuration : 836 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
!
!
!
!
ip subnet-zero
no ip routing
!
!
!
!
!
source-bridge ring-group 1000
source-bridge transparent 1000 11 2 1
!
interface Ethernet0/0
  no ip address
  no ip route-cache
  bridge-group 1
!
interface TokenRing0/0
  no ip address
  no ip route-cache
  ring-speed 16
  source-bridge 4 2 1000
  source-bridge spanning
!
interface Serial1/0
  no ip address
  no ip route-cache
  shutdown
!
interface Serial1/1
  no ip address
  no ip route-cache
  shutdown
!
interface Serial1/2
  no ip address
  no ip route-cache
  shutdown
!
interface Serial1/3
  no ip address
  no ip route-cache
  shutdown
!
ip classless
ip http server
!
!
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
!
line con 0
line aux 0
line vty 0 4
!
end

R3

R3#sh run
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname R3
!
!
no ip routing
!
interface Ethernet0
  ip address 172.16.70.11 255.255.255.0
  no ip route-cache
  no keepalive
!
interface Serial0
  ip address 192.168.16.37 255.255.255.252
  no ip route-cache
  no fair-queue
  clockrate 64000
!
interface Serial1
  no ip address
  no ip route-cache
  shutdown
!
interface BRI0
  no ip address
  no ip route-cache
  shutdown
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
  login
!
end

RIF at R1

R1#sh rif
Codes: * interface, - static, + remote

Dst HW Addr Src HW Addr How Idle(min) Vlan Routing Information Field
0000.3049.d7df N/A To0/0 11 - 0890.00B2.3E82.0040
000a.0a50.5486 N/A To0/0 * - -
0006.c1ec.e54b N/A To0/0 0 - -
R1#

ARP at R1

R1#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 172.16.70.11 26 0000.3049.d7df SNAP TokenRing0/0
Internet 172.16.70.9 - 000a.0a50.5486 SNAP TokenRing0/0

RIF at R2
R2#sh rif
Codes: * interface, - static, + remote

Dst HW Addr Src HW Addr How Idle(min) Vlan Routing Information Field
000a.0a50.5486 N/A BG1 11 - 0810.00B2.3E82.0040
0006.c1ec.e54b N/A To0/0 * - -

ARP at R3
R3#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 172.16.70.11 - 0000.0c92.ebfb ARPA Ethernet0
Internet 172.16.70.9 28 0050.500a.2a61 ARPA Ethernet0
R3#

Thanks

Jaspreet



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:23 GMT-3