Re: SR/TLB using routers as end-stations

From: Rick Burts (burts@xxxxxxxxxxxxxx)
Date: Wed Oct 17 2001 - 09:43:49 GMT-3


   
Brian

If I understand your post correctly the MAC from r9 is showing up
on r4 in the bridge table and ARP is resolved between the two
routers. This is an indication that your bridging is working.
The clue to the problem is that the MAC shows up in the table in
bitswapped (canonical) order. The ARP gets through, the ARP response
is returned with the MAC address which gets bitswapped in the data
link header at the bridge but not in the payload. When the router
attempts to send the ICMP the destination MAC is not in the correct
order.

I would suggest that you add to the configuration on r4 the command
bridge 1 bitswap-layer3-address.
I think this will resolve your difficulty.

Rick

Rick Burts, CCSI CCIE 4615 burts@mentortech.com
Mentor Technologies 240-568-6500 ext 6652
133 National Business Parkway 240-568-6515 fax
Annapolis Junction, Md 20701

Chesapeake Network Solutions has now become Mentor Technologies.
Mentor Technologies is a certified Cisco Training Partner and also
a Cisco Professional Services partner.
We offer most of the Cisco training courses.
We also offer training in Checkpoint Firewall software and
Fore Systems (now Marconi) and MicroMuse.
We also provide network consulting services including
design, management, and problem solving.
We have 21 CCIEs on our staff.
We offer the breakthrough VLAB remote access technology for
access to practice configuration on real equipment.

On Tue, 16 Oct 2001, Brian Lodwick wrote:

> It seems as though Source-route bridging and SR/TLB are sore subjects with
> everyone. Is there anyone out there on the list that knows SR/TLB well
> enough to help me out with this scenario? I am STRUGLING!
>
> r9 tok0--ring9--3920---ring4----tok1 R4 e0-----e0 R11
>
> This is the diagram of my scenario.
> The 3920 Token-Ring switch has the port from r9 in TrCRF 0x09, and the port
> from r4 in TrCRF 0x04.
> Both TrCRF's 0x09 and 0x04 are in TrBRF 0x01.
>
> On router r9's Tok0 interface I have configured an ip address
> (172.16.70.9/24)
> And on r11's e0 interface I have configured an ip address (172.16.70.11/24)
>
> On r4 I have configured SR/TLB to translate from the ethernet segment to the
> Token-Ring and back.
>
> The hopefull outcome is to enable r11 and r9 to be able to ping each other.
> With the current configuration I resolve arp for r11 on r9, and on r11 I
> resolve arp for r9, but I cannot ping back and forth.
> r4 shows the Ring group 1000 to be a part of bridge group 1, and is in the
> forwarding state.
> When I do show bridge verbose on r4 it shows RingGroup1000 with the MAC
> address of r9's tok 0 flipped to canonical.
>
> r9#sh int tok 0
> TokenRing0 is up, line protocol is up
> Hardware is TMS380, address is 0000.3090.c7de (bia 0000.3090.c7de)
> ...snipped....
> r4#sh bridge verbose
>
> Total of 300 station blocks, 297 free
> Codes: P - permanent, S - self
>
> BG Hash Address Action Interface VC Age RX count TX
> count
> 1 5F/0 0000.0c4a.99c6 forward Ethernet0 - 1 1
> 0
> 1 98/0 0000.0c09.e37b forward RingGroup1000 - 0 219
> 11
> 1 DA/0 0050.547f.d00a forward Ethernet0 - 3 1
> 0
>
> This seems right, but I cannot ping across.
>
> Below are my configs:
> r11#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r11
> !
> !
> ip subnet-zero
> no ip routing
> no ip domain-lookup
> bridge irb
> !
> !
> !
> interface Ethernet0
> ip address 172.16.70.11 255.255.255.0
> no ip directed-broadcast
> no ip route-cache
> arp snap
> bridge-group 1
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> no ip route-cache
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> no ip route-cache
> shutdown
> !
> ip classless
> !
> bridge 1 protocol ieee
> alias exec ip sh ip route
> alias exec ipx sh ipx route
> alias exec int sh ip int brief
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> !
> end
>
>
> r4#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r4
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> cns event-service server
> !
> !
> bridge irb
> !
> source-bridge ring-group 1000
> source-bridge transparent 1000 11 2 1
> !
> !
> interface Ethernet0
> no ip address
> no ip directed-broadcast
> arp snap
> bridge-group 1
> !
> interface Ethernet1
> no ip address
> no ip directed-broadcast
> shutdown
> media-type 10BaseT
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> no ip mroute-cache
> shutdown
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface TokenRing0
> no ip address
> no ip directed-broadcast
> shutdown
> ring-speed 16
> !
> interface TokenRing1
> mtu 1500
> no ip address
> no ip directed-broadcast
> ring-speed 16
> multiring all
> source-bridge 4 2 1000
> source-bridge spanning
> !
> !
> ip classless
> no ip http server
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> bridge 1 protocol ieee
> bridge 1 priority 2
> alias exec ip sh ip route
> alias exec ipx sh ipx route
> alias exec int sh ip int brief
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
> r9#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r9
> !
> !
> ip subnet-zero
> no ip routing
> no ip domain-lookup
> ipx routing 0009.0009.0009
> bridge irb
> !
> !
> !
> interface Loopback0
> ip address 172.168.70.1 255.255.255.0
> no ip directed-broadcast
> no ip route-cache
> ipx network 701
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> no ip route-cache
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> no ip route-cache
> shutdown
> !
> interface TokenRing0
> mtu 1500
> ip address 172.16.70.9 255.255.255.0
> no ip directed-broadcast
> no ip route-cache
> ring-speed 16
> multiring all
> !
> ip classless
> !
> !
> !
> !
> alias exec ip sh ip route
> alias exec ipx sh ipx route
> alias exec int sh ip int brief
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> !
> end
>
> VTP VLAN Configuration
>
> TrBRF/TrCRF ID Brdg/Rng Ports Local
> State
> r4r9 49 0x01
> preferred
> r4 4 0x04 yes
> preferred
> r9 9 0x09 yes
> preferred
> Vlan1 100 0x0F
> preferred
> Vlan1.1 101 auto yes
> preferred
> Vlan2 200 0x0F
> preferred
> Vlan2.2 201 auto yes
> preferred
> Vlan3 300 0x0F
> preferred
> Vlan3.1 301 auto yes
> preferred
> trbrf-default 1005 0x0F
> preferred
> trcrf-default 1003 auto no
> preferred
>
> Local VLAN Port Configuration
>
> Port Mode TrCRF TrBRF
> 1 Static r4 r4r9
> 2 Static r9 r4r9
> 3 Static Vlan1.1 Vlan1
> 4 Static Vlan1.1 Vlan1
> 5 Static Vlan1.1 Vlan1
> 6 Static Vlan1.1 Vlan1
> 7 Static Vlan1.1 Vlan1
> 8 Static Vlan1.1 Vlan1
> 13 Static Vlan2.2 Vlan2
> 14 Static Vlan2.2 Vlan2
> 15 Static Vlan2.2 Vlan2
> 16 Static Vlan2.2 Vlan2
> 17 Static Vlan3.1 Vlan3
> 18 Static Vlan3.1 Vlan3
> 19 Static Vlan3.1 Vlan3
>
> Return More Change
>
>
> Thanks in advance everyone.
>
> >>>Brian
>
>
>
>
>
>
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:21 GMT-3