From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Thu Oct 11 2001 - 12:23:06 GMT-3
I now have a bridging scenario built, and I am having some problems with it.
I am attempting to bridge across a hub spoke frame environment, a serial
link and across 2 cat 5000's.
I have one spoke r3 with an ethernet in the bridge group 1, the hub r7 has
only it's serial in bridge-group 1, the other spoke is r1 and it has it's
frame relay interface in bridge-group 1 as well as it's other serial
interface in bridge-group 1, there is then another router connected to the
other side of r1's serial interface this router is r10 and then off of r10
is the 2 Cat 5000's and then on the other side of that is the last router
r5. Everything is fine through the trinks and everything on the switches and
r5, but I seem to be having problems with bridging over the serial links. On
the frame segment I have frame routed bridge to the dlci's on all of the
routers. All of the routers are running IRB and, but none are routing ip
except for r7. R7 has BVI1 with an ip address in the same subnet as all of
the other routers in bridge-group 1.
Anyone have any ideas on my problem?
(BTW I am not just writing to the list cause I don't want to spend the time
to figure out these problems. I figure the rest of the listers without as
much equipment as I have access to, may also benefit from these crazy
scenarios I create.)
Below are my configs and an attempt at a text diagram
/--frame----r3---eth
r7<
\--frame--r1---hdlc---r10---eth---Cat5000--trunk--Cat5000--trunk--R5
I have added the configs from r3, r7, r1, and r10 since I am pretty sure the
problem exists somewhere in this area, because if I add an ip address to
r10's ethernet I can ping between r5 and r10.
Thanks in advance everyone!
r3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
username r10 password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
bridge irb
!
!
!
interface Ethernet0
ip address 172.16.30.2 255.255.255.0
no ip directed-broadcast
no keepalive
bridge-group 1
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
no fair-queue
frame-relay map bridge 307 broadcast
bridge-group 1
!
interface Serial0.1 point-to-point
no ip directed-broadcast
no arp frame-relay
!
interface Serial1
ip address 209.154.229.1 255.255.255.252
no ip directed-broadcast
clockrate 2000000
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 55512121111
isdn spid2 55521211111
ppp callback request
ppp authentication chap
!
interface Dialer0
ip address 172.16.10.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer remote-name Jeff
dialer string 5551010
dialer string 5550101
dialer-group 1
pulse-time 0
ppp callback request
ppp authentication chap
ppp chap hostname Brian
!
ip default-gateway 172.16.30.3
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
!
!
map-class dialer Hoochie
dialer-list 1 protocol ip permit
bridge 1 protocol ieee
alias exec ip sh ip route
alias exec ipx sh ipx route
alias exec int sh ip int brief
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r7#sh run
Building configuration...
Current configuration : 1865 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging rate-limit console 10 except errors
!
!
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
no mgcp timer receive-rtcp
!
!
call rsvp-sync
!
!
!
!
!
bridge irb
!
!
controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 1/1
!
!
interface ATM0/0
no ip address
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
ip address 172.16.70.5 255.255.255.252
pvc 5/15
protocol ip 172.16.70.6 broadcast
protocol clns 49.0000.0008.0008.0008.00 broadcast
!
!
interface Serial1/0:0
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
!
interface Serial1/0:0.2 multipoint
ip ospf network point-to-multipoint
frame-relay map bridge 701 broadcast
frame-relay map bridge 703 broadcast
frame-relay interface-dlci 701
class vofr
vofr cisco
bridge-group 1
!
interface BVI1
ip address 172.16.30.1 255.255.255.0
!
!
router isis
net 48.0000.0007.0007.0007.00
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
!
map-class frame-relay vofr
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay voice bandwidth 32000
frame-relay fragment 80
!
snmp-server engineID local 80000009FF0000A1012D34BF
snmp-server manager
bridge 1 protocol ieee
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 777 pots
destination-pattern 777
port 3/1/0
!
dial-peer voice 111 vofr
destination-pattern 111
session target Serial1/0:0 701
!
!
alias exec ip sh ip route
alias exec int sh ip int brief
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r1#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
!
!
!
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
!
isdn voice-call-failure 0
cns event-service server
bridge irb
!
!
!
!
interface Ethernet0
ip address 172.16.30.4 255.255.255.0
no ip directed-broadcast
bridge-group 1
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
no fair-queue
clockrate 64000
frame-relay traffic-shaping
frame-relay map bridge 107 broadcast
bridge-group 1
!
interface Serial0.1 point-to-point
no ip directed-broadcast
!
interface Serial1
no ip address
no ip directed-broadcast
clockrate 64000
bridge-group 1
!
interface Switch0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no fair-queue
!
interface FR-ATM0
no ip address
no ip directed-broadcast
!
interface FR-ATM20
no ip address
no ip directed-broadcast
shutdown
!
router bgp 300
no synchronization
neighbor 209.154.229.13 remote-as 500
no auto-summary
!
ip classless
no ip http server
!
!
map-class frame-relay vofr
frame-relay voice bandwidth 40000
frame-relay fragment 80
no frame-relay adaptive-shaping
frame-relay fair-queue
!
bridge 1 protocol ieee
!
gatekeeper
shutdown
!
alias exec ip sh ip route
alias exec ipx sh ipx route
alias exec int sh ip int brief
!
line con 0
transport input none
line aux 0
line 2 3
line vty 0 4
login
!
!
voice-port 1/4
timeouts call-disconnect 0
!
voice-port 1/6
timeouts call-disconnect 0
timing hookflash-out 0
!
!
dial-peer voice 111 pots
destination-pattern 111
port 1/4
!
dial-peer voice 777 vofr
destination-pattern 777
session target Serial0 107
!
!
end
r10#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r10
!
!
username r3 password 0 cisco
username Brian password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
bridge irb
!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface Serial0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
shutdown
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 55510101111
isdn spid2 55501011111
ppp callback accept
ppp authentication chap
!
interface Dialer0
ip address 172.16.10.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
ip ospf demand-circuit
dialer remote-name Brian
dialer callback-secure
dialer string 5551212 class CBK
dialer pool 1
ppp callback accept
ppp authentication chap
!
router ospf 100
network 172.16.10.2 0.0.0.0 area 310
!
router rip
version 2
network 209.154.229.0
default-information originate
!
router bgp 65002
no synchronization
bgp confederation identifier 500
bgp confederation peers 65001
neighbor 209.154.229.6 remote-as 65002
neighbor 209.154.229.6 next-hop-self
neighbor 209.154.229.6 route-map loc out
neighbor 209.154.229.14 remote-as 300
no auto-summary
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
!
!
ip prefix-list everything seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list loc seq 5 permit 172.16.20.0/24 le 32
!
map-class dialer CBK
dialer callback-server username
route-map loc permit 10
match ip address prefix-list loc
set local-preference 500
!
route-map loc permit 20
match ip address prefix-list everything
set local-preference 100
!
bridge 1 protocol ieee
alias exec int sh ip int brief
alias exec ip sh ip route
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:17 GMT-3