From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Tue Oct 09 2001 - 17:12:07 GMT-3
Thanks Mike!
So then the side accepting the callback needs to also have a
dialer-list/dialer-group setup on it as well?
Also when you say "I wouldn't worry about proctors taking away points for
unnecessary commands. They are more concerned with "can this guy/gal set
this stuff up and get it working"."
How can you be so confident when you say this?
Do you know this for sure?
I have heard quite the contrary. I have heard it is quite important that you
place the correct commands in the correct places. I understand in the real
world many people have commands they "always" do when say they are working
on a certain technology, but in the lab I have heard that kind of logic is
frowned upon, because they want to know that there is a thought process
behind why you placed a certain command in a certain place, and not that you
just happened to get something working.
>>>Brian
>From: Mike Schlenger <mschlenger@n2nsolutions.com>
>To: 'Brian Lodwick' <xpranax@hotmail.com>
>Subject: RE: PPP Callback and dialer death
>Date: Tue, 9 Oct 2001 15:00:01 -0500
>
>
>
>-----Original Message-----
>From: Brian Lodwick [mailto:xpranax@hotmail.com]
>Sent: Tuesday, October 09, 2001 2:26 PM
>To: ccielab@groupstudy.com
>Subject: PPP Callback and dialer death
>
>
>Bruce Caslow said several times "ISDN is a CCIE killer" so I am going to
>kill it before it kills me (in the lab)! I am currently working on a
>scenario that uses ISDN dialer profiles, PPP authentication and is
>implementing PPP callback. I am a little curious though of the proper
>placement of commands. I don't want the proctors to have any reason to fail
>me, so I want to try to cut down on the unneeded commands.
>
>A couple of questions for the dialer masters out there:
>
>Do you need to have the commands "ppp callback request" "ppp callback
>accept" and (if you were going to bond the b-channels)"ppp multilink" on
>both the physical BRI line and the Dialer interface?
>
>If you are trying to configure ppp callback, these commands are necessary!
>Also, I wouldn't worry about proctors taking away points for unnecessary
>commands. They are more concerned with "can this guy/gal set this stuff up
>and get it working".
>
>Do you need to have "dialer-group _" on the callback router?
>
>Your dialer group command is necessary to define "interesting traffic" in
>order for the callback router to initiate a call. I didn't find any
>dialer-list statements to associate to your dialer groups permitting ip.
>
>
>I've also included my configs if anyone would like to tear them apart to
>tell me what is wrong with my dialer configurations if they see any. Cause
>I
>
>know everyone here loves to read through Cisco configs!
>
>Thanks in advance as always!!!
>
> >>>Brian
>
>r3#sh run
>Building configuration...
>
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname r3
>!
>!
>username r10 password 0 cisco
>ip subnet-zero
>no ip domain-lookup
>isdn switch-type basic-ni
>!
>!
>!
>interface Ethernet0
>ip address 172.16.50.1 255.255.255.248
>no ip directed-broadcast
>no keepalive
>!
>interface Serial0
>no ip address
>no ip directed-broadcast
>encapsulation frame-relay
>no ip mroute-cache
>no fair-queue
>!
>interface Serial0.1 point-to-point
>ip address 172.16.30.2 255.255.255.0
>no ip directed-broadcast
>ip ospf network point-to-multipoint
>no arp frame-relay
>frame-relay interface-dlci 307
>!
>interface Serial1
>ip address 209.154.229.1 255.255.255.252
>no ip directed-broadcast
>clockrate 2000000
>!
>interface BRI0
>no ip address
>no ip directed-broadcast
>encapsulation ppp
>dialer pool-member 1
>isdn switch-type basic-ni
>isdn spid1 55512121111
>isdn spid2 55521211111
>ppp callback request
>ppp authentication chap
>!
>interface Dialer0
>ip address 172.16.10.1 255.255.255.0
>no ip directed-broadcast
>encapsulation ppp
>dialer remote-name Jeff
>dialer string 5551010
>dialer string 5550101
>dialer-group 1
>ppp callback request
>ppp authentication chap
>ppp chap hostname Brian
>!
>router ospf 100
>network 172.16.10.1 0.0.0.0 area 5
>network 172.16.30.2 0.0.0.0 area 0
>!
>router bgp 300
>no synchronization
>neighbor 172.16.30.1 remote-as 300
>neighbor 172.16.30.1 next-hop-self
>neighbor 209.154.229.2 remote-as 500
>no auto-summary
>!
>ip nat translation timeout never
>ip nat translation tcp-timeout never
>ip nat translation udp-timeout never
>ip nat translation finrst-timeout never
>ip nat translation syn-timeout never
>ip nat translation dns-timeout never
>ip nat translation icmp-timeout never
>ip classless
>ip bgp-community new-format
>!
>!
>map-class dialer Hoochie
>dialer-list 1 protocol ip permit
>alias exec ip sh ip route
>alias exec ipx sh ipx route
>alias exec int sh ip int brief
>!
>line con 0
>transport input none
>line aux 0
>line vty 0 4
>login
>!
>end
>
>
>r10#sh run
>Building configuration...
>
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname r10
>!
>!
>username r3 password 0 cisco
>username Brian password 0 cisco
>ip subnet-zero
>no ip domain-lookup
>isdn switch-type basic-ni
>!
>!
>!
>interface Ethernet0
>ip address 209.154.229.5 255.255.255.252
>no ip directed-broadcast
>!
>interface Serial0
>ip address 209.154.229.13 255.255.255.252
>no ip directed-broadcast
>!
>interface Serial1
>no ip address
>no ip directed-broadcast
>shutdown
>!
>interface BRI0
>no ip address
>no ip directed-broadcast
>encapsulation ppp
>shutdown
>dialer pool-member 1
>isdn switch-type basic-ni
>isdn spid1 55510101111
>isdn spid2 55501011111
>ppp callback accept
>ppp authentication chap
>!
>interface Dialer0
>ip address 172.16.10.2 255.255.255.0
>no ip directed-broadcast
>encapsulation ppp
>ip ospf demand-circuit
>dialer remote-name Brian
>dialer callback-secure
>dialer string 5551212 class CBK
>dialer pool 1
>ppp callback accept
>ppp authentication chap
>!
>router ospf 100
>network 172.16.10.2 0.0.0.0 area 310
>!
>router rip
>version 2
>network 209.154.229.0
>!
>router bgp 65002
>no synchronization
>bgp confederation identifier 500
>bgp confederation peers 65001
>neighbor 209.154.229.6 remote-as 65002
>neighbor 209.154.229.6 next-hop-self
>neighbor 209.154.229.6 route-map loc out
>neighbor 209.154.229.14 remote-as 300
>no auto-summary
>!
>ip nat translation timeout never
>ip nat translation tcp-timeout never
>ip nat translation udp-timeout never
>ip nat translation finrst-timeout never
>ip nat translation syn-timeout never
>ip nat translation dns-timeout never
>ip nat translation icmp-timeout never
>ip classless
>!
>!
>ip prefix-list everything seq 5 permit 0.0.0.0/0 le 32
>!
>ip prefix-list loc seq 5 permit 172.16.20.0/24 le 32
>!
>map-class dialer CBK
>dialer callback-server username
>route-map loc permit 10
>match ip address prefix-list loc
>set local-preference 500
>!
>route-map loc permit 20
>match ip address prefix-list everything
>set local-preference 100
>!
>alias exec int sh ip int brief
>alias exec ip sh ip route
>alias exec ipx sh ipx route
>!
>line con 0
>transport input none
>line aux 0
>line vty 0 4
>!
>end
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:16 GMT-3