From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Mon Oct 08 2001 - 15:25:51 GMT-3
I am having a problem with my new lab scenario. I am attempting to bond 2
sync serial lines with ppp multilink between 2 routers. On one side I have a
4500 which works great, I configure a single ip address on a Multilink
interface and associate the 2 serial lines to this interface. The other side
is the issue though. On the other side I have a 2500 and I am unable to
configure a Multilink interface. When I put ppp multilink on the serial
interfaces then show ppp multilink it shows they are associated to a
Virtual-Access interface. Then when I show interface Virtual-Access it says
it is unnumbered using E0's ip address. I don't want it to use the E0's ip
address because basicly I don't understand how that would ever work? I
cannot configure an ip address on the Virtual-Access interface, because when
I try I get this:
r6(config)#int virtual-access 1
% Please use virtual template to configure your virtual access
So I tried to configure the ip address on the Virtual-template, but the
virtual-access interface still kept using ip unnumbered ethernet 0.
r4 = 4500 (one side of ppp multipoint link)
r6 = 2500 (other side of ppp multipoint link)
r5 = 2500 (on same ethernet segment as r6's e0)
How can I have this bonded link between r6 and r4, have the multipoint link
stay unnumbered ethernet 0 on r6, and still have every router be pingable?
If I put the ethernet of r6 in the same segment as r4 then the multilink
bundle works, but then r5 cannot ping r6 because they are in different
subnets. I am troubled with using unnumbered. I don't think I quite
understand the application of using ip unnumbered. I believe I understand
the concept, but I am failing to understand the correct application. Below
is a quick diagram and my configs. Thanks in advance!
>>>Brian
r5---eth----r6-----MPPP----r4
r5#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Ethernet0
ip address 192.168.50.1 255.255.255.0
no ip directed-broadcast
no keepalive
media-type 10BaseT
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial3
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0
no ip address
no ip directed-broadcast
!
interface FastEthernet0.1
encapsulation isl 17
ip address 209.154.229.9 255.255.255.252
no ip redirects
no ip directed-broadcast
!
interface FastEthernet0.2
encapsulation isl 20
ip address 209.154.229.6 255.255.255.252
no ip redirects
no ip directed-broadcast
!
router eigrp 100
network 192.168.50.0
network 209.154.229.0
!
router bgp 500
no synchronization
network 192.168.50.0
neighbor 209.154.229.5 remote-as 300
neighbor 209.154.229.10 remote-as 500
neighbor 209.154.229.10 next-hop-self
no auto-summary
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
!
alias exec ip sh ip route
alias exec ipx sh ipx route
alias exec int sh ip int brief
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r6#sh ru
3d02h: %SYS-5-CONFIG_I: Configured from console by consolen
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
ip subnet-zero
no ip domain-lookup
multilink virtual-template 1
!
!
!
interface Ethernet0
ip address 209.154.229.10 255.255.255.252 secondary
ip address 192.168.40.17 255.255.255.240
no ip directed-broadcast
!
interface Virtual-Template1
no ip address
no ip directed-broadcast
ppp multilink
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
clockrate 64000
ppp multilink
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 64000
ppp multilink
!
router eigrp 100
network 192.168.100.0
network 209.154.229.0
!
router bgp 500
no synchronization
neighbor 192.168.100.2 remote-as 500
neighbor 192.168.100.2 route-reflector-client
neighbor 209.154.229.9 remote-as 500
neighbor 209.154.229.9 route-reflector-client
no auto-summary
!
ip classless
!
alias exec ip sh ip route
alias exec ipx sh ipx route
alias exec int sh ip int brief
!
line con 0
transport input none
line 1 16
line aux 0
line vty 0 4
login
!
end
r4#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Multilink1
ip address 192.168.40.18 255.255.255.240
no ip directed-broadcast
no cdp enable
ppp multilink
multilink-group 1
!
interface Ethernet0
ip address 192.168.40.2 255.255.255.240
no ip directed-broadcast
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial3
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
ring-speed 16
!
interface TokenRing1
ip address 192.168.40.49 255.255.255.240
no ip directed-broadcast
ring-speed 16
!
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
!
alias exec ip sh ip route
alias exec int sh ip int brief
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r4#sh ppp multilink
Multilink1, bundle name is r6
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x12C/0x14 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 2 active, 0 inactive (max not set, min not set)
Serial1
Serial0
r6#sh ppp multilink
Bundle r4, 2 members, Master link is Virtual-Access1
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x14/0x12C rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member Links: 2 (max not set, min not set)
Serial0
Serial1
r6#sh int virtual-access 1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Ethernet0 (192.168.40.17)
MTU 1500 bytes, BW 3088 Kbit, DLY 100000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP Open, multilink Open
Open: IPCP
Last input 00:26:00, output never, output hang never
Last clearing of "show interface" counters 01:29:54
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
11 packets input, 1054 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
524 packets output, 65956 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:15 GMT-3