RE: SETTING UP DIAL ON DEMAND ROUTING USING AUX PORTS

From: Jon Carmichael (jonc@xxxxxxxxxxx)
Date: Thu Sep 06 2001 - 04:50:58 GMT-3


   
Here is a repost of a message originally written by Brian Dennis with
configs. It works, --the one on Cisco's web page does not. One problem is
that it only makes the call in one direction, so it's not good for callback
practice but everything else works.

Just a regular console cable from Aux to Aux.

JONC

*** Begin of Quote...

Below is a working config for AUX-to-AUX dialup using a rollover cable. R1
can call R3 using these configs.

Brian Dennis, CCIE #2210 (R&S)(ISP/Dial) CCSI #98640
5G Networks, Inc.
brian@5g.net
(925) 260-2724

R1#wr t
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
username R3 password 0 cisco
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
no ip finger
chat-script virtualmodem " "
!
!
!
!
process-max-time 200
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Async1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer in-band
 dialer pool-member 1
 async default routing
 async dynamic routing
 async mode dedicated
 no peer default ip address
 no fair-queue
 ppp authentication chap
!
interface Dialer0
 ip address 172.16.1.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name R3
 dialer string 5551212
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.254
!
dialer-list 1 protocol ip permit
!
alias exec c configure terminal
alias exec si show ip route
alias exec ci clear ip route *
alias exec oi show ip ospf interface
alias exec ion show ip ospf neighbor
alias exec ib show ip bgp
alias exec cib clear ip bgp *
alias exec ibn show ip bgp neighbor
alias exec wrb sho run | begin
alias exec sib show ip interface brief
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 exec-timeout 0 0
 script dialer virtualmodem
 modem Host
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 privilege level 15
 no login
!
end

R1#

R3#wr t
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
username R1 password 0 cisco
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
chat-script virtualmodem " "
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Async1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer in-band
 dialer pool-member 1
 async default routing
 async dynamic routing
 async mode dedicated
 no peer default ip address
 ppp authentication chap
!
interface Dialer0
 ip address 172.16.1.3 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name R1
 dialer string 5551212
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
ip classless
!
dialer-list 1 protocol ip permit
!
alias exec c configure terminal
alias exec si show ip route
alias exec ci clear ip route *
alias exec oi show ip ospf interface
alias exec ion show ip ospf neighbor
alias exec ib show ip bgp
alias exec cib clear ip bgp *
alias exec ibn show ip bgp neighbor
alias exec wrb sho run | begin
alias exec sib show ip interface brief
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 exec-timeout 0 0
 script dialer virtualmodem
 modem Dialin
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 privilege level 15
 no login
!
end

R3#

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> alain faure
> Sent: Monday, May 21, 2001 12:34 PM
> To: ccielab@groupstudy.com
> Subject: RE: DDR With Back To Back AUX
>
>
> Hello,
>
> I try PPP betwen aux port with out succes here is my conf
>
> r4<aux>---------port console cable-------<aux>r8
> -------------------------------------------------
> r4
> !
>
> interface Async1
> ip address 200.200.200.4 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> async dynamic routing
> async mode dedicated
> !
>
> line aux 0
> exec-timeout 0 0
> modem InOut
> transport input all
> speed 38400
> flowcontrol hardware
> -----------------------------------------
> r8
> !
>
> interface Async1
> ip address 200.200.200.8 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> async dynamic routing
> async mode dedicated
> !
>
> line aux 0
> exec-timeout 0 0
> modem InOut
> transport input all
> speed 38400
> flowcontrol hardware
>
>
> best regard
> --- Jon Carmichael <jonc@pacbell.net> a icrit : > The "right" way
> to simulate
> DDR with AUX ports is to DO DDR with AUX ports.
> > It's very inexpensive and does not require an ISDN switch. Two analog
> > modems, --two analog phone lines from your local telco. I use
> my voice and
> > my fax line and two RS-232 cables. The modems can be 14.4K or
> slower, --you
> > don't care in a test environment. If you can do it with
> modem, --then ISDN
> > is a snap.
> >
> > This is what you need to study.
> >
> >
> http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12
> cgcr/dial_
> > c/dcasddr.htm
> >
> > JONC
> >
> >
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > Ladipo Adefala
> > Sent: Monday, May 21, 2001 9:31 AM
> > To: gardiner@sprint.net; ccielab@groupstudy.com
> > Subject: Re: DDR With Back To Back AUX
> >
> >
> > I have the exact same problem, please help
> >
> >
> > >From: Jason Gardiner <gardiner@sprint.net>
> > >Reply-To: Jason Gardiner <gardiner@sprint.net>
> > >To: CCIE <ccielab@groupstudy.com>
> > >Subject: DDR With Back To Back AUX
> > >Date: Mon, 21 May 2001 09:53:17 -0400
> > >
> > >Hello,
> > >
> > >Has anyone been able to simulate DDR using back to back AUX
> > >connections? I've been able to establish a permanent
> connection via PPP
> > >and have almost got the DIALER part working. The connection
> drops after
> > >the dialer idle-timeout limit, but then it brings the connection right
> > >back up.
> > >
> > >I've got the interesting traffic set to icmp only, and according to
> > >debug, no interesting traffic passes or initiates the link. I don't
> > >have the configs with me, but any pointers would be appreciated.
> > >
> > >--
> > >Thanks,
> > >
> > >Jason Gardiner
> > >Engineering Services
> > >Sprint E|Solutions
> > >
> > >"The only thing to prevent what's past is to put a stop to it before it
> > >happens."
> > > - Sir Boyle Roche
> > >**Please read:http://www.groupstudy.com/list/posting.html
> >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:14 GMT-3