From: SFeldberg@xxxxxxxxxxxxx
Date: Thu Aug 30 2001 - 12:26:05 GMT-3
OK... this would make it work on your R4 router.
Before...
R2-Vail#sh ip bgp
BGP table version is 39, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i192.168.1.196/30 192.168.1.222 0 100 0 i
*>i192.168.1.200/30 192.168.1.205 0 100 0 400 i
*>i192.168.1.204/30 192.168.1.197 0 100 0 i
*> 192.168.1.208/30 0.0.0.0 0 32768 i
*> 192.168.1.212/30 192.168.1.210 0 0 300 i
*> 192.168.1.216/30 192.168.1.225 0 0 200 i
*>i192.168.1.220/30 192.168.1.222 0 100 0 i
*> 192.168.1.224/30 0.0.0.0 0 32768 i
*>i192.168.50.0 192.168.1.205 0 100 0 400 i
*>i192.168.75.0 192.168.1.205 0 100 0 400 i
*> 192.168.100.0 192.168.1.225 0 0 200 i
*> 192.168.200.0 192.168.1.225 0 0 200 i
*> 192.168.250.0 192.168.1.210 0 0 300 i
router bgp 100
no synchronization
network 192.168.1.208 mask 255.255.255.252
network 192.168.1.224 mask 255.255.255.252
timers bgp 5 15
neighbor 192.168.1.197 remote-as 100
neighbor 192.168.1.197 ebgp-multihop 2
neighbor 192.168.1.210 remote-as 300
neighbor 192.168.1.222 remote-as 100
neighbor 192.168.1.225 remote-as 200
neighbor 192.168.1.225 distribute-list AS500 in
!
access-list 2 permit any
access-list 101 permit ip any 192.168.100.0 0.0.0.255
route-map AS500 permit 10
match ip address 101
set as-path prepend 500
!
route-map AS500 permit 20
match ip address 2
After...
R2-Vail#sh ip bgp
BGP table version is 14, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i192.168.1.196/30 192.168.1.222 0 100 0 i
*>i192.168.1.200/30 192.168.1.205 0 100 0 400 i
*>i192.168.1.204/30 192.168.1.197 0 100 0 i
*> 192.168.1.208/30 0.0.0.0 0 32768 i
*> 192.168.1.212/30 192.168.1.210 0 0 300 i
*> 192.168.1.216/30 192.168.1.225 0 0 200 i
*>i192.168.1.220/30 192.168.1.222 0 100 0 i
*> 192.168.1.224/30 0.0.0.0 0 32768 i
*>i192.168.50.0 192.168.1.205 0 100 0 400 i
*>i192.168.75.0 192.168.1.205 0 100 0 400 i
*> 192.168.100.0 192.168.1.225 0 0 500 200 i
*> 192.168.200.0 192.168.1.225 0 0 200 i
*> 192.168.250.0 192.168.1.210 0 0 300 i
Steve
Marek Janik
<mjanik@mcx.c To: SFeldberg@edeltacom.com
om.pl> cc: ccielab@groupstudy.com
Subject: Re[2]: bgp question
08/30/2001
10:44 AM
Hello SFeldberg,
Thursday, August 30, 2001, 4:13:08 PM, you wrote:
Sec> You can do that with a route-map. This scenario is an add-on to the
Sec> configuration on p. 168 of Doyle vol II. I have added a loopback
interface
Sec> on Taos, added the appropriate network statement and route-map. The
Sec> 99.99.99.0 network appers on Vail as if it originated in AS 500. In
your
Sec> scenario, you would prepend AS500 to the route on R7.
Ok ... but I have to prepend route whitch I got from R7. I can't change
R7 configuration ...
-- Marek Janik **Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:00 GMT-3