From: SFeldberg@xxxxxxxxxxxxx
Date: Thu Aug 30 2001 - 11:13:08 GMT-3
You can do that with a route-map. This scenario is an add-on to the
configuration on p. 168 of Doyle vol II. I have added a loopback interface
on Taos, added the appropriate network statement and route-map. The
99.99.99.0 network appers on Vail as if it originated in AS 500. In your
scenario, you would prepend AS500 to the route on R7.
R1-Taos#sh run
!
interface Loopback9
ip address 99.99.99.1 255.255.255.0
no ip directed-broadcast
!
router bgp 200
no synchronization
bgp router-id 10.100.83.1
network 99.99.99.0 mask 255.255.255.0
network 192.168.1.216 mask 255.255.255.252
network 192.168.1.0
network 192.168.100.0
network 192.168.200.0
timers bgp 5 15
neighbor 192.168.1.217 remote-as 200
neighbor 192.168.1.226 remote-as 100
neighbor 192.168.1.226 route-map AS500 out
no auto-summary
!
access-list 1 permit 99.99.99.0 0.0.0.255
access-list 2 permit any
!
route-map AS500 permit 10
match ip address 1
set as-path prepend 500
R1-Taos#sh ip bgp
BGP table version is 15, local router ID is 10.100.83.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 99.99.99.0/24 0.0.0.0 0 32768 i
*> 192.168.1.196/30 192.168.1.226 0 100 i
*> 192.168.1.200/30 192.168.1.226 0 100 400 i
*> 192.168.1.204/30 192.168.1.226 0 100 i
*> 192.168.1.208/30 192.168.1.226 0 0 100 i
*> 192.168.1.212/30 192.168.1.226 0 100 300 i
*> 192.168.1.216/30 0.0.0.0 0 32768 i
*> 192.168.1.220/30 192.168.1.226 0 100 i
*> 192.168.1.224/30 192.168.1.226 0 0 100 i
*> 192.168.50.0 192.168.1.226 0 100 400 i
*> 192.168.75.0 192.168.1.226 0 100 400 i
*> 192.168.100.0 0.0.0.0 0 32768 i
*> 192.168.200.0 0.0.0.0 0 32768 i
*> 192.168.250.0 192.168.1.226 0 100 300 i
R2-Vail#sh ip bgp
BGP table version is 36, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 99.99.99.0/24 192.168.1.225 0 0 200 500 i
*>i192.168.1.196/30 192.168.1.222 0 100 0 i
*>i192.168.1.200/30 192.168.1.205 0 100 0 400 i
*>i192.168.1.204/30 192.168.1.197 0 100 0 i
*> 192.168.1.208/30 0.0.0.0 0 32768 i
*> 192.168.1.212/30 192.168.1.210 0 0 300 i
*> 192.168.1.216/30 192.168.1.225 0 0 200 i
*>i192.168.1.220/30 192.168.1.222 0 100 0 i
*> 192.168.1.224/30 0.0.0.0 0 32768 i
*>i192.168.50.0 192.168.1.205 0 100 0 400 i
*>i192.168.75.0 192.168.1.205 0 100 0 400 i
*> 192.168.100.0 192.168.1.225 0 0 200 i
*> 192.168.200.0 192.168.1.225 0 0 200 i
*> 192.168.250.0 192.168.1.210 0 0 300 i
Steve
Marek Janik
<mjanik@mcx.c To: ccielab@groupstudy.com
om.pl> cc:
Sent by: Subject: bgp question
nobody@groups
tudy.com
08/30/2001
09:26 AM
Please
respond to
Marek Janik
Hello ccielab,
I've got three routers with BGP
R3 ------- R4 --------- R7
AS3 - ibgp - AS3 - ebpg - AS 200
And on R4 I've got a few routes from R7 .... Is there any way to send
one of these routes from R4 to R3 as originating from AS500 (other than
AS 200)
-- Marek Janik **Please read:http://www.groupstudy.com/list/posting.html **Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:00 GMT-3