From: Martin, Chris (chris@xxxxxxxxxxxx)
Date: Tue Aug 28 2001 - 17:26:39 GMT-3
Id like to add another twist to this scenerio. Say you want routes that go
out of ISP 1 to return through ISP1. Would you put a route map on the
connection that goes to ISP2 that denies packets coming from networks
registered from ISP1?
A common scenerio in the political layer is some companies have customers
who dont like ISP1, therefore they go through ISP2. Yet other customers like
ISP1 rates better so they prefer to go with ISP1. Yet all customers are
connected to the company who has the 2 ISP connections. What is a good
design method in assuring once a packet leaves the interface connected to
ISP1, that it returns through ISP1? Many times by default the destination
will find the closest AS that gets to you, which may or may not be the
original ISP carrier who sent the traffic.
----- Original Message -----
From: "Jing Zeng" <jzeng@peakxv.net>
To: "Rick Stephens" <rstephens@wantec.com>
Cc: <ccielab@groupstudy.com>
Sent: Tuesday, August 28, 2001 1:01 PM
Subject: Re: BGP: AS-PATH PREPEND
> First, I have a question, why you are using private address here. Or you
are
> doing NAT somewhere? Please clear this question.
>
> For the traffic going out, only set the default route will not make sense
> here.
> Because you get the BGP routes from ISP1 and ISP2, and the router will
> choose the longest match route to reach the destination, normally the
router
> will not use the defualt route for most of those traffic that has an
> explicit route in the BGP table.
> The way to solve this is set the local preference for ISP1 bigger than
ISP2
> ( or you can set weight on cisco routers).
>
> For the traffic coming in, the potential problem is ISP1 aggregation. So
the
> destination will get two routes for you, one is from ISP1 and on is from
> ISP2, but the ISP1 summarize your route, so the route from ISP2 is the
> longest match, them all the traffic will come to you through ISP2. This is
> only the potential problem I guess, and because you are using private
> address here, so not so sure.
>
> Jing Zeng
>
> ----- Original Message -----
> From: "Yves Fauser" <Yves@Fauser.de>
> To: "Rick Stephens" <rstephens@wantec.com>
> Cc: <ccielab@groupstudy.com>
> Sent: Tuesday, August 28, 2001 6:36 AM
> Subject: Re: BGP: AS-PATH PREPEND
>
>
> > Hi Rick,
> >
> > I did not have the chance to test it in a Lab, but I don't see a <ip
> > as-path access-list 1> statement in your sample config. When you are
> > doing :
> > ----------------------------------------------------
> > route-map set-as-path 10 permit
> > match as-path 1
> > set as-path prepend 12345 12345 12345 12345
> >
> > route-map set-as-path 20 permit
> > match address 2
> >
> > access-list 1 permit 192.168.1.0 0.0.0.255
> > access-list 2 permit 0.0.0.0 255.255.255.255
> > ----------------------------------------------------
> >
> > I think you wanted to do :
> > -----------------------------------------------------
> > route-map set-as-path 10 permit
> > match ip address 1
> > set as-path prepend 12345 12345 12345 12345
> >
> > route-map set-as-path 20 permit
> >
> > access-list 1 permit 192.168.1.0
> > -----------------------------------------------------
> > This should prepend the as-path <12345 12345 12345 12345> to the
> > 192.168.1.0 prefix
> >
> > Or you could do :
> > -----------------------------------------------------
> > ip as-path access-list 1 permit ^$
> >
> > route-map set-as-path 10 permit
> > match as-path 1
> > set as-path prepend 12345 12345 12345 12345
> >
> > route-map set-as-path 20 permit
> > ------------------------------------------------------
> > This should prepend the as-path <12345 12345 12345 12345> to all
> > prefixes that are localy originated by your AS.
> >
> > hope this helps,
> >
> > Yves
> >
> >
> > Rick Stephens wrote:
> >
> > > Group,
> > > I have a T1 connection going to one ISP (AS 111), and a second 384K
> > > connection going to a different ISP (AS 222). We would like to use the
> > > second connection for backup only. That is, no load sharing rather
only
> to
> > > be used if the T1 goes down.
> > > The T1 is out Serial 0/0.1. The backup connection is out a Wireless
> > > Ethernet. My thought was that simple static routes with adminstrative
> > > distance would prevent the backup line from being used when going out.
> But
> > > the BGP configuration is giving me a little trouble. I thought I
could
> > > prepend the path to the backup connection to make the T1 path to the
1st
> ISP
> > > the best route. But, whenever I set this configuration the incoming
> traffic
> > > comes in through the 2nd ISP. Where am I going wrong? What is the
best
> way?
> > > Thank you in advance.
> > >
> > > router bgp 12345
> > > network 192.168.1.0 mask 255.255.255.0
> > > ! Primary Neighbor (T1 Connection)
> > > neighbor 172.16.1.1 remote-as 111
> > > ! Backup Wireless Neighbor (384K Connection)
> > > neighbor 172.16.10.1 remote-as 222
> > > neighbor 172.16.10.1 route-map set-as-path out
> > >
> > > ip route 0.0.0.0 0.0.0.0 Serial0/0.1
> > > ip route 0.0.0.0 0.0.0.0 172.16.10.1 100
> > >
> > > route-map set-as-path 10 permit
> > > match as-path 1
> > > set as-path prepend 12345 12345 12345 12345
> > >
> > > route-map set-as-path 20 permit
> > > match address 2
> > >
> > > access-list 1 permit 192.168.1.0 0.0.0.255
> > > access-list 2 permit 0.0.0.0 255.255.255.255
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:59 GMT-3