RE: A cry for redistribution help! VLSM /28 into FLSM /24 (summa ry-ad dress)

From: Daniel C. Young (danyoung99@xxxxxxxxxxxx)
Date: Sun Aug 19 2001 - 00:08:34 GMT-3


   
Jim,

You are absolutely correct with your points below. However, to test this
properly, you need to be working with a class B major network. Recall that
IGRP has no problem with classful summaries. In your case, since R2 still
considers those loopbacks as being in a different classful network, you will
not have much of a problem injecting them into the IGRP domain.

When practicing redistribution scenarios, use the same Class B address
throughout your network. This is what causes the most headaches. In this
case, you'll notice that either IGRP needs a default-network statement or
you need to hack OSPF. This has been well-documented before, but I'd also
like to point out that summary-address also has some code-dependencies. I
believe that 12.0.XT does not support it (I'll have to double-check). Also,
your ASBR must be mutually redistributing. That is, if R2 is only
redistributing OSPF into IGRP and not vice versa, it will not work. The
redistribute connected and summary-address combination on R1 is another
possibility. Yet a third option is to use secondary addresses, disable
split-horizon on the IGRP router and filter like crazy (very very dirty).

That being said, understand that these "hacks" are a last-resort, because
they are messy. When confronted with redistribution tasks on the lab, select
the option that has the least impact on the rest of the network.

Regards,
Daniel Young
CCIE #7999

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Jim Brown
Sent: Friday, 17 August 2001 7:26 PM
To: 'afiddler'; 'ccielab@groupstudy.com'
Subject: RE: A cry for redistribution help! VLSM /28 into FLSM /24
(summa ry-ad dress)

I actually began to think I was going crazy until I realized this doesn't
prove the summary-address works as proposed.

You can remove the summary-address command and the 192.168.2.0 network will
still appear in the IGRP domain. Why?

Reason: During redistribution the IGRP process will advertise the route as a
classful network by default. If it doesn't match the mask and major network
of the outgoing interface, the process will advertise it as a major
network... 192.168.2.0

This is the only reason I can tell it is showing up in the IGRP domain. Try
this same exercise with the 172.16.0.0 subnetted network.

-----Original Message-----
From: afiddler [mailto:afiddler@wi.rr.com]
Sent: Friday, August 17, 2001 4:47 PM
To: Jim Brown
Subject: Re: A cry for redistribution help! VLSM /28 into FLSM /24
(summary-ad dress)

HTH

R1
interface Loopback0
 ip address 192.168.2.1 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback1
 ip address 192.168.2.5 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback2
 ip address 192.168.2.9 255.255.255.252
 ip ospf network point-to-point
interface FastEthernet0
 ip address 192.168.3.1 255.255.255.252
 no ip mroute-cache
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.3 area 0
 network 192.168.2.4 0.0.0.3 area 0
 network 192.168.2.8 0.0.0.3 area 0
 network 192.168.3.0 0.0.0.3 area 1

R2
interface Ethernet0
 ip address 192.168.3.2 255.255.255.252
 no ip directed-broadcast
!
interface Serial1
 ip address 192.168.4.1 255.255.255.252
 no ip directed-broadcast
!
router ospf 1
 summary-address 192.168.2.0 255.255.255.0
 network 192.168.3.0 0.0.0.3 area 1
!
router igrp 1
 redistribute ospf 1 metric 10000 1000 255 1 1500
 network 192.168.4.0

sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.0 is directly connected, Serial1
     192.168.2.0/30 is subnetted, 3 subnets
O IA 192.168.2.8 [110/11] via 192.168.3.1, 00:02:19, Ethernet0
O IA 192.168.2.0 [110/11] via 192.168.3.1, 00:02:29, Ethernet0
O IA 192.168.2.4 [110/11] via 192.168.3.1, 00:02:19, Ethernet0
     192.168.3.0/30 is subnetted, 1 subnets
C 192.168.3.0 is directly connected, Ethernet0

interface Serial1
 ip address 192.168.4.2 255.255.255.252
 no ip directed-broadcast
!
router igrp 1
 network 192.168.4.0

sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

S 172.20.0.0/16 is directly connected, Null0
     192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.0 is directly connected, Serial1
I 192.168.2.0/24 [100/9476] via 192.168.4.1, 00:01:14, Serial1
I 192.168.3.0/24 [100/8576] via 192.168.4.1, 00:01:14, Serial1

----- Original Message -----
From: "Jim Brown" <Jim.Brown@CaseLogic.com>
To: <ccielab@groupstudy.com>
Sent: Friday, August 17, 2001 4:52 PM
Subject: A cry for redistribution help! VLSM /28 into FLSM /24 (summary-ad
dress)

> On my quest for redistribution knowledge, this has escaped me.
>
> I have searched high and low, through the archives, in Usenet, and on the
> Cisco web site to no avail.
>
> This discussion has gone on forever and I cannot replicate it with any
> consistency.
>
> How do you use the summary-address command at the redistribution point to
> summarize longer masks into shorter masks?
>
> Everyone tells me it works, but not for me. Am I missing something? Are
> there gothcas escaping me?
>
> I'm throwing in the towel and begging for help. I pray the redistribution
> Gods will smile on me and offer enlightenment.
>
> Scenario in question:
>
> Area0--R1--Area1--R2--IGRP--R3
>
> I have a couple of LoopBack interfaces in Area 0 with a /30. I attempting
to
> summarize them in to a /24 for successful redistribution into IGRP. I
apply
> the summary-address command on R2, but they won't appear in the R2 IGRP
> update, or on R3 if you could imagine that.
>
> I know the summary-address command is documented for summarization INTO
OSPF
> on an ASBR, but there is so much talk about using it in the reverse that I
> feel left out of the party.
>
> I know I can use an area range command on an ABR for summarization
upstream.
>
> I know I can inject a default route into the FLSM to provide reachability.
>
> All this I know, but what I want to use is the summary-address command.
> HELP!
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:53 GMT-3