From: Padhu (LFG) (padhu@xxxxxxxxxxxx)
Date: Fri Aug 17 2001 - 16:46:40 GMT-3
Just did this real quick. Route-maps can do wonders. The below config is
very basic ..You can manipulate however you want to meet a complex
condition. match an ext ACL AND match an interface
AND etc etc....
Cheers,Padhu
interface Loopback0
ip address 172.16.1.1 255.255.255.0
ip nat inside
interface Serial1
ip address 172.16.50.65 255.255.255.224
ip nat outside
ip nat inside source route-map custom-nat interface Serial1 overload
access-list 177 permit ip host 172.16.1.1 host 192.168.1.254 log
route-map custom-nat permit 10
match ip address 177
ip telnet source-interface loopback 0
telnet 192.168.1.254
R1#sh ip nat tra
Pro Inside global Inside local Outside local Outside global
tcp 172.16.50.65:13799 172.16.1.1:13799 192.168.1.254:23
192.168.1.254:23
-----Original Message-----
From: Patrick [mailto:pjm@roadrunner.nf.net]
Sent: Friday, August 17, 2001 2:10 PM
To: ccielab@groupstudy.com
Subject: Conditional NAT!
Can you perform NAT based on a policy?
I have a need to NAT based on destination adddress.....
Patrick
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:52 GMT-3