Recursive routing resolved with bad metrics?

From: SFeldberg@xxxxxxxxxxxxx
Date: Thu Aug 16 2001 - 19:20:02 GMT-3


   
Group,

This is my first "real" post, I have read the archives regarding this
subject. My understanding of this issue is that tunnel "flapping" can be
caused by the dynamic routing protocol trying to reach the tunnel
destination address via the tunnel itself. That being said...

I am using EIGRP in my scenario with three routers, in a small
hub-and-spoke configuration. It is actually part of a larger configuration
(Fatkid 325) where the tunnel was created as a substitute for the BRI
connection that is not available. R3 is connected to R4 via serial, R2 is
connected to R4 via ethernet. The tunnel sources and destinations are
Loopback interfaces on R2 and R3. The tunnel interfaces themselves are
using a /28 subnet of the default network for the exercise.

I have read postings that have suggested using a distribute-list to
accomplish the filtering of the updates that cause recursive routing. I
tried this approach, but I was not able to get it to work. I then thought,
what if I make the metrics of the tunnel so bad that EIGRP would not see
the tunnel as a preferable option? Doing this, I have achieved the
objective of keeping the tunnel up while neighbor relationships are formed
while having all routes advertised through the tunnel.

I have questions about the "gotchas" I will encounter in this scenario, and
I would appreciate feedback from anyone who can provide me with alternative
methods (no passive-interface solutions please).

R3
interface Loopback0
 ip address 190.19.15.185 255.255.255.240
 no ip directed-broadcast
!
interface Tunnel0
 bandwidth 1
 ip address 190.19.15.135 255.255.255.240
 no ip directed-broadcast
 delay 10000
 tunnel source Loopback0
 tunnel destination 190.19.15.151
!
interface Serial0
 bandwidth 4000
 ip address 190.19.15.5 255.255.255.192
 no ip directed-broadcast
 no ip mroute-cache
!
router eigrp 1
 network 190.19.0.0

R3#sh ip eig n
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
                                        (sec) (ms) Cnt Num
1 190.19.15.131 Tu0 10 00:28:12 0 3000 0 7330
0 190.19.15.4 Se0 13 00:29:18 39 234 0 9126

R3#sh ip rou
     190.19.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 190.19.15.160/28 [90/1280000] via 190.19.15.4, Serial0
C 190.19.15.176/28 is directly connected, Loopback0
C 190.19.15.128/28 is directly connected, Tunnel0
D 190.19.15.144/28 [90/1305600] via 190.19.15.4, Serial0
C 190.19.15.0/26 is directly connected, Serial0
D 190.19.15.64/26 [90/1177600] via 190.19.15.4, Serial0

R3#sh ip eig to
IP-EIGRP Topology Table for AS(1)/ID(190.19.15.185)

P 190.19.15.160/28, 1 successors, FD is 1280000
         via 190.19.15.4 (1280000/128256), Serial0
         via 190.19.15.131 (2562713600/793600), Tunnel0
P 190.19.15.176/28, 1 successors, FD is 128256
         via Connected, Loopback0
P 190.19.15.128/28, 1 successors, FD is 2562560000
         via Connected, Tunnel0
P 190.19.15.144/28, 1 successors, FD is 1305600
         via 190.19.15.4 (1305600/409600), Serial0
         via 190.19.15.131 (2562688000/128256), Tunnel0
P 190.19.15.0/26, 1 successors, FD is 551936
         via Connected, Serial0
P 190.19.15.64/26, 1 successors, FD is 1177600
         via 190.19.15.4 (1177600/281600), Serial0
         via 190.19.15.131 (2562585600/665600), Tunnel0

R2
interface Loopback0
 ip address 190.19.15.151 255.255.255.240
 no ip directed-broadcast
!
interface Tunnel0
 bandwidth 1
 ip address 190.19.15.131 255.255.255.240
 no ip directed-broadcast
 delay 10000
 tunnel source Loopback0
 tunnel destination 190.19.15.185
!
interface Ethernet0
 ip address 190.19.15.71 255.255.255.192
 no ip directed-broadcast
!
router eigrp 1
 network 190.19.0.0

R2#sh ip eig n
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
                                        (sec) (ms) Cnt Num
1 190.19.15.135 Tu0 12 00:29:04 864 5000 0 4248
0 190.19.15.74 Et0 13 00:29:11 16 200 0 9125

R2#sh ip rou
     190.19.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 190.19.15.160/28 [90/409600] via 190.19.15.74, 00:22:57, Ethernet0
D 190.19.15.176/28 [90/39620096] via 190.19.15.74, 00:22:57,
Ethernet0
C 190.19.15.128/28 is directly connected, Tunnel0
C 190.19.15.144/28 is directly connected, Loopback0
D 190.19.15.0/26 [90/39492096] via 190.19.15.74, 00:22:57, Ethernet0
C 190.19.15.64/26 is directly connected, Ethernet0

R2#sh ip eig to
IP-EIGRP Topology Table for process 1

P 190.19.15.160/28, 1 successors, FD is 793600
         via 190.19.15.74 (793600/128256), Ethernet0
P 190.19.15.176/28, 1 successors, FD is 39620096
         via 190.19.15.74 (39620096/39594496), Ethernet0
         via 190.19.15.135 (2562688000/128256), Tunnel0
P 190.19.15.128/28, 1 successors, FD is 2562560000
         via Connected, Tunnel0
P 190.19.15.144/28, 1 successors, FD is 128256
         via Connected, Loopback0
P 190.19.15.0/26, 1 successors, FD is 39492096
         via 190.19.15.74 (39492096/39466496), Ethernet0
         via 190.19.15.135 (2563072000/1152000), Tunnel0
P 190.19.15.64/26, 1 successors, FD is 281600
         via Connected, Ethernet0

Steve
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:52 GMT-3