Re: BGP w/loopbacks no statics

From: Dan Pontrelli (dp595@xxxxxxxxxxxxx)
Date: Sun Aug 12 2001 - 16:54:53 GMT-3


   
You can use a policy.
Example:

                     AS1
AS2
1.1.1.1-loop0-R1-S0-172.168.0.1------------------172.168.0.2-S0-R2-loop0-2.2
.2.2

R1 config:

ip local policy route-map relay_to_R2_S0

interface Serial0
ip policy route-map relay_to_R2_S0

router bgp 1
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 update-source loopback 0
neighbor 2.2.2.2 ebgp-multihop 2

access-list 6 permit 2.2.2.2

route-map relay_to_R2_S0 permit 10
 match ip address 6
 set ip next-hop 172.168.0.2

R2 config:

ip local policy route-map relay_to_R1_S0

interface Serial0
ip policy route-map relay_to_R1_S0

router bgp 2
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source loopback 0
neighbor 1.1.1.1 ebgp-multihop 2

access-list 6 permit 1.1.1.1

route-map relay_to_R1_S0 permit 10
 match ip address 6
 set ip next-hop 172.168.0.1

Dan Pontrelli

----- Original Message -----
From: "Shane Miles" <smiles@ftdata.com>
To: <ccielab@groupstudy.com>
Sent: Sunday, August 12, 2001 1:59 PM
Subject: BGP w/loopbacks no statics

> If I want to use loopback addresses in the BGP neighbor commands on
> two routers in different ASs and there is no IGP between them how can I
tell
> the routers how to get to the loopbacks without using static routes?
> --
> Shane P. Miles
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:49 GMT-3