RE: transparent bridging

From: Pickell, Aaryn (Aaryn.Pickell@xxxxxxxxxxxxx)
Date: Thu Jun 14 2001 - 14:19:06 GMT-3


   
I'm not an expert, but here's what I do know.

IRB does not consistantly work with tokenring. I'm not sure why, and I know
that it works sometimes. I would assume that's because the BVI interface is
a virtual ethernet interface, not a virtual token ring, and the router has
to translate from TR to ethernet when linking the two. This is all just
guestimation, though.

ARP and bootp do not work across a translational bridge (token ring to
ethernet). The reason for this is that both of these imbed the layer 2
address in the IP payload. So, while the bit swapping will work
automatically for the actual layer 2 headers, it won't go into the layer 3
payload to change the MAC address there, so the arp cache will be wrong on
the receiving side.

With ARP, you can use the "bridge 1 bitswap-layer3-address" command to fix
it, but bootp will not work. Period. That is to say that DHCP clients
cannot receive an IP address from a DHCP server on the other media type.

As far as your specific situation, I think it's telling that your debug arp
shows the packet arriving on the token ring interface instead of the BVI
interface. I would start by putting the bitswap layer 3 address command on
R4.

Aaryn Pickell - CCNP ATM, CCDP, MCSE
Senior Engineer - Routing Protocols
Getronics Inc.
Direct: 713-394-1609
Email:aaryn.pickell@getronics.com

This e-mail message and any attachments are confidential and may be
privileged. If you are not the intended recipient, please notify me
immediately by replying to this message and please destroy all copies of
this message and attachments. Thank you.

> -----Original Message-----
> From: mcaplan.cs@clearstream.com [mailto:mcaplan.cs@clearstream.com]
> Sent: Thursday, June 14, 2001 11:48 AM
> To: jalcaide@cisco.com; knafie@ncr.com.kw; Pickell, Aaryn;
> ccielab@groupstudy.com
> Subject: RE: transparent bridging
>
>
> Aaryn,
>
> I'de be interested to hear about those caveats you mention. I know
> transparent bridging between TR and Eth must be possible
> because even the
> CCO Bridging and IBM Networking config guide discusses the
> use of OUI in
> converting from TR to Eth in the paragraph about SRT. I am
> trying to do that
> kind of transparent bridging myself in with the following scenario.
>
>
> bvi1=10.1.1.2 bvi=10.1.1.4
> 10.1.1.5
> R2(to0)--------------(to0)R4(s1)-------(s0)R1(e0)-------RHOST
> router acting
> as host
>
> I have got IRB enabled on R2, R4 and R1 and put all BVI
> interfaces into the
> same subnet to test bridging across what I intend to be a
> single broadcast
> domain. I can ping R4 from the RHOST, but not R2. A debug
> shows that the ARP
> request from RHOST actually gets across to R2 ok, but for
> some reason R2
> doesn't enter into the ARP cache, and so the resulting ping
> fails. Here is
> the debug arp failure
>
> *Mar 9 05:30:13.314: IP ARP req filtered src 10.1.1.5
> 0000.0c8d.a396, dst
> 10.1.1.2 0000.0000.0040 wrong cable, interface TokenRing0
> *Mar 9 05:31:13.314: IP ARP req filtered src 10.1.1.5
> 0000.0c8d.a396, dst
> 10.1.1.2 0000.0000.0040 wrong cable, interface TokenRing0
>
> The fact that the ARP request got through shows that bridging
> is working for
> the broadcast, so its not a bit-swap issue. Any help would be
> appreciated.
> See below for configs
>
> Thanks
>
> Mark
>
>
> hostname r2
> !
> bridge irb
> !
> interface TokenRing0
> bridge-group 1
> !
> interface BVI1
> ip address 10.1.1.2 255.255.255.0
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
>
> hostname r4
> !
> bridge irb
> !
> interface Serial1
> bridge-group 1
> !
> interface TokenRing0
> bridge-group 1
> !
> interface BVI1
> ip address 10.1.1.4 255.255.255.0
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
> hostname r1
> no ip routing
> !
> interface Ethernet0/0
> bridge-group 1
> !
> interface Serial0/1
> clockrate 2000000
> bridge-group 1
> !
> bridge 1 protocol ieee
>
> hostname r5
> !
> interface ethernet 0
> ip address 10.1.1.5 255.255.255.0
>
>
>
>
> > ----------
> > From: Pickell, Aaryn[SMTP:Aaryn.Pickell@getronics.com]
> > Reply To: Pickell, Aaryn
> > Sent: Dienstag, 12. Juni 2001 16:59
> > To: 'Juan Alcaide'; Khalid Nafie
> > Cc: Ccielab (E-mail)
> > Subject: RE: transparent bridging
> >
> > You can EVEN do tb between ethernet and token ring, with
> certain caveats.
> >
> > And that's different than translational bridging.
> >
> > Aaryn Pickell - CCNP ATM, CCDP, MCSE
> > Senior Engineer - Routing Protocols
> > Getronics Inc.
> > Direct: 713-394-1609
> > Email:aaryn.pickell@getronics.com
> >
> > This e-mail message and any attachments are confidential and may be
> > privileged. If you are not the intended recipient, please notify me
> > immediately by replying to this message and please destroy
> all copies of
> > this message and attachments. Thank you.
> >
> >
> > > -----Original Message-----
> > > From: Juan Alcaide [mailto:jalcaide@cisco.com]
> > > Sent: Tuesday, June 12, 2001 6:47 AM
> > > To: Khalid Nafie
> > > Cc: Ccielab (E-mail)
> > > Subject: Re: transparent bridging
> > >
> > >
> > > There is no reason why you cannot do it. TB also over FR,
> ATM, etc...
> > >
> > >
> > > -----------------------------------------------------------
> > > Juan Alcaide
> > > Network Consulting Eng. Cisco Systems.
> > > Tel/Fax:1+ (919) 392 7221 Pager 1+800 365 4578
> > > -----------------------------------------------------------
> > >
> > > On Mon, 11 Jun 2001, Khalid Nafie wrote:
> > >
> > > > hi guys,
> > > > I was thinkking all the time that the TB is only for
> > > eathernet, but
> > > > when i went through the documenation CD i found that cisco
> > > is using it for
> > > > both ehternet and tokenring!!!!
> > > > any comment?
> > > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
> Visit us at http://www.clearstream.com
>
> IMPORTANT MESSAGE
>
> Internet communications are not secure and therefore
> Clearstream International does not
> accept legal responsibility for the contents of this message.
>
> The information contained in this e-mail is confidential and
> may be legally privileged. It is
> intended solely for the addressee. If you are not the
> intended recipient, any disclosure,
> copying, distribution or any action taken or omitted to be
> taken in reliance on it, is
> prohibited and may be unlawful. Any views expressed in this
> e-mail are those of the
> individual sender, except where the sender specifically
> states them to be the views of
> Clearstream International or of any of its affiliates or subsidiaries.
>
> END OF DISCLAIMER
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:24 GMT-3