RE: Simple Redistribution question- Configs & Routing Table

From: ElleJf\(Yahoo\) (ellejf@xxxxxxxxx)
Date: Fri Jun 08 2001 - 10:48:05 GMT-3


   
When redistribution, the routes to be redistributed into another protocol is se
lected from "route table", not internal database of that routing protocol. In
 R2's route table, 10.0.0.0/8 is shown as a RIP routes. You need to redistribu
te rip into ospf to have ospf learn that route.

You do redistribute eigrp into ospf, but not redistribute rip into ospf. Altho
ugh EIGRP's topology table will have 10.0.0.0/8 as external route because of re
distribute rip into it, the route 10.0.0.0/8 is not a eigrp route, in route tab
le. Therefore redistrbute eigrp into ospf will not work at R2.

Hope that help!

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of Nathan C
ruz
Sent: Friday, June 08, 2001 1:16 AM
To: ccielab@groupstudy.com
Subject: Simple Redistribution question- Configs & Routing Table

ROUTER 1 CONFIG & ROUTING TABLE

R1#s

Building configuration...

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname R4

!

enable secret 5 $1$kPtv$IsTCOvBiLifnfNt/FIalj/

enable password password

!

ip subnet-zero

ip tcp synwait-time 5

no ip domain-lookup

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

ip address 172.16.1.26 255.255.255.240

clockrate 64000

!

interface Serial1

ip address 15.1.1.1 255.255.255.0

shutdown

!

interface TokenRing0

no ip address

shutdown

!

router ospf 1

network 172.16.1.16 0.0.0.15 area 0

R1#r

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

19.0.0.0/24 is subnetted, 1 subnets

O E2 19.1.1.0 [110/20] via 172.16.1.25, 00:04:16, Serial0

172.16.0.0/28 is subnetted, 1 subnets

C 172.16.1.16 is directly connected, Serial0

ROUTER 2 CONFIG & ROUTING TABLE

R2#s

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R6

!

enable secret 5 $1$WNg7$2SB1xLfQncvxuIMDE9.GX.

enable password password

!

ip subnet-zero

ip tcp synwait-time 5

no ip domain-lookup

!

!

!

!

!

interface Loopback0

ip address 172.16.1.2 255.255.255.240

no ip directed-broadcast

!

interface Loopback1

ip address 172.16.1.85 255.255.255.240

no ip directed-broadcast

!

interface Loopback2

ip address 160.1.2.1 255.255.255.0

no ip directed-broadcast

!

interface Loopback4

ip address 19.1.1.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

ip address 160.1.1.2 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

no fair-queue

clockrate 64000

!

interface Serial1

ip address 172.16.1.25 255.255.255.240

no ip directed-broadcast

!

interface TokenRing0

ip address 20.1.1.1 255.255.255.240

no ip directed-broadcast

ring-speed 16

!

router eigrp 1

redistribute rip

network 19.0.0.0

default-metric 15000 1 150 150 1514

no auto-summary

!

router ospf 1

redistribute eigrp 1 subnets

network 172.16.1.16 0.0.0.15 area 0

!

router rip

network 160.1.0.0

R2#R

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

19.0.0.0/24 is subnetted, 1 subnets

C 19.1.1.0 is directly connected, Loopback4

20.0.0.0/28 is subnetted, 1 subnets

C 20.1.1.0 is directly connected, TokenRing0

172.16.0.0/28 is subnetted, 3 subnets

C 172.16.1.16 is directly connected, Serial1

C 172.16.1.0 is directly connected, Loopback0

C 172.16.1.80 is directly connected, Loopback1

160.1.0.0/24 is subnetted, 2 subnets

C 160.1.1.0 is directly connected, Serial0

C 160.1.2.0 is directly connected, Loopback2

R 10.0.0.0/8 [120/1] via 160.1.1.1, 00:00:14, Serial0

ROUTER 3 CONFIG & ROUTING TABLE

R3#S

Building configuration...

Current configuration:

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname R8

!

enable secret 5 $1$N9H7$SnqmVZ9vJ9GyA1u6XJAcl.

enable password password

!

ip subnet-zero

no ip domain-lookup

ip tcp synwait-time 5

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

!

interface Loopback1

ip address 10.1.2.1 255.255.255.0

!

interface Serial0

ip address 15.1.1.2 255.255.255.0

no fair-queue

clockrate 64000

!

interface Serial1

ip address 160.1.1.1 255.255.255.0

!

interface TokenRing0

no ip address

shutdown

!

router rip

network 10.0.0.0

network 160.1.0.0

R3#R

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is not set

10.0.0.0 255.255.255.0 is subnetted, 2 subnets

C 10.1.2.0 is directly connected, Loopback1

C 10.1.1.0 is directly connected, Loopback0

160.1.0.0 255.255.255.0 is subnetted, 2 subnets

C 160.1.1.0 is directly connected, Serial1

R 160.1.2.0 [120/1] via 160.1.1.2, 00:00:07, Serial1
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:20 GMT-3