Re: HSRP Track Serial interface

From: Jeff K. (jeffbk@xxxxxxxxxxxxx)
Date: Thu Jun 07 2001 - 02:11:16 GMT-3


   
Higher priority, as strange as this sounds, does not mean that router will
always take over. If R1 and R2 are both configured at the same time
(neither has gone past the Speak state), then the one with higher priority
will become active. But, once a router is active, it will not be 'demoted'
to standby by a router with higher priority unless that router is configured
to preempt.

Here is what was happening in your case:

You have the R1 and R2 Ethernet interfaces in a standby group. You brought
up these at the same time or R1 first, so R1 is active. It had a priority
of 100 and R2 was 90. Initially, you had the default track of 10, so when
R1's S0 went down, priority was 90. Easy to see R2 won't go active -- both
are at 90. You switched the track to 20, meaning R1 has a priority of 80
when S0 is down, which is less than R2's 90. R2, however, was not set to
preempt. Basically, this means that R2, with higher priority, stayed
standby. I suppose this is a 'if it's working don't fix it' concept since
all the interfaces in the standby group are technically still up. You need
to tell R2 it is ok to take over in this case (i.e., add the standby preempt
statement). But, even without the preempt on R2, R2 would have taken over
if E0 was down - it would also have done this without the track command if
E0 went down, of course. So, with HSRP the interface will take over if it's
active peer goes down no matter what (assuming they are in the same group,
etc.) OR if the priority of the peer becomes lower AND you tell it to
preempt. Back to your setup -- when R1's S0 is back up, it's priority is
back to 100 (more than R2) AND it is set to preempt so it steals the active
role from R2 (R1 sent a coup message to R2). If you didn't have the preempt
on R1, R2 would remain active when the serial on R1 came back up.

Hopefully this makes sense... Let me know.

-Jeff

----- Original Message -----
From: "Jeongwoo Park" <jpark@wams.com>
To: "'Jeff K.'" <jeffbk@austin.rr.com>; <ccie@groupstudy.com>
Sent: Wednesday, June 06, 2001 11:37 PM
Subject: RE: HSRP Track Serial interface

> Thanks. it work.
> how coudl it happen?
> How come it makes sense that R2 also should have preempt statement?
>
> Thanks jeff
>
> jp
>
> -----Original Message-----
> From: Jeff K. [mailto:jeffbk@austin.rr.com]
> Sent: Wednesday, June 06, 2001 7:52 PM
> To: Jeongwoo Park; Ccielab@Groupstudy. Com
> Subject: Re: HSRP Track Serial interface
>
>
> The default track decrement is 10, so when serial 1 fails on R1, the
> priorities are equal. Since E0 on R1 is still up, there is no reason for
R2
> to take over - but it wouldn't take over anyway (even with a track of 11
or
> more in this case) unless E0 on R1 went down since you don't have the
> preempt statement on R2. Right now, when the R1 serial fails and its
> priority is less, R1 will remain active. This is what the preempt
statement
> does -- it allows the router to immediately take over when it has higher
> priority than the other. Once R1's serial comes back up, it's priority
will
> go back to 100 (as in your config) and the preempt statement you have
> configured already will allow R1 to take over from R2. If you didn't have
> that preempt, R2 would remain active even though R1 had higher priority.
>
> Here is an easy way to test this. Shut the Ethernet interfaces on R1 and
> R2. Configure R2, for example, with a priority of 90 for HSRP. No shut
the
> interface and do a 'sh stand brief' until you see it is active since it is
> the only interface up. Configure R1 for HSRP in the same group with
default
> priority of 100. Do a 'sh stand brief' until it leaves the Speak state
and
> you'll see R1 is standby, R2 active. Do a standby preempt on R1 and it
will
> take over. If you bring both R1 and R2 up before they finish 'Listen' and
> 'Speak,' then the higher priority will be active.
>
> Here is an article on CCO that explains this pretty well:
>
> http://www.cisco.com/warp/public/619/6.html
>
> HTH,
>
> -Jeff
> ----- Original Message -----
> From: "Jeongwoo Park" <jpark@wams.com>
> To: "Ccielab@Groupstudy. Com" <ccielab@groupstudy.com>
> Sent: Wednesday, June 06, 2001 8:39 PM
> Subject: HSRP Track Serial interface
>
>
> > Hi all
> > I configured stand 1 track s0 on router r1.
> > I expected r1 to fail over to r2 when I plugged out dte cable from S0 on
> R1.
> > Didn't work !!!!
> > what is missing in my config?
> >
> >
> > R1-------------ethernet----/R2
> > | /
> > | serial
> > | /
> > |serial /
> > | /
> > | /
> > | /
> > TermServer
> >
> > r1:
> > hostname r1
> > !
> > !
> > no ip domain-lookup
> > !
> > !
> > interface Ethernet0
> > ip address 10.10.1.1 255.255.255.0
> > no ip redirects
> > standby 1 priority 100
> > standby 1 preempt
> > standby 1 ip 10.10.1.3
> > standby 1 track Serial0
> > !
> > interface Serial0
> > ip address 172.16.1.2 255.255.255.0
> > no ip mroute-cache
> > !
> > interface Serial1
> > no ip address
> > shutdown
> > !
> > ip classless
> > !
> > !
> > line con 0
> > line aux 0
> > line vty 0 4
> > login
> > !
> > end
> >
> > --------------------------------------------------------------
> > r2:
> > hostname r2
> > !
> > !
> > ip subnet-zero
> > no ip domain-lookup
> > !
> > !
> > !
> > interface Ethernet0
> > ip address 10.10.1.2 255.255.255.0
> > no ip redirects
> > no ip directed-broadcast
> > standby 1 priority 90
> > standby 1 ip 10.10.1.3
> > !
> > interface Serial0
> > ip address 172.16.2.2 255.255.255.0
> > no ip directed-broadcast
> > no ip mroute-cache
> > !
> > interface Serial1
> > no ip address
> > no ip directed-broadcast
> > shutdown
> > !
> > interface TokenRing0
> > no ip address
> > no ip directed-broadcast
> > shutdown
> > !
> > ip nat translation timeout never
> > ip nat translation tcp-timeout never
> > ip nat translation udp-timeout never
> > ip nat translation finrst-timeout never
> > ip nat translation syn-timeout never
> > ip nat translation dns-timeout never
> > ip nat translation icmp-timeout never
> > ip classless
> > !
> > !
> > line con 0
> > transport input none
> > line aux 0
> > line vty 0 4
> > login
> > !
> > end
> > **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:19 GMT-3